Author Topic: Php version switcher not working  (Read 589 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Php version switcher not working
« on: June 28, 2023, 03:18:57 PM »
Hello there
I have CentOS 8.2 and cwp installed on it too
Everything is working fine but I have to change php version to some new version... The version that is now in the work is php 5.6 and I tried installing 7.x and 8.x versions of php with php switcher but it's not working and I get this in log:
...
config.status: creating config.h

/bin/sh /usr/local/src/libsodium-2.0.23/libtool --mode=compile cc -I. -I/usr/local/src/libsodium-2.0.23 -DPHP_ATOM_INC -I/usr/local/src/libsodium-2.0.23/include -I/usr/local/src/libsodium-2.0.23/main -I/usr/local/src/libsodium-2.0.23 -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib -DHAVE_CONFIG_H -g -O2 -c /usr/local/src/libsodium-2.0.23/libsodium.c -o libsodium.lo

mkdir .libs

cc -I. -I/usr/local/src/libsodium-2.0.23 -DPHP_ATOM_INC -I/usr/local/src/libsodium-2.0.23/include -I/usr/local/src/libsodium-2.0.23/main -I/usr/local/src/libsodium-2.0.23 -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib -DHAVE_CONFIG_H -g -O2 -c /usr/local/src/libsodium-2.0.23/libsodium.c -fPIC -DPIC -o .libs/libsodium.o

/bin/sh /usr/local/src/libsodium-2.0.23/libtool --mode=compile cc -I. -I/usr/local/src/libsodium-2.0.23 -DPHP_ATOM_INC -I/usr/local/src/libsodium-2.0.23/include -I/usr/local/src/libsodium-2.0.23/main -I/usr/local/src/libsodium-2.0.23 -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib -DHAVE_CONFIG_H -g -O2 -c /usr/local/src/libsodium-2.0.23/libsodium.c -o libsodium.lo

cc -I. -I/usr/local/src/libsodium-2.0.23 -DPHP_ATOM_INC -I/usr/local/src/libsodium-2.0.23/include -I/usr/local/src/libsodium-2.0.23/main -I/usr/local/src/libsodium-2.0.23 -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib -DHAVE_CONFIG_H -g -O2 -c /usr/local/src/libsodium-2.0.23/libsodium.c -fPIC -DPIC -o .libs/libsodium.o

What should I do I need new php version plz help me