Author Topic: CWP fails update jumped 3 versions  (Read 2573 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
CWP fails update jumped 3 versions
« on: July 27, 2023, 03:49:49 PM »
Cwp  change log has jumped 3 versions but in our admin panels it fails to update i even ran the update code in ssh but fails.




Offline
****
Re: CWP fails update jumped 3 versions
« Reply #1 on: July 27, 2023, 07:43:49 PM »
Current version is 0.9.8.1160, and there is an update pending today.

Check your firewall, more than likely you are blocking a country the update is coming from.

Offline
*
Re: CWP fails update jumped 3 versions
« Reply #2 on: July 27, 2023, 08:11:32 PM »
Firewall is all good  ;) I been seeing this update for well over 24 hours as of this posting time.

Offline
****
Re: CWP fails update jumped 3 versions
« Reply #3 on: July 27, 2023, 08:23:38 PM »
You'll see the update run when CWP runs it cronjob tonight/early tomorrow morning.

Offline
****
Re: CWP fails update jumped 3 versions
« Reply #4 on: July 27, 2023, 10:10:24 PM »
It's been failing to apply for me, still showing as available (with/without CSF enabled). I'll see if the update applies via cron overnight.

Offline
****
Re: CWP fails update jumped 3 versions
« Reply #5 on: July 27, 2023, 10:22:30 PM »
I just noticed the update notification today.
I'll be keeping on eye on it now tonight.

Offline
*
Re: CWP fails update jumped 3 versions
« Reply #6 on: July 28, 2023, 12:48:58 AM »
Dam it jumped another version  CWP7: 0.9.8.1164

Apache version: Apache/2.4.57 now installs.

Offline
****
Re: CWP fails update jumped 3 versions
« Reply #7 on: July 28, 2023, 12:54:49 AM »
Are you installing beta versions, or stable releases (2 weeks tested)? I'm on the more conservative track.

Offline
****
Re: CWP fails update jumped 3 versions
« Reply #8 on: July 28, 2023, 01:04:43 AM »
Hmm.
According to CWP's changelog they did jump from 0.9.8.1160 to 0.9.8.1164 with today's release date of 2023-07-27.

https://control-webpanel.com/changelog

Offline
*
Re: CWP fails update jumped 3 versions
« Reply #9 on: July 28, 2023, 02:37:22 AM »
Are you installing beta versions, or stable releases (2 weeks tested)? I'm on the more conservative track.

Never use beta the stable as of late dont seem so stable as it used to be so no chance of using beta.

Offline
****
Re: CWP fails update jumped 3 versions
« Reply #10 on: July 28, 2023, 08:49:24 AM »
Yup.
CWP went to 0.9.8.1164 on the Release channel last night.

Has the current versions of PHP in the selectors.

Offline
*
Re: CWP fails update jumped 3 versions
« Reply #11 on: July 28, 2023, 06:34:09 PM »
Looks like they killed mod_security (url_rewrite) also.

Offline
****
Re: CWP fails update jumped 3 versions
« Reply #12 on: July 28, 2023, 07:09:00 PM »
Looks like they killed mod_security (url_rewrite) also.

Weird. None of our servers mod_secuirty configs changed.

Offline
*
Re: CWP fails update jumped 3 versions
« Reply #13 on: July 28, 2023, 07:32:17 PM »
Yeah they killed url_rewrite for phpbb boards.


Offline
****
Re: CWP fails update jumped 3 versions
« Reply #14 on: July 28, 2023, 07:49:12 PM »
That wasn't CWP.
mod_security has nothing to do with that.
And the only way modules are Enabled/Disabled is if you rebuild Apache or change them manually in httpd.conf.

Which again isn't automatically done by CWP.

This looks more like a change when your phpbb updated, since that's the screen you are showing.

If you rebuilt Apache, you'll just have to go into the forementioned httpd.conf and remove the comment tag.