Author Topic: facing errors on CWP installation  (Read 1934 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
facing errors on CWP installation
« on: August 14, 2023, 02:46:30 AM »

Offline
****
Re: facing errors on CWP installation
« Reply #1 on: August 14, 2023, 07:17:05 AM »
OK,

What 'errors' are being displayed?

What distro are you trying to install CWP onto?

VPS or Dedicated?
Specs?

Offline
*
Re: facing errors on CWP installation
« Reply #2 on: August 14, 2023, 04:32:19 PM »
What 'errors' are being displayed?


>>>https://ibb.co/vwp95NQ

----------------------------------------------------------------------------------------------------------------------------------------------

What distro are you trying to install CWP onto?

cd /usr/local/src
wget http://centos-webpanel.com/cwp-el7-latest
sh cwp-el7-latest
----------------------------------------------------------------------------------------------------------------------------------------------

Specs?
>>>> 8GB RAM etc.... enough power n space
« Last Edit: August 14, 2023, 04:35:29 PM by amitksaha »

Offline
****
Re: facing errors on CWP installation
« Reply #3 on: August 14, 2023, 09:06:37 PM »
What disto, aka Operating System are you trying to install CWP on?

And is it a Virtual Server or Dedicated?


That error screenshot shows you don't have enough RAM, it is seeing 512MB or less.


Offline
*
Re: facing errors on CWP installation
« Reply #4 on: August 15, 2023, 05:47:02 AM »
What disto, aka Operating System are you trying to install CWP on?

>>> CentOS 7[/size]And is it a Virtual Server or Dedicated?
>>> Virtual Private ServerThat error screenshot shows you don't have enough RAM, it is seeing 512MB or less.
>>> it is i guess 8GM RAM... but have asked the server team to send me specs, which i shall share in sometime
[/color]

Offline
****
Re: facing errors on CWP installation
« Reply #5 on: August 15, 2023, 03:37:19 PM »
CentOS 7 is depreciated, and some stuff may not be available for a new install.

Try using AlmaLinux 8.x or Rocky Linux 8.x for new installs.

And make sure the VPS has a Minimum of 512GB RAM plus SWAP.

It will also need an IPv4, as CWP doesn't currently install on IPv6 only servers.

Offline
*
Re: facing errors on CWP installation
« Reply #6 on: August 16, 2023, 02:56:09 PM »
CentOS 7 is depreciated, and some stuff may not be available for a new install.
>>> cannot go for CentOS 8 as it's EOL is very near. And Cloud Linux is paid so no for now. We will have to go for CentOS7 for now.[/size]Try using AlmaLinux 8.x or Rocky Linux 8.x for new installs.
>>> cannot go for these options nowAnd make sure the VPS has a Minimum of 512GB RAM plus SWAP.
>>> RAM is 8GB, SWAP is 5GB, CPU is 4 coreIt will also need an IPv4, as CWP doesn't currently install on IPv6 only servers.
>>> yes, IPv4 server

[/color]

Offline
****
Re: facing errors on CWP installation
« Reply #7 on: August 16, 2023, 10:28:26 PM »
CentOS 8 is already dead, thanks to RedHat.

I would recommend, again, AlmaLinux 8.x or Rocky Linux 8.x, both of which are free.

You can also try  to upgrade from CentOS 7 to AlmaLinux using Elevate: https://almalinux.org/elevate/

Offline
**
Re: facing errors on CWP installation
« Reply #8 on: October 24, 2023, 06:42:57 PM »
@starburst

Do you know if Elevating from CWP7 on Centos 7 to Alma 8.8 is working, or does Alma 8 need CWP8?

Have you ever tried to elevate and if yes, is the PHP-selector fixed or PHP-FPM?

As time is running out and this seems to be a working inplace upgrade, it would be good to know if everything is working now.

thanks

Offline
****
Re: facing errors on CWP installation
« Reply #9 on: October 24, 2023, 08:09:06 PM »
Some here have used elevate from CentOS 7 to AlmaLinux 8.

I've only been testing AL 8 to AL 9.

I would advise to create an image as a backup before doing anything.

CWP works on both.

We use AL 8.8 currently, and PHP works fine.

Offline
****
Re: facing errors on CWP installation
« Reply #10 on: November 24, 2023, 06:32:30 PM »
You can NOT redo the CWP installation once done.
If you try CWP will fail giving you an error that it's already been installed.

Best bet in the original situation, was to do a fresh AlmaLinux 8 OS & CWP install using cwp-el8-latest.

Offline
****
Re: facing errors on CWP installation
« Reply #11 on: November 26, 2023, 01:00:34 AM »
CWP does NOT come with an 'uninstall' script. Never has.

It has some install and rebuild scripts in the /scripts directory, but that's about it.

Never was designed to be 'uninstalled'.

Even the Official CWP Wiki states this:
https://wiki.centos-webpanel.com/how-to-uninstall-cwp#:~:text=%2FLicense%20%2FHow%20to%20uninstall%20CWP%20%3F&text=CWP%20has%20no%20uninstaller%2C%20since,had%20it%20before%20cwp%20installation.

Please stop giving out false information @head223a
(Your whole 2 posts ever posted, have both been false.)
« Last Edit: November 26, 2023, 01:04:34 AM by Starburst »

Offline
****
Re: facing errors on CWP installation
« Reply #12 on: November 26, 2023, 04:01:24 AM »
And spammy malware links to top it off...