Author Topic: CWP Pro not activated after changing IP  (Read 1007 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
CWP Pro not activated after changing IP
« on: August 15, 2023, 09:39:17 AM »
Hello everyone,

I'm facing the problem for almost more than a week now and not received support team response yet. Recently I've added a new ip in my cwp server. Added ip by creating a virtual interface for that new ip. So now my server have 2 IPs. After that I changed the IP from cwp admin interface and follows everystep and successfully changed it (From cwp license portal, cwp ip setting and so on). Now everything is working except for the cwp pro version which was activated on my old IP. Although I've changed the ip in the license portal of cwp but 2 weeks passed it still cwp pro not activated on my new ip.

When I check using terminal by running this from my server it shows old IP. https://www.centos-webpanel.com/ip/
I also ran sh /scripts/update_cwp but no luck.

Due to this problem my some websites not working because of multiphp-fpm versions. It'll be helpful if anyone of you have any other suggestions for me or the support can look into this problem.

Offline
*
Re: CWP Pro not activated after changing IP
« Reply #1 on: August 15, 2023, 11:01:31 AM »
I've found that if you do the premium support they jump on it pretty quick

Offline
****
Re: CWP Pro not activated after changing IP
« Reply #2 on: August 15, 2023, 02:39:16 PM »
Did you try temporarily disabling your CSF firewall?
I had a problem like yours 2-3 years ago and a regular support request resolved it in 24 hours. Maybe support lead times have slipped.

(As for the other suggestion, a new pro license to CWP is cheaper than paying for premium support...)

Offline
****
Re: CWP Pro not activated after changing IP
« Reply #3 on: August 15, 2023, 03:43:03 PM »
Your new IP must be your servers Base IP, which is the one CWP reads.

Additional IP's are only shown as that, additional IP's to be assigned to websites.

Just do a simple ifconfig from the CLI, and it will show your servers configured base IP as e.g. eth0 or eth0:0

Then your addon should shows as eth0:1, etc.

(NOTE: eth is only an example, it could start with almost anything)
« Last Edit: August 15, 2023, 03:44:37 PM by Starburst »

Offline
*
Re: CWP Pro not activated after changing IP
« Reply #4 on: August 16, 2023, 05:41:28 AM »
Did you try temporarily disabling your CSF firewall?
I had a problem like yours 2-3 years ago and a regular support request resolved it in 24 hours. Maybe support lead times have slipped.

(As for the other suggestion, a new pro license to CWP is cheaper than paying for premium support...)

I will try to disable CSF and will check again.

Offline
*
Re: CWP Pro not activated after changing IP
« Reply #5 on: August 16, 2023, 05:50:10 AM »
Your new IP must be your servers Base IP, which is the one CWP reads.

Additional IP's are only shown as that, additional IP's to be assigned to websites.

Just do a simple ifconfig from the CLI, and it will show your servers configured base IP as e.g. eth0 or eth0:0

Then your addon should shows as eth0:1, etc.

(NOTE: eth is only an example, it could start with almost anything)

Yes. My base IP is the old one. Which represents interface enp0s4 and the new IP which I wanted is added on virtual interface like enp0s4:0 (I created this manually). Another thing is my base interface is dhcp and the virtual one enp0s4:0 is static. I got my server f rom hetzner. When the first time I added my additional IP on the base interface as a static IP it worked but after reboot my interface was automatically removed and network was boom. So thats why I added a virtual interface like enp0s4:0. Do you have any idea what can I do to add my new ip on my base interface and old ip on the virtual interface? and also like before, will it again remove my interfaces on reboot.

Offline
****
Re: CWP Pro not activated after changing IP
« Reply #6 on: August 16, 2023, 10:24:37 PM »
Well that explains why it's not updating.

Your enp0s4 needs to be your new IP you want to license to, and should be a static IP.

Again, the CWP license it tied Only to the Base IP.
It doesn't care about any other configured IP's on the server.