Author Topic: CWP falling behind with PHP. Again.  (Read 810 times)

0 Members and 1 Guest are viewing this topic.

Online
****
CWP falling behind with PHP. Again.
« on: September 12, 2023, 07:29:56 AM »
PHP 8.1.23 and 8.2.10 both came out on 2023-08-31
Along with 8.3.0 RC1

CWP release 0.9.8.1169 & .1170 since then, and neither update has had any PHP updates.

ionCube 13.0.2 was just released this point version today (2023-09-11) also.

Online
****
Re: CWP falling behind with PHP. Again.
« Reply #1 on: September 12, 2023, 08:36:56 PM »
I remember the glory days of living with a PHP point release for years (I just got one client off of 5.6, finally) now it feels as if the snowball down the mountain is gathering avalanche-levels of momentum...

Online
****
Re: CWP falling behind with PHP. Again.
« Reply #2 on: October 06, 2023, 06:40:13 PM »
Yup.

CWP is 3 versions behind now, the worst so far.
They broke their record of being 2 versions behind.

Online
****
Re: CWP falling behind with PHP. Again.
« Reply #3 on: November 21, 2023, 06:47:54 AM »
PHP 8.1.25 & 8.2.12 have been out since 2023-10-26

CWP has fallen a behind again. :(

Online
****
Re: CWP falling behind with PHP. Again.
« Reply #4 on: November 23, 2023, 05:46:09 PM »
Well, it's happened.

PHP 8.3.0 has been released today on 2023-11-23.

Along with PHP 8.2.13.

Online
****
Re: CWP falling behind with PHP. Again.
« Reply #5 on: November 24, 2023, 02:20:21 AM »
But does much of anything require 8.3? For instance, Drupal requires 8.1, 8.1.6 recommended...

Online
****
Re: CWP falling behind with PHP. Again.
« Reply #6 on: November 24, 2023, 02:26:25 AM »
ionCube doesn't support 8.3.x yet either.

More of a FYI on that 8.3 has been released.

But PHP 8.1.x is 1 version behind, and PHP 8.2 is now 2 versions behind.

Online
****
Re: CWP falling behind with PHP. Again.
« Reply #7 on: November 27, 2023, 04:29:53 AM »
Woo hoo. The new version of CWP 0.9.8.1172 has all the current (as of 2023-11-26) versions of PHP.

Including 8.3.0

Just remember, that ionCube doesn't support 8.3.0 as of the date above.

Online
****
Re: CWP falling behind with PHP. Again.
« Reply #8 on: November 27, 2023, 06:09:44 PM »
Saw that. Gives you some hope that somehow, someway the devs are actually watching the forum and take into account user priorities. So I'll put out the urge: EL9 support should be TOP priority, so those of us with CentOS 7 servers can migrate next spring before the apocalyptic EOL comes upon us!