Author Topic: CWP can't compile php-fpm 8.2  (Read 844 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
CWP can't compile php-fpm 8.2
« on: October 17, 2023, 10:24:54 AM »
8.1 work ok. at 8.2 i get all time error logs that all .so ale unaivailable or similar
Almalinux 8.8, installed all updates - i guest that most of them should be the same as 8.1

errors whcih  i found:
at end:
"Error: Can't add notification!" what is mean ?

in compiling:
"shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
chdir: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory"
what folder ? why it not create it then ? i compile new php version. - it has no folders so why it except that it exist instead create it ?


"
configure: error: Cannot find libpq-fe.h. Please specify correct PostgreSQL installation path

make: *** No targets specified and no makefile found. Stop.

make: *** No rule to make target 'install'. Stop.

"
 - I doesnt change defaul postgresql installation path...


"
Error: Unable to find a match: compat-openldap openldap-servers-sql
"

at 8.1 the same modules not have problem - i guest it should be the same...


turn off all modules also not compile php (fpm) 8.2....
i am still looking for logs which could say what happening, why it doesnt work.

Internet and dns works ok.

 I liked cwp but there is much problems with it. it often and often not work out of box or update destroy something and stop completly work sometimes makes is less and less ready to use...

And all time i get info that i need pay to get help but it should work i never did anything to broke it.

Offline
*
Re: CWP can't compile php-fpm 8.2
« Reply #1 on: November 08, 2023, 12:00:16 PM »
Managing compile options for Your PHP version. In my case nano /usr/local/cwpsrv/htdocs/resources/conf/el8/php-fpm_selector/8.2_last_build.ini and find the following part
Code: [Select]
[pgsql]
default="0"
option="--with-pgsql=/usr/pgsql-16/bin"
info-file="pgsql.txt"
[pdo-pgsql]
default="0"
option="--with-pdo-pgsql=/usr/pgsql-16/bin"
info-file="pdo-pgsql.txt"

Edit and set the postgresql bin path for options --with-pgsql and --with-pdo-pgsql. In my case the postgresql bin path was /usr/pgsql-16/bin.

Code: [Select]
[pgsql]
default="1"
option="--with-pgsql=/usr/pgsql-16/bin"
info-file="pgsql.txt"
[pdo-pgsql]
default="1"
option="--with-pdo-pgsql=/usr/pgsql-16/bin"
info-file="pdo-pgsql.txt"

You can also edit this file from CWP panel too.

Now You will be able to compile PHP from source code.

Additionally you can find your postgresql bin dir with the command pg_config --bindir

Offline
*
Re: CWP can't compile php-fpm 8.2
« Reply #2 on: November 08, 2023, 04:45:15 PM »
Thank you.
It is not exactly repair all what happen just running cwp which autopdate and addding accounts and sites, and update time to time from cwp panel - nothing more, but I found cause of problems: much of packets are outdated:
eg. MariaDB was 10.4 and it couldnt work with php8.2 (at 8.1 work).
PQSQL is 14 etc...
 
Quote
You can also edit this file from CWP panel too
Panel stopped work i got 404 Error - not found, nothing from old threads help, so  for me best will be wait for CWP EL 9 and install it from 0, or mayby after i update all what is need magically it start work...
User panels work normally.
I don't have problem check actual pqsql version and folders, but command not work.


Another problem is some configs eg.
/etc/yum.repos.d/mariadb.repo
had:
Code: [Select]
baseurl = http://yum.mariadb.org/11/centos8-amd64
But there not was centos8 only RHEL8
I don't have Centos8, Its Almalinux8
« Last Edit: November 08, 2023, 04:58:33 PM by skyref »