Author Topic: php-fpm83 not installing well / working  (Read 1167 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
php-fpm83 not installing well / working
« on: January 29, 2024, 09:46:25 PM »
I have tried installing php-fpm83 about 10 times . i did 2 times a new setup of my bare metal server. i downloaded and have used the latest 8 stream version ( Kernel: Linux 4.18.0-535.el8.x86_64) and the version before that. no matt what i do, i can not get 8,3 installed working. during install i get multiple errors. can not find can not make. I installed while firewall was disabled as i found out that a rule in my firewall ( ip that tried to gain access and was automatic banned, but no idea wich) was blocking access to the repositories. so that cant be the issue either.

Im honestly a bit done with CWP. i have so many little issues that not getting solved.... and i after 10 times reinstalling im a bit done honestly.

anyone any clue what i can do ?

i will paste some messages from the cli
this is the last part of the installation with errors.

Code: [Select]
Package libsodium-devel-1.0.18-2.el8.x86_64 is already installed.
Dependencies resolved.
Nothing to do.
Complete!
chdir: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100 28505  100 28505    0     0  51360      0 --:--:-- --:--:-- --:--:-- 51360
/usr/local/cwpsrv/htdocs/resources/conf/el8/php-fpm_selector/external_modules/8.3/sodium.sh: line 9: /opt/alt/php-fpm83/usr/bin/phpize: No such file or directory
/usr/local/cwpsrv/htdocs/resources/conf/el8/php-fpm_selector/external_modules/8.3/sodium.sh: line 10: ./configure: No such file or directory
make: *** No targets specified and no makefile found.  Stop.
make: *** No rule to make target 'install'.  Stop.
/usr/local/cwpsrv/htdocs/resources/conf/el8/php-fpm_selector/external_modules/8.3/sodium.sh: line 14: /opt/alt/php-fpm83/usr/bin/php-config: No such file or directory
ERROR: Missing extension file /sodium.so

Build Completed
###################


Notification added
this is the result when i do a " systemctl status php-fpm83 "
Code: [Select]
]# systemctl status php-fpm83
● php-fpm83.service - The PHP FastCGI Process Manager
   Loaded: loaded (/usr/lib/systemd/system/php-fpm83.service; enabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Mon 2024-01-29 22:20:55 CET; 7min ago
  Process: 554732 ExecStart=/opt/alt/php-fpm83/usr/sbin/php-fpm --nodaemonize --fpm-config /opt/alt/php-fpm83/usr/etc/php-fpm.conf (code=exited, status=203/EXEC)
 Main PID: 554732 (code=exited, status=203/EXEC)

Jan 29 22:20:55 stdwwwsrv001.standerhosting.nl systemd[1]: Started The PHP FastCGI Process Manager.
Jan 29 22:20:55 stdwwwsrv001.standerhosting.nl systemd[1]: php-fpm83.service: Main process exited, code=exited, status=203/EXEC
Jan 29 22:20:55 stdwwwsrv001.standerhosting.nl systemd[1]: php-fpm83.service: Failed with result 'exit-code'.

when i do a "ls /opt/alt/php-fpm83/usr/lib/php/extensions"
This is the output
Code: [Select]
ls: cannot access '/opt/alt/php-fpm83/usr/lib/php/extensions': No such file or directory
When i do "systemctl | grep php "
This is the output
Code: [Select]
cwp-phpfpm.service                                                                               loaded active running   The PHP FastCGI Process Manager
  cwpsrv-phpfpm.service                                                                            loaded active running   The PHP FastCGI Process Manager
  php-fpm53.service                                                                                loaded active running   The PHP FastCGI Process Manager
  php-fpm72.service                                                                                loaded active running   The PHP FastCGI Process Manager
  php-fpm82.service                                                                                loaded active running   The PHP FastCGI Process Manager
● php-fpm83.service                                                                                loaded failed failed    The PHP FastCGI Process Manager

I have tried to install with the basic settings. turned off ioncube, and still same.
I have zipped and uploaded the complete php-selector-rebuild.log
https://gofile.io/d/5rzfxS
Hope someone can figure out whats wrong,
So im serious in need of help / assistance.
« Last Edit: January 29, 2024, 10:27:11 PM by Dutch_Mike »


Offline
*
Re: php-fpm83 not installing well / working
« Reply #2 on: January 30, 2024, 10:22:57 PM »
I followed the instructions but its still not working,

lets hope this is working. i cant copy paste the output as a code. the forum doesnt allow. It would come in handy when the forom mods would make a list of what kind of words or codes are not allowed, instead of letting payin customers floating around in the dark when they get a "no permission. not allowed to..... "

i really get the sh i ts of this i can even post a link to a screenshot. im getting frustrated as f*** wit this amateurisic hassle...

after 3 years of hassles and a lot of missery i think its time to move on to another panel thats working better. this is no fun anymore.
« Last Edit: January 30, 2024, 10:35:01 PM by Dutch_Mike »

Offline
****
Re: php-fpm83 not installing well / working
« Reply #3 on: January 30, 2024, 11:52:11 PM »
Funny, I had the opposite experience: 3 years ago some early bugs & troubles, esp. in migrating cPanel sites. But then after those early hiccups, it's largely been smooth sailing and once past the initial learning curve, you can lean on the stable CentOS foundation and ride mostly smoothly.

Offline
****
Re: php-fpm83 not installing well / working
« Reply #4 on: January 31, 2024, 09:38:14 AM »
New PHP version are bound to have issues.

Most panels don't even have PHP 8.3 integrated yet.
Some just added 8.2 finally.

ionCube doesn't offer 8.3.x support yet either. So in turn developers can't offer it.

The instructions at AlphaGNU are for PHP-CGI if you really need to run 8.3.x on the whole system with ionCube.

Offline
*
Re: php-fpm83 not installing well / working
« Reply #5 on: January 31, 2024, 01:18:15 PM »
as i wrote i turned off ioncube.
the instructions at sandeeps site not work either.
still can install

i did setup a vm with fresh installed centos 8 stream followed sandeeps video onstruction how to prepare and installed cwp. after installation and  fisnished the initial settings i went to the php version switcher and tried to install 8.3.1. i the only optional setting i changed was turning off ioncube... and saved and installed...

guess what... its still not installing. infact... instead of going through the whole installing cyclus... half way it just stalled. i left it overnight.. and when i just got back it still at the same point.

i understand new versions comes with hassles and kids desease.... but this ?

Offline
****
Re: php-fpm83 not installing well / working
« Reply #6 on: January 31, 2024, 10:54:39 PM »
They are looking into it, so hopefully we will have a solution soon.

Offline
****
Re: php-fpm83 not installing well / working
« Reply #7 on: February 02, 2024, 01:05:08 AM »
@Dutch_Mike

Thanks to Sandeep.

There is a work around until the next release, to build without the mbstring option.

Tested it with PHP-FPM 8.3.1, and it compiled OK without the ioncube & mbstring options, and is running.




Of course, if you need ionCube and/or mbstring, then you will have to use PHP-FPM 8.2.x

Offline
*
Re: php-fpm83 not installing well / working
« Reply #8 on: February 02, 2024, 08:50:34 PM »
Great, thanks Sandeep and Starbust.

I did setup a vm cwp server. going to test it first there. easy to get a clean cwp setup everyt time that way, so i can be sure it its just not in my  production server .
And no, i dont need those 2 options.

Offline
*
Re: php-fpm83 not installing well / working
« Reply #9 on: February 03, 2024, 08:15:30 PM »
well i have no clue what or how you did it....
but on my clean fresh installed cwp with no additional programs installed i tried to install the 8.3.1 php from the version switcher....
but no luck

first i turned the options off like  mbstrings, as by default thats turned on. ioncube was already off. i turned on sourcegardian and upload progress, but it kept hang on both. after few times the fresh vm put back i tried to install it without any options... then it hanged on  sodium, thats turned on by deault too, so i turned that off too.
then only had memcached on, that one went ok but it kept hang on php

see code.
Code: [Select]
Installed:
  memcached-1.5.22-2.el8.x86_64

Complete!
Configuring for:
PHP Api Version:         20131106
Zend Module Api No:      20131226
Zend Extension Api No:   220131226
checking for grep that handles long lines and -e... /usr/bin/grep
checking for egrep... /usr/bin/grep -E
checking for a sed that does not truncate output... /usr/bin/sed
checking for cc... cc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether cc accepts -g... yes
checking for cc option to accept ISO C89... none needed
checking how to run the C preprocessor... cc -E
checking for icc... no
checking for suncc... no
checking whether cc understands -c and -o together... yes
checking for system library directory... lib
checking if compiler supports -R... no
checking if compiler supports -Wl,-rpath,... yes
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking target system type... x86_64-unknown-linux-gnu
checking for PHP prefix... /usr/local
checking for PHP includes... -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib
checking for PHP extension directory... /usr/local/lib/php/extensions/no-debug-non-zts-20131226
checking for PHP installed headers prefix... /usr/local/include/php
checking if debug is enabled... no
checking if zts is enabled... no
checking for re2c... no
checking for gawk... gawk
checking whether to enable memcache support... yes, shared
checking whether to enable memcache session handler support... yes
checking for the location of ZLIB... no
checking for the location of zlib... /usr
checking PHP version...

i left it hang there for 2 hours but still no go.

maybe better remove the button 8.3.1 untill it function as a normal WORKING install because this makes no sensen

Offline
****
Re: php-fpm83 not installing well / working
« Reply #10 on: February 04, 2024, 05:42:56 PM »
Stating the obvious, but what does the dangling fruit of php 8.3 offer you that 8.2 won't cover for the immediate future? I don't find it worth the effort, and my clients don't need it with little CMS software optimized for it currently. I don't plan to even look at it for another 6 months.