Author Topic: Can't install PHP 3.1  (Read 445 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Can't install PHP 3.1
« on: February 03, 2024, 05:41:40 PM »
I cannot install PHP 3.1 below is a partial log

/usr/bin/ld: dynamic STT_GNU_IFUNC symbol `mb_utf16be_to_wchar' with pointer equality in `ext/mbstring/libmbfl/filters/mbfilter_utf16.o' can not be used when making an executable; recompile with -fPIE and relink with -pie

collect2: error: ld returned 1 exit status

make: *** [Makefile:314: sapi/cli/php] Error 1

shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory

shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory

Skipping as php build failed

shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory

shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory

Skipping as php build failed

shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory

Skipping as php build failed

shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory

varnishcache_varnish64 3.5 kB/s | 1.0 kB 00:00

varnishcache_varnish64-source 1.8 kB/s | 951 B 00:00

Package libsodium-1.0.18-2.el8.x86_64 is already installed.

Package libsodium-devel-1.0.18-2.el8.x86_64 is already installed.

Dependencies resolved.

Nothing to do.

Complete!

chdir: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory

% Total % Received % Xferd Average Speed Time Time Time Current

Dload Upload Total Spent Left Speed

0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0 100 28505 100 28505 0 0 72902 0 --:--:-- --:--:-- --:--:-- 72902

/usr/local/cwpsrv/htdocs/resources/conf/el8/php-fpm_selector/external_modules/8.3/sodium.sh: line 9: /opt/alt/php-fpm83/usr/bin/phpize: No such file or directory

/usr/local/cwpsrv/htdocs/resources/conf/el8/php-fpm_selector/external_modules/8.3/sodium.sh: line 10: ./configure: No such file or directory

make: *** No targets specified and no makefile found. Stop.

make: *** No rule to make target 'install'. Stop.

/usr/local/cwpsrv/htdocs/resources/conf/el8/php-fpm_selector/external_modules/8.3/sodium.sh: line 14: /opt/alt/php-fpm83/usr/bin/php-config: No such file or directory

ERROR: Missing extension file /sodium.so

exe:/opt/alt/php-fpm83/usr/sbin/php-fpm

Build Completed

###################

Notification added

Offline
****
Re: Can't install PHP 3.1
« Reply #1 on: February 04, 2024, 05:45:02 PM »
See other threads on this topic. Starburst was able to get it to build by disabling mbstring and IonCube:
https://forum.centos-webpanel.com/index.php?topic=13337.msg46538#msg46538

Offline
****
Re: Can't install PHP 3.1
« Reply #2 on: February 04, 2024, 06:37:56 PM »
When I first saw PHP 3.1, and was  :o

@overseers is correct.
ionCube doesn't support PHP 8.3.x, and there seems to be a bug with mbstring.

If you build PHP-FPM 8.3.x without those 2 options you will be good to go.

IF you need the mbstring option for something, then you will have to stay with 8.2.x temporarily.