Author Topic: NodeJS issue  (Read 1003 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
NodeJS issue
« on: February 10, 2024, 12:05:16 PM »
Hi All,

Installed NodeJS 20.11.0 and tried to set it up for one of the user profiles and keep getting an issue.

When I go to the Node.js Manager, I get the add new application now. When the general settings come up, I select the user account and the NodeJS Version says First install of NodeJS version. I select it and the configuration comes up. I select the version and install. Once completed, it shows None NodeJS version installed!

Offline
****
Re: NodeJS issue
« Reply #1 on: February 10, 2024, 01:51:39 PM »
What OS & version are you running?

Offline
*
Re: NodeJS issue
« Reply #2 on: February 11, 2024, 11:30:41 AM »
Running Centos Steam 8. Trying to put in NodeJS 20.

Offline
*
Re: NodeJS issue
« Reply #3 on: February 16, 2024, 10:57:48 AM »
Anyone?
« Last Edit: February 16, 2024, 11:07:46 AM by daowen »

Offline
****
Re: NodeJS issue
« Reply #4 on: February 16, 2024, 02:20:10 PM »
My only suggestion would be to get off of CentOS Stream and migrate to AlmaLinux 8. A rolling release is not a good foundation for a server! (CWP only listed support for it initially because it was the only game in town, but now we have Rocky & Alma for EL8 releases that have LTS, with upgrade paths to EL9 when CWP supports it).

Offline
*
Re: NodeJS issue
« Reply #5 on: February 16, 2024, 02:53:38 PM »
Thanks for the suggestion. It's just, the EL8 and rocky have the following warning:

Compatible but with possible issues, Recommended is to use CentOS 8 Stream or CentOS 7

Why would the suggestion be to use CentOS 8 Stream? This is causing confusion and hesitation.

Offline
****
Re: NodeJS issue
« Reply #6 on: February 16, 2024, 11:00:58 PM »
Currently AlmaLinux 8.x is the recommended OS for CWP currently.

Like with many things, the website needs to be updated.

Offline
*
Re: NodeJS issue
« Reply #7 on: February 17, 2024, 12:44:03 PM »
Okay, so I installed Alma Linux and still running into the issue.

More information.

Installed the NodeJS manager and have "None application created" when going to the list. I select the Configurations and install the node version 20.11.1 LTS and get the message that it was successful. I rebooted the server just for my want to be thorough.

The mod_nodejs still shows None NodeJS verison installed, which is an issue for that was selected prior.

Getting a little frustrated with this issue.

Offline
****
Re: NodeJS issue
« Reply #8 on: February 17, 2024, 06:44:42 PM »
Then the only thing I could suggest is to open a support ticket directly with CWP, and let them login and take a look.

Offline
*
Re: NodeJS issue
« Reply #9 on: March 20, 2024, 12:28:20 PM »
If you still encounter this issue. Maybe you can try to install the NodeJS manually (not from the CWP GUI). I use AlmaLinux 8, I have set up my NodeJS 20.x and it works well.