Author Topic: Centos 8 fresh install IP tables issue  (Read 1338 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Centos 8 fresh install IP tables issue
« on: February 26, 2024, 01:07:25 PM »
I'm trying to turn on firewall but that is not working

Code: [Select]
Status: csf and lfd have been disabled, use 'csf -e' to enable
I checked the forms and looks like
Code: [Select]
iptables is not installed in the Fresh Installation. Then I installed iptables

Now, when I enable the firewall CWP stop responding and my sites start giving me 500 error. I did disabled using
Code: [Select]
csf -x which bring back the sites and CWP up.

How can I make this up. I had a server from 5 years back and it is now starting to act so doing a fresh clean install on different machine and migrating the content to new one.

Offline
****
Re: Centos 8 fresh install IP tables issue
« Reply #1 on: February 26, 2024, 02:36:29 PM »
If you're starting fresh, please start with AlmaLinux 8. CentOS Stream even with delayed repos is not a viable foundation for a server.

Offline
*
Re: Centos 8 fresh install IP tables issue
« Reply #2 on: February 26, 2024, 03:10:51 PM »
following installation script, as soon as i run

Code: [Select]
yum -y update
I got these errors and I lost my interest in this one

Code: [Select]
Total                                                                                                                                                          31 MB/s | 542 MB     00:17     
AlmaLinux 8 - BaseOS                                                                                                                                          3.3 MB/s | 3.4 kB     00:00   
Importing GPG key 0xC21AD6EA:
 Userid     : "AlmaLinux <packager@almalinux.org>"
 Fingerprint: E53C F5EF 91CE B0AD 1812 ECB8 51D6 647E C21A D6EA
 From       : /etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Key imported successfully
Import of key(s) didn't help, wrong key(s)?
AlmaLinux 8 - AppStream                                                                                                                                       3.3 MB/s | 3.4 kB     00:00   
Importing GPG key 0xC21AD6EA:
 Userid     : "AlmaLinux <packager@almalinux.org>"
 Fingerprint: E53C F5EF 91CE B0AD 1812 ECB8 51D6 647E C21A D6EA
 From       : /etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Key imported successfully
Import of key(s) didn't help, wrong key(s)?
Public key for kernel-4.18.0-513.18.1.el8_9.x86_64.rpm is not installed. Failing package is: kernel-4.18.0-513.18.1.el8_9.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for kernel-core-4.18.0-513.18.1.el8_9.x86_64.rpm is not installed. Failing package is: kernel-core-4.18.0-513.18.1.el8_9.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for kernel-modules-4.18.0-513.18.1.el8_9.x86_64.rpm is not installed. Failing package is: kernel-modules-4.18.0-513.18.1.el8_9.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for linux-firmware-20230824-120.git0e048b06.el8_9.noarch.rpm is not installed. Failing package is: linux-firmware-20230824-120.git0e048b06.el8_9.noarch
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for NetworkManager-1.40.16-13.el8_9.alma.1.x86_64.rpm is not installed. Failing package is: NetworkManager-1:1.40.16-13.el8_9.alma.1.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for NetworkManager-libnm-1.40.16-13.el8_9.alma.1.x86_64.rpm is not installed. Failing package is: NetworkManager-libnm-1:1.40.16-13.el8_9.alma.1.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for NetworkManager-team-1.40.16-13.el8_9.alma.1.x86_64.rpm is not installed. Failing package is: NetworkManager-team-1:1.40.16-13.el8_9.alma.1.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for NetworkManager-tui-1.40.16-13.el8_9.alma.1.x86_64.rpm is not installed. Failing package is: NetworkManager-tui-1:1.40.16-13.el8_9.alma.1.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for glibc-2.28-236.el8_9.12.x86_64.rpm is not installed. Failing package is: glibc-2.28-236.el8_9.12.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for glibc-common-2.28-236.el8_9.12.x86_64.rpm is not installed. Failing package is: glibc-common-2.28-236.el8_9.12.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for glibc-gconv-extra-2.28-236.el8_9.12.x86_64.rpm is not installed. Failing package is: glibc-gconv-extra-2.28-236.el8_9.12.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for glibc-langpack-en-2.28-236.el8_9.12.x86_64.rpm is not installed. Failing package is: glibc-langpack-en-2.28-236.el8_9.12.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for gnutls-3.6.16-8.el8_9.1.x86_64.rpm is not installed. Failing package is: gnutls-3.6.16-8.el8_9.1.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for kernel-tools-4.18.0-513.18.1.el8_9.x86_64.rpm is not installed. Failing package is: kernel-tools-4.18.0-513.18.1.el8_9.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for kernel-tools-libs-4.18.0-513.18.1.el8_9.x86_64.rpm is not installed. Failing package is: kernel-tools-libs-4.18.0-513.18.1.el8_9.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for libssh-0.9.6-13.el8_9.x86_64.rpm is not installed. Failing package is: libssh-0.9.6-13.el8_9.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for libssh-config-0.9.6-13.el8_9.noarch.rpm is not installed. Failing package is: libssh-config-0.9.6-13.el8_9.noarch
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for libsss_autofs-2.9.1-4.el8_9.5.alma.1.x86_64.rpm is not installed. Failing package is: libsss_autofs-2.9.1-4.el8_9.5.alma.1.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for libsss_certmap-2.9.1-4.el8_9.5.alma.1.x86_64.rpm is not installed. Failing package is: libsss_certmap-2.9.1-4.el8_9.5.alma.1.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for libsss_idmap-2.9.1-4.el8_9.5.alma.1.x86_64.rpm is not installed. Failing package is: libsss_idmap-2.9.1-4.el8_9.5.alma.1.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for libsss_nss_idmap-2.9.1-4.el8_9.5.alma.1.x86_64.rpm is not installed. Failing package is: libsss_nss_idmap-2.9.1-4.el8_9.5.alma.1.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for libsss_sudo-2.9.1-4.el8_9.5.alma.1.x86_64.rpm is not installed. Failing package is: libsss_sudo-2.9.1-4.el8_9.5.alma.1.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for openssh-8.0p1-19.el8_9.2.x86_64.rpm is not installed. Failing package is: openssh-8.0p1-19.el8_9.2.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for openssh-clients-8.0p1-19.el8_9.2.x86_64.rpm is not installed. Failing package is: openssh-clients-8.0p1-19.el8_9.2.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for openssh-server-8.0p1-19.el8_9.2.x86_64.rpm is not installed. Failing package is: openssh-server-8.0p1-19.el8_9.2.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for platform-python-3.6.8-56.el8_9.3.alma.1.x86_64.rpm is not installed. Failing package is: platform-python-3.6.8-56.el8_9.3.alma.1.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for python3-libs-3.6.8-56.el8_9.3.alma.1.x86_64.rpm is not installed. Failing package is: python3-libs-3.6.8-56.el8_9.3.alma.1.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for python3-perf-4.18.0-513.18.1.el8_9.x86_64.rpm is not installed. Failing package is: python3-perf-4.18.0-513.18.1.el8_9.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for python3-rpm-4.14.3-28.el8_9.x86_64.rpm is not installed. Failing package is: python3-rpm-4.14.3-28.el8_9.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for python3-urllib3-1.24.2-5.el8_9.2.noarch.rpm is not installed. Failing package is: python3-urllib3-1.24.2-5.el8_9.2.noarch
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for rpm-4.14.3-28.el8_9.x86_64.rpm is not installed. Failing package is: rpm-4.14.3-28.el8_9.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for rpm-build-libs-4.14.3-28.el8_9.x86_64.rpm is not installed. Failing package is: rpm-build-libs-4.14.3-28.el8_9.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for rpm-libs-4.14.3-28.el8_9.x86_64.rpm is not installed. Failing package is: rpm-libs-4.14.3-28.el8_9.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for rpm-plugin-selinux-4.14.3-28.el8_9.x86_64.rpm is not installed. Failing package is: rpm-plugin-selinux-4.14.3-28.el8_9.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for rpm-plugin-systemd-inhibit-4.14.3-28.el8_9.x86_64.rpm is not installed. Failing package is: rpm-plugin-systemd-inhibit-4.14.3-28.el8_9.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for sos-4.6.1-1.el8.alma.1.noarch.rpm is not installed. Failing package is: sos-4.6.1-1.el8.alma.1.noarch
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for sqlite-libs-3.26.0-19.el8_9.x86_64.rpm is not installed. Failing package is: sqlite-libs-3.26.0-19.el8_9.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for sssd-client-2.9.1-4.el8_9.5.alma.1.x86_64.rpm is not installed. Failing package is: sssd-client-2.9.1-4.el8_9.5.alma.1.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for sssd-common-2.9.1-4.el8_9.5.alma.1.x86_64.rpm is not installed. Failing package is: sssd-common-2.9.1-4.el8_9.5.alma.1.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for sssd-kcm-2.9.1-4.el8_9.5.alma.1.x86_64.rpm is not installed. Failing package is: sssd-kcm-2.9.1-4.el8_9.5.alma.1.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for sssd-nfs-idmap-2.9.1-4.el8_9.5.alma.1.x86_64.rpm is not installed. Failing package is: sssd-nfs-idmap-2.9.1-4.el8_9.5.alma.1.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for sudo-1.9.5p2-1.el8_9.x86_64.rpm is not installed. Failing package is: sudo-1.9.5p2-1.el8_9.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for tzdata-2024a-1.el8.noarch.rpm is not installed. Failing package is: tzdata-2024a-1.el8.noarch
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for cloud-init-23.1.1-11.el8_9.1.alma.1.noarch.rpm is not installed. Failing package is: cloud-init-23.1.1-11.el8_9.1.alma.1.noarch
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for libmaxminddb-1.2.0-10.el8_9.1.x86_64.rpm is not installed. Failing package is: libmaxminddb-1.2.0-10.el8_9.1.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for qemu-guest-agent-6.2.0-40.module_el8.9.0+3714+46544554.2.x86_64.rpm is not installed. Failing package is: qemu-guest-agent-15:6.2.0-40.module_el8.9.0+3714+46544554.2.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for tcpdump-4.9.3-3.el8_9.1.alma.1.x86_64.rpm is not installed. Failing package is: tcpdump-14:4.9.3-3.el8_9.1.alma.1.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'yum clean packages'.
Error: GPG check FAILED

I also had tried the Rocky one, there were no errors. but the issue was same with iptables. I couldnt enable them

Offline
****
Re: Centos 8 fresh install IP tables issue
« Reply #3 on: February 26, 2024, 04:25:04 PM »
On a Fresh install of AlmaLinux 8, here are the first step you Need to do:

Run the following:

Code: [Select]
rpm --import https://repo.almalinux.org/almalinux/RPM-GPG-KEY-AlmaLinux

dnf update ca-certificates

dnf install dnf-plugins-core

dnf config-manager --set-enabled powertools

dnf install elrepo-release epel-release -y

/usr/bin/crb enable

dnf install nano wget ipset ebtables iptables uuid uuid-devel libuuid-devel m4 pcre pcre-devel zlib-devel perl-DBD-MySQL perl-IPC-Cmd perl-Pod-Html libtool s-nail -y

dnf --refresh update

Set timezime with:
Code: [Select]
timedatectl set-timezone (your timezone here)
timedatectl set-local-rtc 0

Disable SELinux

Config Hostname & Hosts file


Then proceed to install CWP.

After installing CWP, upgrade MariaDB to latest LTS 10.11 following CWP Tutorial.

Config CSF, and start.


That's a clippet of our 9 page setup list for AlmaLinux 8 & CWP.

Offline
****
Re: Centos 8 fresh install IP tables issue
« Reply #4 on: February 26, 2024, 04:29:12 PM »
following installation script, as soon as i run

Code: [Select]
yum -y update
I got these errors and I lost my interest in this one

Code: [Select]
Total                                                                                                                                                          31 MB/s | 542 MB     00:17     
AlmaLinux 8 - BaseOS                                                                                                                                          3.3 MB/s | 3.4 kB     00:00   
Importing GPG key 0xC21AD6EA:
 Userid     : "AlmaLinux <packager@almalinux.org>"
 Fingerprint: E53C F5EF 91CE B0AD 1812 ECB8 51D6 647E C21A D6EA
 From       : /etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Key imported successfully
Import of key(s) didn't help, wrong key(s)?
AlmaLinux 8 - AppStream                                                                                                                                       3.3 MB/s | 3.4 kB     00:00   
Importing GPG key 0xC21AD6EA:
 Userid     : "AlmaLinux <packager@almalinux.org>"
 Fingerprint: E53C F5EF 91CE B0AD 1812 ECB8 51D6 647E C21A D6EA
 From       : /etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Key imported successfully
Import of key(s) didn't help, wrong key(s)?
Public key for kernel-4.18.0-513.18.1.el8_9.x86_64.rpm is not installed. Failing package is: kernel-4.18.0-513.18.1.el8_9.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for kernel-core-4.18.0-513.18.1.el8_9.x86_64.rpm is not installed. Failing package is: kernel-core-4.18.0-513.18.1.el8_9.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for kernel-modules-4.18.0-513.18.1.el8_9.x86_64.rpm is not installed. Failing package is: kernel-modules-4.18.0-513.18.1.el8_9.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for linux-firmware-20230824-120.git0e048b06.el8_9.noarch.rpm is not installed. Failing package is: linux-firmware-20230824-120.git0e048b06.el8_9.noarch
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for NetworkManager-1.40.16-13.el8_9.alma.1.x86_64.rpm is not installed. Failing package is: NetworkManager-1:1.40.16-13.el8_9.alma.1.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for NetworkManager-libnm-1.40.16-13.el8_9.alma.1.x86_64.rpm is not installed. Failing package is: NetworkManager-libnm-1:1.40.16-13.el8_9.alma.1.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for NetworkManager-team-1.40.16-13.el8_9.alma.1.x86_64.rpm is not installed. Failing package is: NetworkManager-team-1:1.40.16-13.el8_9.alma.1.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for NetworkManager-tui-1.40.16-13.el8_9.alma.1.x86_64.rpm is not installed. Failing package is: NetworkManager-tui-1:1.40.16-13.el8_9.alma.1.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for glibc-2.28-236.el8_9.12.x86_64.rpm is not installed. Failing package is: glibc-2.28-236.el8_9.12.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for glibc-common-2.28-236.el8_9.12.x86_64.rpm is not installed. Failing package is: glibc-common-2.28-236.el8_9.12.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for glibc-gconv-extra-2.28-236.el8_9.12.x86_64.rpm is not installed. Failing package is: glibc-gconv-extra-2.28-236.el8_9.12.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for glibc-langpack-en-2.28-236.el8_9.12.x86_64.rpm is not installed. Failing package is: glibc-langpack-en-2.28-236.el8_9.12.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for gnutls-3.6.16-8.el8_9.1.x86_64.rpm is not installed. Failing package is: gnutls-3.6.16-8.el8_9.1.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for kernel-tools-4.18.0-513.18.1.el8_9.x86_64.rpm is not installed. Failing package is: kernel-tools-4.18.0-513.18.1.el8_9.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for kernel-tools-libs-4.18.0-513.18.1.el8_9.x86_64.rpm is not installed. Failing package is: kernel-tools-libs-4.18.0-513.18.1.el8_9.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for libssh-0.9.6-13.el8_9.x86_64.rpm is not installed. Failing package is: libssh-0.9.6-13.el8_9.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for libssh-config-0.9.6-13.el8_9.noarch.rpm is not installed. Failing package is: libssh-config-0.9.6-13.el8_9.noarch
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for libsss_autofs-2.9.1-4.el8_9.5.alma.1.x86_64.rpm is not installed. Failing package is: libsss_autofs-2.9.1-4.el8_9.5.alma.1.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for libsss_certmap-2.9.1-4.el8_9.5.alma.1.x86_64.rpm is not installed. Failing package is: libsss_certmap-2.9.1-4.el8_9.5.alma.1.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for libsss_idmap-2.9.1-4.el8_9.5.alma.1.x86_64.rpm is not installed. Failing package is: libsss_idmap-2.9.1-4.el8_9.5.alma.1.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for libsss_nss_idmap-2.9.1-4.el8_9.5.alma.1.x86_64.rpm is not installed. Failing package is: libsss_nss_idmap-2.9.1-4.el8_9.5.alma.1.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for libsss_sudo-2.9.1-4.el8_9.5.alma.1.x86_64.rpm is not installed. Failing package is: libsss_sudo-2.9.1-4.el8_9.5.alma.1.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for openssh-8.0p1-19.el8_9.2.x86_64.rpm is not installed. Failing package is: openssh-8.0p1-19.el8_9.2.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for openssh-clients-8.0p1-19.el8_9.2.x86_64.rpm is not installed. Failing package is: openssh-clients-8.0p1-19.el8_9.2.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for openssh-server-8.0p1-19.el8_9.2.x86_64.rpm is not installed. Failing package is: openssh-server-8.0p1-19.el8_9.2.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for platform-python-3.6.8-56.el8_9.3.alma.1.x86_64.rpm is not installed. Failing package is: platform-python-3.6.8-56.el8_9.3.alma.1.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for python3-libs-3.6.8-56.el8_9.3.alma.1.x86_64.rpm is not installed. Failing package is: python3-libs-3.6.8-56.el8_9.3.alma.1.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for python3-perf-4.18.0-513.18.1.el8_9.x86_64.rpm is not installed. Failing package is: python3-perf-4.18.0-513.18.1.el8_9.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for python3-rpm-4.14.3-28.el8_9.x86_64.rpm is not installed. Failing package is: python3-rpm-4.14.3-28.el8_9.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for python3-urllib3-1.24.2-5.el8_9.2.noarch.rpm is not installed. Failing package is: python3-urllib3-1.24.2-5.el8_9.2.noarch
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for rpm-4.14.3-28.el8_9.x86_64.rpm is not installed. Failing package is: rpm-4.14.3-28.el8_9.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for rpm-build-libs-4.14.3-28.el8_9.x86_64.rpm is not installed. Failing package is: rpm-build-libs-4.14.3-28.el8_9.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for rpm-libs-4.14.3-28.el8_9.x86_64.rpm is not installed. Failing package is: rpm-libs-4.14.3-28.el8_9.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for rpm-plugin-selinux-4.14.3-28.el8_9.x86_64.rpm is not installed. Failing package is: rpm-plugin-selinux-4.14.3-28.el8_9.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for rpm-plugin-systemd-inhibit-4.14.3-28.el8_9.x86_64.rpm is not installed. Failing package is: rpm-plugin-systemd-inhibit-4.14.3-28.el8_9.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for sos-4.6.1-1.el8.alma.1.noarch.rpm is not installed. Failing package is: sos-4.6.1-1.el8.alma.1.noarch
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for sqlite-libs-3.26.0-19.el8_9.x86_64.rpm is not installed. Failing package is: sqlite-libs-3.26.0-19.el8_9.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for sssd-client-2.9.1-4.el8_9.5.alma.1.x86_64.rpm is not installed. Failing package is: sssd-client-2.9.1-4.el8_9.5.alma.1.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for sssd-common-2.9.1-4.el8_9.5.alma.1.x86_64.rpm is not installed. Failing package is: sssd-common-2.9.1-4.el8_9.5.alma.1.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for sssd-kcm-2.9.1-4.el8_9.5.alma.1.x86_64.rpm is not installed. Failing package is: sssd-kcm-2.9.1-4.el8_9.5.alma.1.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for sssd-nfs-idmap-2.9.1-4.el8_9.5.alma.1.x86_64.rpm is not installed. Failing package is: sssd-nfs-idmap-2.9.1-4.el8_9.5.alma.1.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for sudo-1.9.5p2-1.el8_9.x86_64.rpm is not installed. Failing package is: sudo-1.9.5p2-1.el8_9.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for tzdata-2024a-1.el8.noarch.rpm is not installed. Failing package is: tzdata-2024a-1.el8.noarch
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for cloud-init-23.1.1-11.el8_9.1.alma.1.noarch.rpm is not installed. Failing package is: cloud-init-23.1.1-11.el8_9.1.alma.1.noarch
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for libmaxminddb-1.2.0-10.el8_9.1.x86_64.rpm is not installed. Failing package is: libmaxminddb-1.2.0-10.el8_9.1.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for qemu-guest-agent-6.2.0-40.module_el8.9.0+3714+46544554.2.x86_64.rpm is not installed. Failing package is: qemu-guest-agent-15:6.2.0-40.module_el8.9.0+3714+46544554.2.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
Public key for tcpdump-4.9.3-3.el8_9.1.alma.1.x86_64.rpm is not installed. Failing package is: tcpdump-14:4.9.3-3.el8_9.1.alma.1.x86_64
 GPG Keys are configured as: file:///etc/pki/rpm-gpg/RPM-GPG-KEY-AlmaLinux
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'yum clean packages'.
Error: GPG check FAILED

I also had tried the Rocky one, there were no errors. but the issue was same with iptables. I couldnt enable them

You have an older AlmaLinux 8 image that doesn't have the updated GPG-KEY.
To fix that error, run
Code: [Select]
rpm --import https://repo.almalinux.org/almalinux/RPM-GPG-KEY-AlmaLinux
Or follow our instructions after a fresh install.

Offline
*
Re: Centos 8 fresh install IP tables issue
« Reply #5 on: February 27, 2024, 06:40:14 AM »
Where is this 8 pages installation instruction / upgrade Maria to LTS page.

Can you please provide me its link. I had just followed the installation notes on the landing site. I think that link shall be added there as well.

Offline
*
Re: Centos 8 fresh install IP tables issue
« Reply #6 on: February 27, 2024, 09:32:08 AM »
I have followed what you mentioned here, and also updated the maria db to 10.11. Now firewall is starting fine.

I have started CWP->CWP migration and will test further.

Thank you

Offline
****
Re: Centos 8 fresh install IP tables issue
« Reply #7 on: February 27, 2024, 02:37:22 PM »
CWP -> CWP Migration is tricky, you have to have the right port (2304) open thru the firewall on both servers.
And any hardware firewalls, if you have them also.

This is just needed during the transfer, after you are complete, you can close that port.

Offline
****
Re: Centos 8 fresh install IP tables issue
« Reply #8 on: February 27, 2024, 02:42:18 PM »
Where is this 8 pages installation instruction / upgrade Maria to LTS page.

Can you please provide me its link. I had just followed the installation notes on the landing site. I think that link shall be added there as well.

It's an internal document we created to make it easier to bring servers online, and make sure nothing is missed.
Just started making it this month, and have had 19 updates so far. :/
Something we might put on our public KB soon, if there is interest.
But most sys admins like doing their own configs.

The MariaDB Wiki can be found at: https://wiki.centos-webpanel.com/mariadb-upgrade-to-new-version
But I think you found it already.
Just replace the 10.5 with 10.11.

Offline
****
Re: Centos 8 fresh install IP tables issue
« Reply #9 on: February 27, 2024, 04:49:47 PM »
There is definitely interest. Thanks for the short version here, it will be very helpful in my upcoming work.