Author Topic: OwnCloud needs webDAV  (Read 17939 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
OwnCloud needs webDAV
« on: November 05, 2015, 01:25:25 PM »
I spent a day trying to sort out getting owncloud to work. I wanted access to it with a FQDN so I went about trying to install it the same as I did on my cpanel server... without luck.

Tried Softaculous but it's broken at the moment.
The php installer script from ownCloud threw a 500.. found the permissions problem and fixed it.

With OwnCloud installed I moved to sync my files... no dice. I got these three error messages:

  • Your web server is not yet set up properly to allow file synchronization because the WebDAV interface seems to be broken.
  • This server has no working Internet connection. This means that some of the features like mounting external storage, notifications about updates or installation of third-party apps will not work. Accessing files remotely and sending of notification emails might not work, either. We suggest to enable Internet connection for this server if you want to have all features.
  • cURL is using an outdated NSS version (NSS/3.19.1 Basic ECC). Please update your operating system or features such as installing and updating apps via the app store or Federated Cloud Sharing will not work reliably.

I don't manage servers daily so I'm the type who looks for instructions; I've usually got a decent idea of what they're talking about and pretty good at following them. I've never had to deal with webDAV before (it's always been there) so I'm looking for something to work from in the centos 6.6/cwp environment. Best I can find so far is centos 5 without a web panel.

I don't mind starting over and reinstalling if there's simply a way to do that, but I'm reasonably sure someone else has or will have this same question.

Thanks for this panel,  I'm trying to move away from cpanel and webmin makes my head hurt.

Re: OwnCloud needs webDAV
« Reply #1 on: November 05, 2015, 06:33:04 PM »
Enable Web DAV
-----------------

nano /usr/local/apache/conf/httpd.conf

#Include conf/extra/httpd-dav.conf (Uncomment This Line)
#LoadModule dav_module modules/mod_dav.so (Uncomment This Line)
#LoadModule dav_fs_module modules/mod_dav_fs.so (Uncomment This Line)
#LoadModule auth_digest_module modules/mod_auth_digest.so (Uncomment This Line)

Save and restart apache

service httpd restart


Inside your owncloud folder edit .htaacess file (nano .htaccess) and add the lines below at the end of file.

<Limit GET POST>
order allow,deny
allow from all
</Limit>
<Limit PUT DELETE>
order allow,deny
allow from all
</Limit>


Upgrade CURL.

rpm -Uvh http://nervion.us.es/city-fan/yum-repo/city-fan.org-release-1-13.rhel6.noarch.rpm
nano /etc/yum.repos.d/city-fan.org.repo
change enabled=1 to 0
yum --enablerepo=city-fan.org update curl -y

Now check ....

Offline
*
Re: OwnCloud needs webDAV
« Reply #2 on: April 06, 2016, 01:53:20 PM »
Hello , I followed the directions , uncommented lines to enable the WebDav and this error occurred .

Searching the internet I found out that the problem is with the module. I did not understand whether to install it or just load . But I can not do any of the things .

Can someone help me? My owncloud not sync in desktop without webdav

THANKS



Starting httpd: Syntax error on line 15 of /usr/local/apache/conf/extra/httpd-dav.conf:
Invalid command 'DavLockDB', perhaps misspelled or defined by a module not included in the server configuration
[FAILED]

Starting httpd: httpd: Syntax error on line 55 of /usr/local/apache/conf/httpd.conf: Cannot load /usr/local/apache/modules/mod_dav.so into server: /usr/local/apache/modules/mod_dav.so: cannot open shared object file: No such file or directory
[FAILED]

Offline
*
Re: OwnCloud needs webDAV
« Reply #3 on: April 11, 2016, 04:17:54 PM »
No one here had problem with webdav? I can not synchronize calendar, but now nothing more in sync owncloud.
Someone could enable webdav smoothly? Someone has idei how to install a module?
« Last Edit: April 11, 2016, 06:47:14 PM by cristiancobra2 »

Offline
*****
Re: OwnCloud needs webDAV
« Reply #4 on: April 12, 2016, 08:43:24 AM »
Hello.

If you did recompile Apache throught CWP, check if the module loaded:
Code: [Select]
httpd -M | grep -i dav
You can ask me to solve any problem with your server for some money in pm  ;)
Services Monitoring & RBL Monitoring
http://centos-webpanel.com/services-monitor
Join our Development Team and get paid !
http://centos-webpanel.com/develope-modules-for-cwp

Installation Instructions
http://centos-webpanel.com/installation-instructions
Get Fast Support Here
http://centos-webpanel.com/support-services

Offline
*
Re: OwnCloud needs webDAV
« Reply #5 on: April 12, 2016, 12:45:05 PM »
[root@server1 ~]# httpd -M | grep -i dav
-bash: httpd: command not found


He gave command not found. Apache is installed automatically when installed CWPanel.

How do I reinstall through CWPanel? It is to do this without losing the settings all?

thank you.

Offline
*
Re: OwnCloud needs webDAV
« Reply #6 on: April 12, 2016, 01:08:52 PM »
/usr/local/apache/bin/httpd -M|grep -i dav

you will not lose anything except if you did a custom manual changes in apache configuration, you should use apache rebuilder in cwp.admin
AntiDDoS Protection (web + mail)
http://centos-webpanel.com/website-ddos-protection-proxy

Join our Development Team and get paid !
http://centos-webpanel.com/develope-modules-for-cwp


Services Monitoring & RBL Monitoring
http://centos-webpanel.com/services-monitor


Do you need Fast and FREE Support included for your CWP linux server?
http://centos-webpanel.com/noc-partner-list
Installation Instructions
http://centos-webpanel.com/installation-instructions
Get Fast Support Here
http://centos-webpanel.com/support-services

Offline
*
Re: OwnCloud needs webDAV
« Reply #7 on: April 12, 2016, 02:33:30 PM »
The command returned an error. What does it mean?

[root@server1 ~]# /usr/local/apache/bin/httpd -M | grep -i dav                                                               
Syntax OK 

Offline
*
Re: OwnCloud needs webDAV
« Reply #8 on: April 12, 2016, 02:54:46 PM »
I used the Apache Re-build, chose the most current version .31. But when I make changes to the httpd.conf, continues giving error in module use:

Starting httpd: httpd: Syntax error on line 404 of /usr/local/apache/conf/httpd.conf: Cannot load /usr/local/apache/modules/mod_dav.so into server: /usr/local/apache/modules/mod_dav.so: cannot open shared object file: No such file or directory
[FAILED]

Any suggestion?
thank you.

Offline
*****
Re: OwnCloud needs webDAV
« Reply #9 on: April 13, 2016, 11:45:59 AM »
The command returned an error. What does it mean?

[root@server1 ~]# /usr/local/apache/bin/httpd -M | grep -i dav                                                               
Syntax OK 

It means, you 're don't have the module.
Contact the CWP support http://centos-webpanel.com/support-services for compile it for you.
You can ask me to solve any problem with your server for some money in pm  ;)
Services Monitoring & RBL Monitoring
http://centos-webpanel.com/services-monitor
Join our Development Team and get paid !
http://centos-webpanel.com/develope-modules-for-cwp

Installation Instructions
http://centos-webpanel.com/installation-instructions
Get Fast Support Here
http://centos-webpanel.com/support-services

Offline
*
Re: OwnCloud needs webDAV
« Reply #10 on: April 13, 2016, 12:42:50 PM »
First I would like to thank your help.

I would not like to do this? I can not spend money at this point (and the dollar here in Brazil is very expensive).

If anyone has a tutorial for me to try before.

thank you

Offline
*
Re: OwnCloud needs webDAV
« Reply #11 on: April 13, 2016, 08:16:36 PM »
we didn't test it so there is no tutorial for it and that is why it was recommended to contact support.
You can google for apache recompile instructions and add this into your cwp apache rebuilder flags.
AntiDDoS Protection (web + mail)
http://centos-webpanel.com/website-ddos-protection-proxy

Join our Development Team and get paid !
http://centos-webpanel.com/develope-modules-for-cwp


Services Monitoring & RBL Monitoring
http://centos-webpanel.com/services-monitor


Do you need Fast and FREE Support included for your CWP linux server?
http://centos-webpanel.com/noc-partner-list
Installation Instructions
http://centos-webpanel.com/installation-instructions
Get Fast Support Here
http://centos-webpanel.com/support-services

Offline
*
Re: OwnCloud needs webDAV
« Reply #12 on: April 14, 2016, 01:40:56 PM »
Thank you for your help. I researched and I think I could recompile Apache with modules, for now they appear in the Apache Status tab as Loaded Modules.

And that previous command now returns different:

/ Usr / local / apache / bin / httpd -M | grep -i dav
httpd: Could not reliably determine the server's fully qualified domain name, using server1.edicoescobra.com.br for ServerName
Syntax OK
  dav_module (static)
  dav_fs_module (static)
  dav_lock_module (static)

Now when I edit the httpd.conf and descomento the line to activate the DAV can restart apache without problems. But when the adicono LoadModules lines in conf get this error when starting apache:

dav_module module is built-in and can not be loaded

This means that it has already been loaded? The problem is that the error persists and ownCloud continues with the error messages.

Can anyone give me some direction?
And again thank you for the help already given.

Offline
*
Re: OwnCloud needs webDAV
« Reply #13 on: April 14, 2016, 03:35:04 PM »
They work!

Modules started to work after compiling Apache. In fact just missed this step jumped.

Inside your owncloud folder edit .htaacess file (nano .htaccess) and add the lines below at the end of file.

<Limit GET POST>
order allow, deny
allow from all
</ Limit>
<Limit PUT DELETE>
order allow, deny
allow from all
</ Limit>

For those who have the same problem. I recompiled Apache by the panel in APACHE RE-BUILD entering the options:
--enable-dav
--enable-dav-fs
--enable-dav-lock
--enable-auth-digest

I thank you all for your help.
Thank you very much.

Offline
*
Re: OwnCloud needs webDAV
« Reply #14 on: July 30, 2020, 05:21:51 PM »
I will report the problem I had and how I solved it.
After a lot of work I managed to install Nextcloud 19.

Procedures performed:

1) Rebuild Apache with the following added switches – you can use Apache 2.4.x
Add..
--enable-dav
--enable-dav-fs
--enable-dav-lock
--enable-auth-digest
--enable-authn-core
--enable-authz-core

2) Enable the Apache modules: nano /usr/local/apache/conf/httpd.conf

LoadModule alias_module modules/mod_alias.so
LoadModule authn_file_module modules/mod_authn_file.so
LoadModule authn_core_module modules/mod_authn_core.so
LoadModule authz_user_module modules/mod_authz_user.so
LoadModule auth_digest_module modules/mod_auth_digest.so
LoadModule dav_module modules/mod_dav.so
LoadModule dav_fs_module modules/mod_dav_fs.so
LoadModule dav_lock_module modules/mod_dav_lock.so
LoadModule auth_digest_module modules/mod_auth_digest.so
LoadModule setenvif_module modules/mod_setenvif.so
LoadModule expires_module modules/mod_expires.so
LoadModule headers_module modules/mod_headers.so
Include conf/extra/httpd-dav.conf

3) Restart Apache:
systemctl restart httpd

4) Check for dav modules:
/usr/local/apache/bin/httpd -M | grep -i dav

The result should look like this:

dav_module (shared)
dav_fs_module (shared)
dav_lock_module (shared)

5) Edit your “httpd-userdir.conf” nano /usr/local/apache/conf/extra/httpd-userdir.conf

…replace everything in this file with the following text…

<Directory "/home/*/public_html">
AllowOverride FileInfo AuthConfig Limit Indexes
Options MultiViews Indexes SymLinksIfOwnerMatch IncludesNoExec
<Limit GET POST OPTIONS>
Order allow,deny
Allow from all
</Limit>
<LimitExcept GET POST OPTIONS>
Order deny,allow
Deny from all
</LimitExcept>
</Directory>

6) Change the vhosts for nextcloud
Find your vhost file(s) (/usr/local/apache/conf.d/vhosts) Modify both the ordinary vhost and the one marked “ssl” if using an SSL certificate (which I advise…)

<IfModule mod_rewrite.c>
RewriteEngine on
RewriteRule ^/ocm-provider /Cloud/ocm-provider/ [R=301,L]
RewriteRule ^/ocs-provider /Cloud/ocs-provider/ [R=301,L]
RewriteRule ^/\.well-known/carddav /Cloud/remote.php/dav/ [R=301,L]
RewriteRule ^/\.well-known/caldav /Cloud/remote.php/dav/ [R=301,L]
</IfModule>



7)

Edit your Nextcloud .htaccess file
…adding the following data to the end of the file:

<Limit GET POST>
order deny,allow
allow from all
</Limit>
<Limit PUT DELETE>
order deny,allow
allow from all
</Limit>

8) The most important.
For me it only works when I disabled mod security in:
CWP > Segurity > Flap Accounts > Disable.
« Last Edit: July 30, 2020, 06:04:07 PM by thiagodifoiz »