Author Topic: Phpmyadmin unable to import 40MB file  (Read 8379 times)

0 Members and 1 Guest are viewing this topic.

Phpmyadmin unable to import 40MB file
« on: November 18, 2015, 07:45:29 AM »
Hi Team,

I have tried to upload 40Mb mysql file. While import I am getting error to increase maximum upload file size. So I tried the below steps.

1. nano /usr/local/php/php.ini
Code: [Select]
post_max_size = 8M
upload_max_filesize = 2M
max_execution_time = 30
max_input_time = 60
memory_limit = 8M
Change to:

post_max_size = 750M
upload_max_filesize = 750M
max_execution_time = 300
max_input_time = 540
memory_limit = 1000M

2. Open /usr/local/apache/htdocs/phpMyAdmin/libraries/config.default.php

Code: [Select]
 * phpMyAdmin default configuration, you can copy values from here to your

3. So I have copied the config.default.php file to and edited the

Code: [Select]
$cfg['ExecTimeLimit'] = 0;
4. Restarted the Apache httpd service.

But still I am getting error. Please find the Images below for errors.

Re: Phpmyadmin unable to import 40MB file
« Reply #1 on: November 18, 2015, 10:09:16 AM »
I really don't get what you have done actually. But let me tell you the simple process of doing it. But before that reverse what have you done earlier. The system is you have to actually edit the /usr/local/php/php.ini file of your currently running php version. Just change these two lines :
upload_max_filesize = 50M
post_max_size = 200M

Then restart apache : service httpd restart

Do not set these values too high. Also can you please tell me that what PHP version your using? And if you have varnish cache enabled then try disabling it and then uploading the SQL file. Varnish cache might also cause these types of issues.