Author Topic: How to setup user quotas ?  (Read 104697 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Re: How to setup user quotas ?
« Reply #45 on: July 10, 2018, 02:01:19 PM »
For those having the problem setting up the quota on XFS file system, hope the below tips would help you. I finally got this work for my server.

1. Follow the steps on this link.
https://help.directadmin.com/item.php?id=557

(Ignore the step 7,8).

2. Enter the command line "/usr/sbin/repquota /" to make sure the quota is working.

3. Follow the XFS instructions on this post page 1.

Reference sites:
- https://help.directadmin.com/item.php?id=557
- https://help.directadmin.com/item.php?id=42
- https://www.server-world.info/en/note?os=CentOS_7&p=quota
« Last Edit: July 10, 2018, 02:03:19 PM by infinitech07 »

Offline
*
Re: How to setup user quotas ?
« Reply #46 on: August 17, 2018, 11:37:12 AM »
It still doesn't work for KVM with XFS file system.
Its being 2 days i'm struggling to find a solution for this.
Would definitely be very helpful if someone could provide clear instructions for users with no /home partition.


Offline
*
Re: How to setup user quotas ?
« Reply #47 on: September 22, 2018, 04:31:53 PM »
How to make Disk Quota Setup for Google Cloud Virtual Instance - Centos 7? I couldn't make it work

Offline
*
VPS & Dedicated server provider with included FREE Managed support for CWP.
http://www.studio4host.com/

*** Don't allow that your server or website is down, choose hosting provider with included expert managed support for your CWP.


Offline
*
Re: How to setup user quotas ?
« Reply #50 on: March 09, 2019, 12:56:29 PM »
I have managed to fix the quota in CentOS 7 +CWP - xfs formatted.

Code: [Select]
mount | grep ' / '
If the result is: /dev/vda1 on / type xfs (rw,relatime,attr2,inode64,noquota)

Then

Code: [Select]
nano /etc/default/grub

Add to the end of line of GRUB_CMDLINE_LINUX=
Code: [Select]
rootflags=uquota,gquota
Before
Code: [Select]
GRUB_CMDLINE_LINUX="console=tty0 crashkernel=auto console=ttyS0,115200"
After
Code: [Select]
GRUB_CMDLINE_LINUX="console=tty0 crashkernel=auto console=ttyS0,115200 rootflags=uquota,gquota"

Rebuild the grub config:
Code: [Select]
cp /boot/grub2/grub.cfg /boot/grub2/grub.cfg.orig
grub2-mkconfig -o /boot/grub2/grub.cfg

Then update the fstab

Code: [Select]
nano /etc/fstab
Change from
Code: [Select]
UUID=5f18...a0a / xfs defaults        0 0To
Code: [Select]
UUID=5f18...a0a / xfs defaults,usrquota,grpquota        0 0
Reboot

Now login to the cwp and update each package and check while saving (Update quota for all users using this package, also disables inode limits !)

Offline
*
Enable quotas to OPENVZ
« Reply #51 on: May 04, 2020, 10:17:32 AM »
If your hosting company uses openvz platform and you use a container the only thing you have to do is the following
1. Ask them to enable second level quotas for your container
2. After it is enabled then go to Users --> User quota. You will ensure that quota is working
3. Finally go to Packages --> Packages and after you select each one of them click "update" having the "update quota" enabled.

You are ready to go and list your accounts and ensure that "Disk usage" is working normally.
You need a reliable hosting company for your website or your eshop?
Need a cheap, reliable, fast and secure hosting?
You want fast support and action to every technical issue?
Freespirits is here for you :) - Don't look any further!