Author Topic: Fatal error: Class 'kLO201gUtE3IVP' not found after fresh CWP install  (Read 5178 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Hosting Provider: SimplerCloud.com
with template CentOS 6.7 (64-bit) + CentOS Web Panel 0.9.8.11 20160221
(recent issue after rebuilding the same template with steps that worked before and updated perfectly)
- have tried to resolve this 3x by rebuilding with additional precautions each time without success

Most recent unsuccessful rebuild:

1. yum -y update
2. Steps taken first to update mySQL 5.1 to 5.6
3. Then upgraded mySQL before restarting
4. Installed CWP-latest with MariaDB switch - completes without errors
5. After reboot,
6. yum -y update again
7. Do do upgrade_mysql again (forced) before restarting mysqld and cwpsrv
8. And just to make sure, I do another reboot
9. Then when attempting to access web gui (https://IP-ADDRESS:2031) gives:



Fatal error: Class 'kLO201gUtE3IVP' not found in /usr/local/cwpsrv/htdocs/admin/index.php(1) : eval()'d code(1) : eval()'d code on line 5

Same error each time.
Have also tried changing root passwd, including encryption from default SHA512 to MD5 to no avail.

Appreciate solution as soon as possible to prevent loss of further downtime :(
« Last Edit: June 05, 2016, 12:45:43 PM by raylee »

Offline
*****
what exactly you want to install with CWP ?
mariadb ?

Offline
*
Hi Sandeep,

I want to install (and actually when I installed it previously I was 100% successful at it):

  • Centos Web Panel
  • with mySQL updated to at least v5.5.50 first
  • then with MariaDB v10.1+ when CWP is compiled

I have achieved much more before. Let's keep it simple for now. All I want to do is to figure out why even after 5 compiles I cannot get CWP to even start.

Sincerely,
Ray Lee

Offline
*****
install fresh/clean centos 6 minimal (don't install os with CWP)

use this commands/script to install cwp with mariadb
Code: [Select]
cd /usr/local/src
wget http://centos-webpanel.com/cwp-latest
sh cwp-latest -d mariadb

Offline
*
Hi Sandeep,

Actually I thought about the logic trying it the way you mentioned. I checked out the original error message indicating a problem with the /usr/local/cwpsrv/htdocs/admin/index.php file on line 5. So I tried viewing the file and discovered it was an encrypted one, although I did not recognize the technology. Regardless, I figured that if I did a minimal Centos 6 install (which already was because it is a hosting provider servlet template), any proprietary encryption techniques wouldn't be immediately installed which wasn't for Centos Web Panel.

Nevertheless, it was probably something that kept interfering with the encryption when trying to login (http://forum.centos-webpanel.com/centos-webpanel/how-to-fix-encryption-error-on-login/). Initially I tried this, and was confident it would help, but it didn't and the same error persisted no matter how many times I rebuild the server with the servlet template that worked a few months ago.

Then I realized that one external factor that my servlet offered was to enable you to generate and use an SSH key pair, and I noticed that it could have negative effect if it required a decryption procedure to figure out the root password before allowing you to successfully logon to CWP. And this was probably associated with this mysterious encrypted class.

So, before rebuilding the server again, I removed all SSH key pairs I had. Then after rebuilding, I went about the normal prescribed way of updating the server,mysql and installing CWP with MariaDB.

And that worked!!!

Anyway, thanks for your suggestions and prompt replies.

Sincerely,
Ray Lee