Author Topic: failed all after sh upgrade_mysql  (Read 10741 times)

0 Members and 1 Guest are viewing this topic.

Offline
***
failed all after sh upgrade_mysql
« on: June 21, 2016, 11:27:44 AM »
Hi i used  mysqld 5.1.x (default) and i go to sh upgrade_mysql (scripts default have centos web panel).

I have that after upgrade

Code: [Select]

Warning: mysql_connect(): No such file or directory in /usr/local/cwpsrv/htdocs/admin/index.php(1) : eval()'d code(1) : eval()'d code on line 2


Trying to start mysql server, please wait!
Try to restart CentOS Web Panel with command: service cwpsrv restart

**Check your MySQL root password in: /usr/local/cwpsrv/htdocs/resources/admin/include/db_conn.php and /root/.my.cnf

Could not connect: No such file or directory

NOTE: i go see password and it all ok.
NOTE2: i restart server centos 6.8



Code: [Select]
i see log and i have that after upgrade:

160621 12:36:11 [Note] Event Scheduler: Purging the queue. 0 events
160621 12:36:13 [Note] /usr/libexec/mysqld: Shutdown complete

160621 12:36:13 mysqld_safe mysqld from pid file /var/run/mysqld/mysqld.pid ended
160621 12:41:12 mysqld_safe Starting mysqld daemon with databases from /var/lib/mysql
160621 12:41:12 [Note] /usr/libexec/mysqld (mysqld 5.5.49) starting as process 29874 ...
160621 12:41:12 [Note] Plugin 'FEDERATED' is disabled.
160621 12:41:12 InnoDB: The InnoDB memory heap is disabled
160621 12:41:12 InnoDB: Mutexes and rw_locks use GCC atomic builtins
160621 12:41:12 InnoDB: Compressed tables use zlib 1.2.3
160621 12:41:12 InnoDB: Using Linux native AIO
160621 12:41:12 InnoDB: Initializing buffer pool, size = 128.0M
160621 12:41:12 InnoDB: Completed initialization of buffer pool
InnoDB: Error: checksum mismatch in data file ./ibdata1
160621 12:41:12 InnoDB: Could not open or create data files.
160621 12:41:12 InnoDB: If you tried to add new data files, and it failed here,
160621 12:41:12 InnoDB: you should now edit innodb_data_file_path in my.cnf back
160621 12:41:12 InnoDB: to what it was, and remove the new ibdata files InnoDB created
160621 12:41:12 InnoDB: in this failed attempt. InnoDB only wrote those files full of
160621 12:41:12 InnoDB: zeros, but did not yet use them in any way. But be careful: do not
160621 12:41:12 InnoDB: remove old data files which contain your precious data!
160621 12:41:12 [ERROR] Plugin 'InnoDB' init function returned error.
160621 12:41:12 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
160621 12:41:12 [ERROR] Unknown/unsupported storage engine: InnoDB
160621 12:41:12 [ERROR] Aborting

160621 12:41:12 [Note] /usr/libexec/mysqld: Shutdown complete




http://forum.centos-webpanel.com/informations/outdated-info-over-mysql-conection-error-cwp-panel/



After i try remove mysql 5.5 and i have that error:

Code: [Select]

                   Tamaño
=============================================================================================================================================================================================================================================
Eliminando:
 mysql55w                                                      x86_64                                               5.5.49-1.w6                                                @webtatic                                                28 M
Eliminando para las dependencias:
 mysql55w-devel                                                x86_64                                               5.5.49-1.w6                                                @webtatic                                               601 k
 mysql55w-server                                               x86_64                                               5.5.49-1.w6                                                @webtatic                                                45 M

Resumen de la transacción
=============================================================================================================================================================================================================================================
Eliminar       3 Paquete(s)

Tamaño instalado: 74 M
Está de acuerdo [s/N]:s
Descargando paquetes:
Ejecutando el rpm_check_debug
Ejecutando prueba de transacción
La prueba de transacción ha sido exitosa
Ejecutando transacción
  Eliminando    : mysql55w-devel-5.5.49-1.w6.x86_64                                                                                                                                                                                      1/3
  Eliminando    : mysql55w-server-5.5.49-1.w6.x86_64                                                                                                                                                                                     2/3
advertencia:/var/log/mysqld.log guardado como /var/log/mysqld.log.rpmsave
  Eliminando    : mysql55w-5.5.49-1.w6.x86_64                                                                                                                                                                                            3/3
  Verifying     : mysql55w-devel-5.5.49-1.w6.x86_64                                                                                                                                                                                      1/3
  Verifying     : mysql55w-server-5.5.49-1.w6.x86_64                                                                                                                                                                                     2/3
  Verifying     : mysql55w-5.5.49-1.w6.x86_64                                                                                                                                                                                            3/3

Eliminado(s):
  mysql55w.x86_64 0:5.5.49-1.w6

Dependencia(s) eliminada(s):
  mysql55w-devel.x86_64 0:5.5.49-1.w6                                                                                  mysql55w-server.x86_64 0:5.5.49-1.w6

¡Listo!
[root@ns3010965 scripts]# yum install mysql
Complementos cargados:fastestmirror, replace
Configurando el proceso de instalación
Loading mirror speeds from cached hostfile
 * base: fr.mirror.babylon.network
 * extras: fr.mirror.babylon.network
 * ius: mirrors.ircam.fr
 * remi-safe: fr.mirror.babylon.network
 * rpmforge: mirrors.ircam.fr
 * updates: fr.mirror.babylon.network
Resolviendo dependencias
--> Ejecutando prueba de transacción
---> Package mysql.x86_64 0:5.1.73-7.el6 will be instalado
--> Procesando dependencias: mysql-libs = 5.1.73-7.el6 para el paquete: mysql-5.1.73-7.el6.x86_64
--> Ejecutando prueba de transacción
---> Package mysql-libs.x86_64 0:5.1.73-7.el6 will be instalado
--> Procesando conflictos: mysql55w-libs-5.5.49-1.w6.x86_64 choca con mysql-libs < 5.5
--> Resolución de dependencias finalizada
Error: mysql55w-libs conflicts with mysql-libs-5.1.73-7.el6.x86_64
 Podría intentar utilizar el comando --skip-broken para sortear el problema
Podría intentar ejecutar: rpm- Va --nofiles --nodigest


and if i go to yum remove mysql55w-libs

i have that

[root@ns3010965 scripts]# yum remove mysql55w-libs
Complementos cargados:fastestmirror, replace
Configurando el proceso de eliminación
Resolviendo dependencias
--> Ejecutando prueba de transacción
---> Package mysql55w-libs.x86_64 0:5.5.49-1.w6 will be eliminado
--> Procesando dependencias: mysql-libs para el paquete: 2:postfix-2.6.6-6.el6_7.1.x86_64
--> Ejecutando prueba de transacción
---> Package postfix.x86_64 2:2.6.6-6.el6_7.1 will be eliminado
--> Procesando dependencias: /usr/sbin/sendmail para el paquete: cronie-1.4.4-15.el6_7.1.x86_64
--> Procesando dependencias: /usr/sbin/sendmail para el paquete: 14:arpwatch-2.1a15-16.el6.x86_64
--> Ejecutando prueba de transacción
---> Package arpwatch.x86_64 14:2.1a15-16.el6 will be eliminado
---> Package cronie.x86_64 0:1.4.4-15.el6_7.1 will be eliminado
--> Procesando dependencias: cronie = 1.4.4-15.el6_7.1 para el paquete: cronie-anacron-1.4.4-15.el6_7.1.x86_64
--> Ejecutando prueba de transacción
---> Package cronie-anacron.x86_64 0:1.4.4-15.el6_7.1 will be eliminado
--> Resolución de dependencias finalizada

Dependencias resueltas

=============================================================================================================================================================================================================================================
 Paquete                                                     Arquitectura                                        Versión                                                        Repositorio                                            Tamaño
=============================================================================================================================================================================================================================================
Eliminando:
 mysql55w-libs                                               x86_64                                              5.5.49-1.w6                                                    @webtatic                                              4.1 M
Eliminando para las dependencias:
 arpwatch                                                    x86_64                                              14:2.1a15-16.el6                                               @base                                                  452 k
 cronie                                                      x86_64                                              1.4.4-15.el6_7.1                                               @updates                                               174 k
 cronie-anacron                                              x86_64                                              1.4.4-15.el6_7.1                                               @updates                                                43 k
 postfix                                                     x86_64                                              2:2.6.6-6.el6_7.1                                              @updates                                               9.7 M

Resumen de la transacción
=============================================================================================================================================================================================================================================
Eliminar       5 Paquete(s)

Tamaño instalado: 14 M
Está de acuerdo [s/N]:s
Descargando paquetes:
Ejecutando el rpm_check_debug
ERROR con el rpm_check_debug vs depsolve:
/etc/cron.d se necesita para (instalado) crontabs-1.10-33.el6.noarch
Podría intentar ejecutar: rpm- Va --nofiles --nodigest
Your transaction was saved, rerun it with:
 yum load-transaction /tmp/yum_save_tx-2016-06-21-13-247KQpOX.yumtx
Tiene correo en /var/spool/mail/root
[root@ns3010965 scripts]#


and i cant remove...




I need help please...

Offline
***
Re: failed all after sh upgrade_mysql
« Reply #1 on: June 21, 2016, 11:32:10 AM »
And if i go install... for 5.1.X

Code: [Select]
start: Unknown job: mysqld
[root@ns3010965 scripts]# yum install mysql
Complementos cargados:fastestmirror, replace
Configurando el proceso de instalación
Loading mirror speeds from cached hostfile
 * base: fr.mirror.babylon.network
 * extras: fr.mirror.babylon.network
 * ius: mirrors.ircam.fr
 * remi-safe: fr.mirror.babylon.network
 * rpmforge: mirrors.ircam.fr
 * updates: fr.mirror.babylon.network
Resolviendo dependencias
--> Ejecutando prueba de transacción
---> Package mysql.x86_64 0:5.1.73-7.el6 will be instalado
--> Procesando dependencias: mysql-libs = 5.1.73-7.el6 para el paquete: mysql-5.1.73-7.el6.x86_64
--> Ejecutando prueba de transacción
---> Package mysql-libs.x86_64 0:5.1.73-7.el6 will be instalado
--> Procesando conflictos: mysql55w-libs-5.5.49-1.w6.x86_64 choca con mysql-libs < 5.5
--> Resolución de dependencias finalizada
Error: mysql55w-libs conflicts with mysql-libs-5.1.73-7.el6.x86_64
 Podría intentar utilizar el comando --skip-broken para sortear el problema
Podría intentar ejecutar: rpm- Va --nofiles --nodigest
[root@ns3010965 scripts]#


But if i go try yum remove mysql55w-libs for can install mysql libs 5.1 error up (first post).

Offline
***
Re: failed all after sh upgrade_mysql
« Reply #2 on: June 21, 2016, 12:53:57 PM »
Code: [Select]
[root@ns3010965 yum.repos.d]# rpm -qa | grep mysql
libmysqlclient16-5.1.69-1.w6.x86_64
php70w-mysql-7.0.7-1.w6.x86_64
[i][b]mysql55w-libs-5.5.49-1.w6.x86_64[/b][/i] That can remove..
mysql-community-release-el6-5.noarch

I try manuallity

but conflict again with mysqld55w_libs. The problem it to ejecuted sh upgrade_mysql and  remplaced (yum replaced ...)

[root@ns3010965 yum.repos.d]#  [i][b]sudo yum install mysql-community-server[/b][/i]
Complementos cargados:fastestmirror, replace
Configurando el proceso de instalación
Loading mirror speeds from cached hostfile
 * base: fr.mirror.babylon.network
 * extras: fr.mirror.babylon.network
 * ius: mirrors.ircam.fr
 * remi: fr.mirror.babylon.network
 * remi-php56: fr.mirror.babylon.network
 * remi-safe: fr.mirror.babylon.network
 * rpmforge: mirrors.ircam.fr
 * updates: fr.mirror.babylon.network
Resolviendo dependencias
--> Ejecutando prueba de transacción
---> Package mysql-community-server.x86_64 0:5.6.31-2.el6 will be instalado
--> Procesando dependencias: mysql-community-common(x86-64) = 5.6.31-2.el6 para el paquete: mysql-community-server-5.6.31-2.el6.x86_64
--> Procesando dependencias: mysql-community-client(x86-64) = 5.6.31-2.el6 para el paquete: mysql-community-server-5.6.31-2.el6.x86_64
--> Ejecutando prueba de transacción
---> Package mysql-community-client.x86_64 0:5.6.31-2.el6 will be instalado
--> Procesando dependencias: mysql-community-libs(x86-64) = 5.6.31-2.el6 para el paquete: mysql-community-client-5.6.31-2.el6.x86_64
---> Package mysql-community-common.x86_64 0:5.6.31-2.el6 will be instalado
--> Ejecutando prueba de transacción
---> Package mysql-community-libs.x86_64 0:5.6.31-2.el6 will be instalado
--> Resolución de dependencias finalizada

Dependencias resueltas

=============================================================================================================================================================================================================================================
 Paquete                                                          Arquitectura                                     Versión                                                 Repositorio                                                 Tamaño
=============================================================================================================================================================================================================================================
Instalando:
 mysql-community-server                                           x86_64                                           5.6.31-2.el6                                            mysql56-community                                            54 M
Instalando para las dependencias:
 mysql-community-client                                           x86_64                                           5.6.31-2.el6                                            mysql56-community                                            18 M
 mysql-community-common                                           x86_64                                           5.6.31-2.el6                                            mysql56-community                                           308 k
 mysql-community-libs                                             x86_64                                           5.6.31-2.el6                                            mysql56-community                                           1.9 M

Resumen de la transacción
=============================================================================================================================================================================================================================================
Instalar       4 Paquete(s)

Tamaño total: 74 M
Tamaño instalado: 333 M
Está de acuerdo [s/N]:



Error en la verificación de la transacción:
  file /etc/my.cnf from install of mysql-community-server-5.6.31-2.el6.x86_64 conflicts with file from package mysql55w-libs-5.5.49-1.w6.x86_64
  file /usr/share/mysql/czech/errmsg.sys from install of mysql-community-common-5.6.31-2.el6.x86_64 conflicts with file from package mysql55w-libs-5.5.49-1.w6.x86_64
  file /usr/share/mysql/danish/errmsg.sys from install of mysql-community-common-5.6.31-2.el6.x86_64 conflicts with file from package mysql55w-libs-5.5.49-1.w6.x86_64
  file /usr/share/mysql/dutch/errmsg.sys from install of mysql-community-common-5.6.31-2.el6.x86_64 conflicts with file from package mysql55w-libs-5.5.49-1.w6.x86_64
  file /usr/share/mysql/english/errmsg.sys from install of mysql-community-common-5.6.31-2.el6.x86_64 conflicts with file from package mysql55w-libs-5.5.49-1.w6.x86_64
  file /usr/share/mysql/estonian/errmsg.sys from install of mysql-community-common-5.6.31-2.el6.x86_64 conflicts with file from package mysql55w-libs-5.5.49-1.w6.x86_64
  file /usr/share/mysql/french/errmsg.sys from install of mysql-community-common-5.6.31-2.el6.x86_64 conflicts with file from package mysql55w-libs-5.5.49-1.w6.x86_64
  file /usr/share/mysql/german/errmsg.sys from install of mysql-community-common-5.6.31-2.el6.x86_64 conflicts with file from package mysql55w-libs-5.5.49-1.w6.x86_64
  file /usr/share/mysql/greek/errmsg.sys from install of mysql-community-common-5.6.31-2.el6.x86_64 conflicts with file from package mysql55w-libs-5.5.49-1.w6.x86_64
  file /usr/share/mysql/hungarian/errmsg.sys from install of mysql-community-common-5.6.31-2.el6.x86_64 conflicts with file from package mysql55w-libs-5.5.49-1.w6.x86_64
  file /usr/share/mysql/italian/errmsg.sys from install of mysql-community-common-5.6.31-2.el6.x86_64 conflicts with file from package mysql55w-libs-5.5.49-1.w6.x86_64
  file /usr/share/mysql/japanese/errmsg.sys from install of mysql-community-common-5.6.31-2.el6.x86_64 conflicts with file from package mysql55w-libs-5.5.49-1.w6.x86_64
  file /usr/share/mysql/korean/errmsg.sys from install of mysql-community-common-5.6.31-2.el6.x86_64 conflicts with file from package mysql55w-libs-5.5.49-1.w6.x86_64
  file /usr/share/mysql/norwegian-ny/errmsg.sys from install of mysql-community-common-5.6.31-2.el6.x86_64 conflicts with file from package mysql55w-libs-5.5.49-1.w6.x86_64
  file /usr/share/mysql/norwegian/errmsg.sys from install of mysql-community-common-5.6.31-2.el6.x86_64 conflicts with file from package mysql55w-libs-5.5.49-1.w6.x86_64
  file /usr/share/mysql/polish/errmsg.sys from install of mysql-community-common-5.6.31-2.el6.x86_64 conflicts with file from package mysql55w-libs-5.5.49-1.w6.x86_64
  file /usr/share/mysql/portuguese/errmsg.sys from install of mysql-community-common-5.6.31-2.el6.x86_64 conflicts with file from package mysql55w-libs-5.5.49-1.w6.x86_64
  file /usr/share/mysql/romanian/errmsg.sys from install of mysql-community-common-5.6.31-2.el6.x86_64 conflicts with file from package mysql55w-libs-5.5.49-1.w6.x86_64
  file /usr/share/mysql/russian/errmsg.sys from install of mysql-community-common-5.6.31-2.el6.x86_64 conflicts with file from package mysql55w-libs-5.5.49-1.w6.x86_64
  file /usr/share/mysql/serbian/errmsg.sys from install of mysql-community-common-5.6.31-2.el6.x86_64 conflicts with file from package mysql55w-libs-5.5.49-1.w6.x86_64
  file /usr/share/mysql/slovak/errmsg.sys from install of mysql-community-common-5.6.31-2.el6.x86_64 conflicts with file from package mysql55w-libs-5.5.49-1.w6.x86_64
  file /usr/share/mysql/spanish/errmsg.sys from install of mysql-community-common-5.6.31-2.el6.x86_64 conflicts with file from package mysql55w-libs-5.5.49-1.w6.x86_64
  file /usr/share/mysql/swedish/errmsg.sys from install of mysql-community-common-5.6.31-2.el6.x86_64 conflicts with file from package mysql55w-libs-5.5.49-1.w6.x86_64
  file /usr/share/mysql/ukrainian/errmsg.sys from install of mysql-community-common-5.6.31-2.el6.x86_64 conflicts with file from package mysql55w-libs-5.5.49-1.w6.x86_64
  file /usr/share/mysql/charsets/Index.xml from install of mysql-community-common-5.6.31-2.el6.x86_64 conflicts with file from package mysql55w-libs-5.5.49-1.w6.x86_64
  file /usr/share/mysql/charsets/armscii8.xml from install of mysql-community-common-5.6.31-2.el6.x86_64 conflicts with file from package mysql55w-libs-5.5.49-1.w6.x86_64
  file /usr/share/mysql/charsets/ascii.xml from install of mysql-community-common-5.6.31-2.el6.x86_64 conflicts with file from package mysql55w-libs-5.5.49-1.w6.x86_64
  file /usr/share/mysql/charsets/cp1250.xml from install of mysql-community-common-5.6.31-2.el6.x86_64 conflicts with file from package mysql55w-libs-5.5.49-1.w6.x86_64
  file /usr/share/mysql/charsets/cp1256.xml from install of mysql-community-common-5.6.31-2.el6.x86_64 conflicts with file from package mysql55w-libs-5.5.49-1.w6.x86_64
  file /usr/share/mysql/charsets/cp1257.xml from install of mysql-community-common-5.6.31-2.el6.x86_64 conflicts with file from package mysql55w-libs-5.5.49-1.w6.x86_64
  file /usr/share/mysql/charsets/cp850.xml from install of mysql-community-common-5.6.31-2.el6.x86_64 conflicts with file from package mysql55w-libs-5.5.49-1.w6.x86_64
  file /usr/share/mysql/charsets/cp852.xml from install of mysql-community-common-5.6.31-2.el6.x86_64 conflicts with file from package mysql55w-libs-5.5.49-1.w6.x86_64
  file /usr/share/mysql/charsets/cp866.xml from install of mysql-community-common-5.6.31-2.el6.x86_64 conflicts with file from package mysql55w-libs-5.5.49-1.w6.x86_64
  file /usr/share/mysql/charsets/dec8.xml from install of mysql-community-common-5.6.31-2.el6.x86_64 conflicts with file from package mysql55w-libs-5.5.49-1.w6.x86_64
  file /usr/share/mysql/charsets/geostd8.xml from install of mysql-community-common-5.6.31-2.el6.x86_64 conflicts with file from package mysql55w-libs-5.5.49-1.w6.x86_64
  file /usr/share/mysql/charsets/greek.xml from install of mysql-community-common-5.6.31-2.el6.x86_64 conflicts with file from package mysql55w-libs-5.5.49-1.w6.x86_64
  file /usr/share/mysql/charsets/hebrew.xml from install of mysql-community-common-5.6.31-2.el6.x86_64 conflicts with file from package mysql55w-libs-5.5.49-1.w6.x86_64
  file /usr/share/mysql/charsets/hp8.xml from install of mysql-community-common-5.6.31-2.el6.x86_64 conflicts with file from package mysql55w-libs-5.5.49-1.w6.x86_64
  file /usr/share/mysql/charsets/keybcs2.xml from install of mysql-community-common-5.6.31-2.el6.x86_64 conflicts with file from package mysql55w-libs-5.5.49-1.w6.x86_64
  file /usr/share/mysql/charsets/koi8r.xml from install of mysql-community-common-5.6.31-2.el6.x86_64 conflicts with file from package mysql55w-libs-5.5.49-1.w6.x86_64
  file /usr/share/mysql/charsets/koi8u.xml from install of mysql-community-common-5.6.31-2.el6.x86_64 conflicts with file from package mysql55w-libs-5.5.49-1.w6.x86_64
  file /usr/share/mysql/charsets/latin1.xml from install of mysql-community-common-5.6.31-2.el6.x86_64 conflicts with file from package mysql55w-libs-5.5.49-1.w6.x86_64
  file /usr/share/mysql/charsets/latin2.xml from install of mysql-community-common-5.6.31-2.el6.x86_64 conflicts with file from package mysql55w-libs-5.5.49-1.w6.x86_64
  file /usr/share/mysql/charsets/latin5.xml from install of mysql-community-common-5.6.31-2.el6.x86_64 conflicts with file from package mysql55w-libs-5.5.49-1.w6.x86_64
  file /usr/share/mysql/charsets/latin7.xml from install of mysql-community-common-5.6.31-2.el6.x86_64 conflicts with file from package mysql55w-libs-5.5.49-1.w6.x86_64
  file /usr/share/mysql/charsets/macce.xml from install of mysql-community-common-5.6.31-2.el6.x86_64 conflicts with file from package mysql55w-libs-5.5.49-1.w6.x86_64
  file /usr/share/mysql/charsets/macroman.xml from install of mysql-community-common-5.6.31-2.el6.x86_64 conflicts with file from package mysql55w-libs-5.5.49-1.w6.x86_64
  file /usr/share/mysql/charsets/swe7.xml from install of mysql-community-common-5.6.31-2.el6.x86_64 conflicts with file from package mysql55w-libs-5.5.49-1.w6.x86_64
  file /usr/lib64/mysql/libmysqlclient.so.18 from install of mysql-community-libs-5.6.31-2.el6.x86_64 conflicts with file from package mysql55w-libs-5.5.49-1.w6.x86_64



I need help please... all website it down...

not help?¿
« Last Edit: June 21, 2016, 10:13:48 PM by robbyq »