Author Topic: Error at end of MYSQL backup script since 0.9.8.15 (Access denied for user root)  (Read 9257 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Since 0.9.8.15 (2016.-06-06) there is the following error and warning in the backup script i.e. in the "Daily MySQL Backup starting" section:

Code: [Select]
warning: /var/tmp/rpm-tmp.96Bmm9: Header V4 DSA/SHA1 Signature, key ID cd2efd2a: NOKEY
DBI connect(';;mysql_read_default_group=client','',...) failed: Access denied for user 'root'@'localhost' (using password: NO) at /usr/bin/pt-show-grants line 1338

Offline
*****
Hi, maybe you have changed mysql root password?
You can ask me to solve any problem with your server for some money in pm  ;)
Services Monitoring & RBL Monitoring
http://centos-webpanel.com/services-monitor
Join our Development Team and get paid !
http://centos-webpanel.com/develope-modules-for-cwp

Installation Instructions
http://centos-webpanel.com/installation-instructions
Get Fast Support Here
http://centos-webpanel.com/support-services

Offline
*
Hi.


Thank you for your reply.

I did not change it, and I can still log-in in phpMyAdmin with the "MySQL root Pasword" that the CWP installer gave back in February, when I installed CWP on the VPS.

What I did change related to MySQL is that I used the CWP upgrade script to 5.5 months ago (but I think that was way before the issue occurred, the issue started exactly on the day where it upgraded to 0.9.8.15 (it's the last email that says 0.9.8.14, but the typical no update something line is missing, meaning it updated exactly on that day as it usually does)) and also I lately upgraded manually to 5.6, which was a bit complicated, but the issue is still the same.


I'd be interested if other users have a similar problem (maybe they don't read the log that closely) or if it's only me.


With kind regards

Offline
*
the error clearly says that he can not login to mysql with username root and using no password to login. so the backup script wants a password. and it can not be empty. that what it basicly says. it looks like that you changed the default mysql password from the installation. so now the backup script does not know it anymore and he can not make backup.i guess you delete /root/my.cnf file that is where the password was. but you right i just ckeck my email from the daily backup and i have same issue. and i did not delete the file and i still have not changed the password. so i goto check what is going and and i let you know how to fix it.

Offline
*
so found out why DBI::MYSQL is a Unix Socket where he connect to mysql.
But the MySQL server listen on TCP/IP and your MySQL server only listens on ip + port. but he needs to do both unix and ip.

Offline
*
i restarted the firewall and run the daily backup with
/usr/local/cwp/php54/bin/php -d max_execution_time=1000000 -q /usr/local/cwpsrv/htdocs/resources/admin/include/cron_backup.php

and got no error. lets see tomorrow

Offline
*
Anything new in this issue?