Author Topic: Enable NAT button keeps on coming even NAT is enable  (Read 5258 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Enable NAT button keeps on coming even NAT is enable
« on: August 10, 2016, 01:05:08 AM »
WARNING! Possible NAT networking detected, if you are using NAT-ed network then please enable NAT.
error message is coming even NAT has been enabled and Vhosts have been rebuild. Simply deactivate that error is not an option. I like to know issue to solve it and not simply ignore.

Offline
*
Re: Enable NAT button keeps on coming even NAT is enable
« Reply #1 on: May 15, 2020, 05:24:28 PM »
I have this error too  even though I have a static IP at a datacenter, CWP is somehow "autodetecting" a NAT'd IP address. I have to dismiss the alert regularly.

Offline
*
Re: Answering my own question
« Reply #2 on: May 15, 2020, 05:43:04 PM »
I'll answer my own question out of posterity, in case it will help someone else. Turns own the CentOS VM I was dabbling with had libvrtd enabled by default, instead of being a lean mean LAMP stack. So to fix the problem, you have to get rid of the virb0 and virbr0-nic virtual bridge interfaces.
Code: [Select]
systemctl stop libvirtd.service
systemctl disable libvirtd.service
brctl show
ip link set virbr0 down
brctl delbr virbr0
brctl show
ifconfig -a
Reboot if necessary and you should be left with just your primary en and loopback interfaces.

Offline
*
Re: Enable NAT button keeps on coming even NAT is enable
« Reply #3 on: May 20, 2020, 02:50:47 PM »
Well, it went away for a day or two, but now the NAT settings detection dialog box still keeps coming back, even with no virtual bridges. A frequent annoyance to be sure.

Offline
*
Re: Enable NAT button keeps on coming even NAT is enable
« Reply #4 on: May 20, 2020, 05:13:48 PM »
This fix appears to work. Edit  /usr/local/apache/conf/sharedip.conf. Change the first line to read:
Code: [Select]
<VirtualHost *:80>Voila  no more erroneous NAT nag screen.

Offline
*
Re: Enable NAT button keeps on coming up
« Reply #5 on: July 01, 2020, 02:45:02 PM »
Actually, I spoke too soon. After the next reboot & login, the NAT nag screen has returned. I can't see any obvious reason why, since my IP setup is static. On one server, it was setup without NetworkManager with static IF configs; the other 2 servers were setup with nmtui and set as static connections.