Author Topic: [SOLVED] PHP Selector installs Apache from Yum  (Read 4215 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
[SOLVED] PHP Selector installs Apache from Yum
« on: November 15, 2016, 12:18:01 AM »
Hey,
I need some help with Apache and PHP Selector. When I install dependencies it seems to install Apache 2.2.15 from Yum. This effects installed domains with Let's Encrypt SSL certificates. These domains don't load.

I remove Apache using yum remove and restart the server which makes all domains work again.

The problem, I cannot use the .htaccess commands to set a folder to use another PHP version.

What do I do?
« Last Edit: November 20, 2016, 07:58:12 AM by LifeSteala »

Offline
*
Re: [SOLVED] PHP Selector installs Apache from Yum
« Reply #1 on: November 20, 2016, 08:00:40 AM »
I managed to fix this. I read the php-selector-build.log and it says you have to add paths to PHP include_path variable.

I added this to CWP php.ini file:

Code: [Select]
include_path = "/opt/alt/php56:/opt/alt/php7/usr/lib/php"
I can now choose which PHP version I want using .htaccess files.

This should be added to the wiki.