Author Topic: Apache crashed with failed phpv7.0 install with the PHP Selector.  (Read 7118 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Crashed.....when trying to install php v7.x in the php selector.

part of log.

Nothing to do
buildconf: checking installation...
buildconf: autoconf version 2.63 (ok)
rebuilding aclocal.m4
rebuilding configure
configure.ac:276: error: Autoconf version 2.64 or higher is required
build/ax_check_compile_flag.m4:60: AX_CHECK_COMPILE_FLAG is expanded from...
autom4te: /usr/bin/m4 failed with exit status: 63
rebuilding main/php_config.h.in
configure.ac:276: error: Autoconf version 2.64 or higher is required
build/ax_check_compile_flag.m4:60: AX_CHECK_COMPILE_FLAG is expanded from...
autom4te: /usr/bin/m4 failed with exit status: 63
autoheader: '/usr/bin/autom4te' failed with exit status: 63
/usr/local/cwp/.conf/php_conf/php7.conf: line 1: ./configure: No such file or directory
make: *** No targets specified and no makefile found.  Stop.
make: *** No rule to make target `install'.  Stop.
Stopping httpd: [  OK  ]
Starting httpd: (98)Address already in use: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs
[FAILED]

Build Completed
###################

After a reboot it came with message

WARNING! You are not running CWP Apache and this could cause that your domains do not work!

under service status:
Apache Webserver      httpd dead but subsys locked

How to fix httpd dead but subsys locked?
« Last Edit: February 18, 2017, 04:46:35 PM by TheRavenKing »

Offline
*****
Re: Apache crashed with failed phpv7.0 install with the PHP Selector.
« Reply #1 on: February 19, 2017, 06:45:50 AM »
"
WARNING! You are not running CWP Apache and this could cause that your domains do not work!"
click on fix it

Offline
*
Re: Apache crashed with failed phpv7.0 install with the PHP Selector.
« Reply #2 on: February 19, 2017, 11:14:59 AM »
@Sandeep,  sure I pressed fix it.

But I have 2 issues.

- I can't install php v.7 with the PHP selector.
- Apache Webserver      httpd dead but subsys locked

So, what's cwp going to do about it?

Offline
*
Re: Apache crashed with failed phpv7.0 install with the PHP Selector.
« Reply #3 on: February 19, 2017, 01:58:56 PM »
I have same problem.. But Apache is working without problem.