Author Topic: Session Cache is not configured.  (Read 19848 times)

0 Members and 1 Guest are viewing this topic.

Session Cache is not configured.
« on: March 24, 2017, 01:19:53 AM »
I'm seeing this message in my Apache error log (error.log):

[warn] Init: Session Cache is not configured [hint: SSLSessionCache]

Unfortunately I haven't had much success in resolving the message not to mention I'm not entirely certain if it needs resolving.

Here's the error log, after being cleared and httpd restarted:
Code: [Select]
[Thu Mar 23 18:06:48.070518 2017] [mpm_event:notice] [pid 22068:tid 140480764557
184] AH00492: caught SIGWINCH, shutting down gracefully
[Thu Mar 23 18:06:50.000176 2017] [ssl:warn] [pid 22272:tid 140431233562496] AH0
1873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Thu Mar 23 18:06:50.002419 2017] [mpm_event:notice] [pid 22272:tid 140431233562
496] AH00489: Apache/2.4.25 (Unix) OpenSSL/1.0.1e-fips configured -- resuming no
rmal operations
[Thu Mar 23 18:06:50.002449 2017] [core:notice] [pid 22272:tid 140431233562496]
AH00094: Command line: '/usr/local/apache/bin/httpd'

Your thoughts, suggestions and solutions are welcomed!  :)


Re: Session Cache is not configured.
« Reply #1 on: March 24, 2017, 01:40:01 AM »
FWIW, I may have found a resolve by adding the following to /usr/local/apache/conf/httpd.conf

Code: [Select]
SSLSessionCache memcache:
LoadModule socache_memcache_module modules/

Technically I simply removed the '#' from LoadModule socache_memcache_module modules/ within the /usr/local/apache/conf/httpd.conf file.

Apache restarted without the error and yes, I do have memcached enabled and configured on the server; including PHP support for three (3) switchable PHP versions.

The next question is there any benefit to using memcache as opposed to shmbc in reference to SSLSessionCache and does this make any difference being that I'm not loading, as I understand SSL support is provided via OpenSSL? (Yes, my site uses SSL via Let's Encrypt Cert., FWIW).

Your thoughts and suggestions are highly welcomed!


Re: Session Cache is not configured.
« Reply #2 on: August 30, 2019, 10:48:25 PM »
hi VPREATR, i to ran into this error not so long ago,
while trying your example as a fix, i still encountered the error.
a little research for possible reasons/benefits, for and against very from forum to forum.
how ever i did find a good working fix, so thought it might help others

LoadModule socache_memcache_module modules/
SSLSessionCache memcache:memcache.CHANGE-THIS-TO-SERVER-NAME.COM:11211
SSLSessionCacheTimeout 3600

add to the httpd.conf and stop/start Apache.