Author Topic: Cannot Access Accounts via IP address ~/username  (Read 7106 times)

0 Members and 1 Guest are viewing this topic.

Cannot Access Accounts via IP address ~/username
« on: May 19, 2017, 06:09:48 PM »
I noticed this issue a few weeks ago.  I solved the issue on a production server making sure that every account had a qualified domain name.  This made all the accounts work but the accounts are still not accessible by the IP.

Last night I updated my development VM and today the same issues were happening on the dev server.  There are no qualified domain names on the dev server so I can only access the accounts via IP address ~/username

To troubleshoot I turned back the dev vm to the last working snapshot.
- Everything was working
- Trying to recreate my steps that broke the accounts I did a yum update (CWP Settings > Yum Manager > Update All)
- I again tested the accounts via IP~/username and everything was working
- I rebooted the VM to apply all of the updates and the accounts were broken

Here is what happens:
- when I access the IP for the server I get the site that is the first (top) site in the vhosts.conf (note that the server IP should give the file that is specified in the httpd.conf file DocumentRoot "/usr/local/apache/htdocs")
- when trying to access any account as http://ip~/username the browser displays a 500 server error.  There is no error in the Apache error_log but the Apache access_log shows a 500 server error.

I've been able to reproduce this on 3 servers now.  Any help with this would be appreciated.

Re: Cannot Access Accounts via IP address ~/username
« Reply #1 on: May 26, 2017, 02:42:32 PM »
Update:  Today I added a new account.  Again (like all the other accounts) this did not have a qualified domain name.  I used a uniquename.local.  The yum updates were not applied to the server (as in the previous post) and the same issue is happening.

All of the accounts going to http://ip/~account are showing a 500 Internal Server Error.

When going to http://ip I am not getting the website delivered from the root indicated in the httpd.conf file but the root is delivering the first account that is listed in the vhosts.conf.  None of the other hosts in the vhosts file work.