Author Topic: HTTPD Issues - Will not start  (Read 9590 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
HTTPD Issues - Will not start
« on: August 29, 2017, 02:03:29 AM »
Hi all,

I have run into a problem with httpd not starting, even after reboots. When I try to start it I get the following error

Code: [Select]
Starting httpd: httpd: Syntax error on line 499 of /usr/local/apache/conf/httpd.conf: Syntax error on line 1 of /usr/local/apache/conf.d/suphp.conf: Cannot load modules/mod_suphp.so into server: /usr/local/apache/modules/mod_suphp.so: undefined symbol: ap_log_rerror
[FAILED]

The httpd.conf have 499 lines and the last ones are these

Code: [Select]
ExtendedStatus On
Include /usr/local/apache/conf/sharedip.conf
Include /usr/local/apache/conf.d/*.conf

here's the suphp.conf

Code: [Select]
LoadModule suphp_module modules/mod_suphp.so
suPHP_Engine on
AddType application/x-httpd-php .php5 .php4 .php .php3 .php2 .phtml
<Directory />
        suPHP_AddHandler application/x-httpd-php
</Directory>
#suPHP_UserGroup nobody nobody
suPHP_AddHandler application/x-httpd-php44
suPHP_AddHandler application/x-httpd-php52
suPHP_AddHandler application/x-httpd-php53
suPHP_AddHandler application/x-httpd-php54
suPHP_AddHandler application/x-httpd-php55
suPHP_AddHandler application/x-httpd-php56
suPHP_AddHandler application/x-httpd-php7

Business server is down right now. Any help would be appreciated.

Offline
*
Re: HTTPD Issues - Will not start
« Reply #1 on: August 29, 2017, 09:09:20 AM »
try this command
Code: [Select]
yum reinstall cwp-suphp
VPS & Dedicated server provider with included FREE Managed support for CWP.
http://www.studio4host.com/

*** Don't allow that your server or website is down, choose hosting provider with included expert managed support for your CWP.

Offline
*
Re: HTTPD Issues - Will not start
« Reply #2 on: August 29, 2017, 09:29:48 AM »
Okay, that got a little further. Now there is another error coming up:

Code: [Select]
Starting httpd: AH00526: Syntax error on line 2 of /usr/local/apache/conf.d/ssl.conf:
Invalid command 'SSLProtocol', perhaps misspelled or defined by a module not included in the server configuration
[FAILED]

Pulled the file and:

Code: [Select]
Listen 443
SSLProtocol All -SSLv2 -SSLv3
SSLHonorCipherOrder on
SSLCipherSuite ECDH+AESGCM:DH+AESGCM:ECDH+AES256:DH+AES256:ECDH+AES128:DH+AES:E$

NameVirtualHost 23.111.69.102:443

Offline
*
Re: HTTPD Issues - Will not start
« Reply #3 on: August 29, 2017, 11:03:39 AM »
then run this commands one by one

Code: [Select]
yum reinstall cwp-httpd
yum reinstall cwp-php
yum reinstall cwp-suphp
VPS & Dedicated server provider with included FREE Managed support for CWP.
http://www.studio4host.com/

*** Don't allow that your server or website is down, choose hosting provider with included expert managed support for your CWP.

Offline
*
Re: HTTPD Issues - Will not start
« Reply #4 on: August 30, 2017, 12:05:20 AM »
Ran the three commands and still getting the following when trying to run HTTPD

Code: [Select]
Starting httpd: AH00526: Syntax error on line 2 of /usr/local/apache/conf.d/ssl.conf:
Invalid command 'SSLProtocol', perhaps misspelled or defined by a module not included in the server configuration
[FAILED]

Offline
*
Re: HTTPD Issues - Will not start - RESOLVED
« Reply #5 on: August 30, 2017, 12:18:35 AM »
Code: [Select]
Figured it out!

edited /usr/local/apache/conf.d/ssl.conf and add this into it

Code: [Select]
<IfModule !ssl_module>
LoadModule ssl_module modules/mod_ssl.so
</IfModule>

httpd works now and was able to auto the ssl on the other addon domain that I had been working on.

Thanks! Would not have been able to get it fixed without your help.

Offline
*
Re: HTTPD Issues - Will not start
« Reply #6 on: March 29, 2018, 08:06:24 AM »
Hey,
i have the same Problem after Rebuild my Apache Re-Build!

But I can not reinstall my httpd and my suphp.

My error message translated in the terminal.

Code: [Select]
Loaded plugins: fastestmirror, presto, replace
Set up the reinstallation process
No match for argument: cwp-httpd
Loading mirror speeds from cached hostfile
  * base: ftp.plusline.de
  * extras: ftp.rz.uni-frankfurt.de
  * rpmforge: mirror.de.leaseweb.net
  * updates: mirror.23media.de
Package (s) cwp-httpd available but not installed.
Mistake: Nothing to do

Offline
*****
Re: HTTPD Issues - Will not start
« Reply #7 on: April 05, 2018, 06:12:42 AM »
Hello.

Seems like you do not have the cwp repo.

Code: [Select]
[root ~]# cat /etc/yum.repos.d/cwp.repo
[cwp]
name=CentOS Web Panel repo for Linux 6 - $basearch
baseurl=http://repo.centos-webpanel.com/repo/6/$basearch
failovermethod=priority
enabled=1
gpgcheck=0
[root ~]#
You can ask me to solve any problem with your server for some money in pm  ;)
Services Monitoring & RBL Monitoring
http://centos-webpanel.com/services-monitor
Join our Development Team and get paid !
http://centos-webpanel.com/develope-modules-for-cwp

Installation Instructions
http://centos-webpanel.com/installation-instructions
Get Fast Support Here
http://centos-webpanel.com/support-services

Offline
*
Re: HTTPD Issues - Will not start
« Reply #8 on: March 31, 2019, 03:01:26 PM »
Hey guys,

I have the same exact problem. My server was working and I guess some updates ruined it and not I cant start the http again.

Tried all this bun when I do yum reinstall cwp-suphp I get this:

Code: [Select]
[root@webserver ~]# yum reinstall cwp-suphp
Loaded plugins: fastestmirror
Setting up Reinstall Process
No Match for argument: cwp-suphp
Loading mirror speeds from cached hostfile
 * base: centos.mirrors.benatherton.com
 * extras: centos.mirrors.benatherton.com
 * remi-safe: remi.mirror.ate.info
 * rpmforge: mirrors.ircam.fr
 * updates: centos.mirrors.benatherton.com
Package(s) cwp-suphp available, but not installed.
Error: Nothing to do

Any help ?

Offline
*****
Re: HTTPD Issues - Will not start
« Reply #9 on: April 03, 2019, 06:27:46 AM »
Hello.

Try the command below:
Code: [Select]
yum --enablerepo=cwp install cwp-suphp
If you still have the problem show what do you see with:
Code: [Select]
yum --enablerepo=cwp repolist
Hey guys,

I have the same exact problem. My server was working and I guess some updates ruined it and not I cant start the http again.

Tried all this bun when I do yum reinstall cwp-suphp I get this:

Code: [Select]
[root@webserver ~]# yum reinstall cwp-suphp
Loaded plugins: fastestmirror
Setting up Reinstall Process
No Match for argument: cwp-suphp
Loading mirror speeds from cached hostfile
 * base: centos.mirrors.benatherton.com
 * extras: centos.mirrors.benatherton.com
 * remi-safe: remi.mirror.ate.info
 * rpmforge: mirrors.ircam.fr
 * updates: centos.mirrors.benatherton.com
Package(s) cwp-suphp available, but not installed.
Error: Nothing to do

Any help ?
You can ask me to solve any problem with your server for some money in pm  ;)
Services Monitoring & RBL Monitoring
http://centos-webpanel.com/services-monitor
Join our Development Team and get paid !
http://centos-webpanel.com/develope-modules-for-cwp

Installation Instructions
http://centos-webpanel.com/installation-instructions
Get Fast Support Here
http://centos-webpanel.com/support-services

Offline
*
Re: HTTPD Issues - Will not start
« Reply #10 on: July 04, 2019, 03:08:26 AM »
This fixed it for me:

Modsecurity config file had some bad code. I set that back to default and everything starts.

As admin, go to Security>Mod Security

Click "Edit Rules" next to each one, and hit the "Edit File" link at the bottom.

Shows you the contents of:
"/usr/local/apache/conf/userdata/USERNAME/example.com/modsec.conf"

Mine was basically corrupted. I set back to:

<IfModule mod_security2.c>
SecRuleEngine On
</IfModule>

If your file is fine, try checking the other related security files. If you ever tried to manually edit any of those, it is a good chance thats the problem. Could just be a missing > or duplicate code.

Hope it helps someone else!