php7.x installation fails

Started by n8v8r, January 22, 2018, 12:18:17 PM

Previous topic - Next topic

n8v8r

Could the switch of the libzip libraries have messed up PHP-FPM? I am now getting this warning which I do not recall happening prior to the switch
QuoteNOTICE: PHP message: PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib64/php/modules/zip.so' - libzip.so.2: cannot open shared object file: No such file or directory in Unknown on line 0
The file zip.so is available in named location but perhaps it got upgraded to a version that PHP-FPM cannot handle? If so how to revert/uninstall rpm libzip-1.4.0?

bullten

Hello,

I dont think that would cause issue.

n8v8r

Nonetheless the issue is there and though I cannot be 1oo% sure ti seems related and would prefer PHP-FPM not having any issues. Either get PHP-FPM to recognize the available files or revert/downgrade the libzip library and see whether it heals the matter.

Is there an uninstall script for safe removal, assuming that there are systemlinks as shared library in place?

bullten

May i know how I can replicate the issue?

n8v8r

#19
Not sure, my system specification are posted and we went (with thanks) that far as to get the PHP7.x resources compiled/installed. As I said I cannot be 100% sure but prior this exercise PHP-FPM did not report this. The file in question is present


reading the error it seems that zip.so is calling another dependency (zip.so' - libzip.so.2), which may not be present on the system but might have prior installing libzip 1.4, or might have different path or call routine than PHP-FPM is expecting.


bullten


n8v8r

do I not have to remove libzip1.4 first to avoid any conflict, or shall there be none?

bullten


n8v8r

done and the error is gone, php-fpm reporting no issues.

I just hope there will be no confusion/confilcts between the versions



jijib

Tried to install php 7.4.7 on the latest CWP 0.9.8.993, got the error :

Quotechecking for libzip... configure: error: system libzip must be upgraded to version >= 0.11

What fix it for me was installing the pychothic ninja repo then running:

rpm --import http://wiki.psychotic.ninja/RPM-GPG-KEY-psychotic
rpm -ivh http://packages.psychotic.ninja/6/base/i386/RPMS/psychotic-release-1.0.0-1.el6.psychotic.noarch.rpm


yum --enablerepo=psychotic-plus install libzip-devel


Then you just start the desired build and it works.