Author Topic: Problem with AutoSSL Tab in Module SSL Certificates  (Read 20247 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Problem with AutoSSL Tab in Module SSL Certificates
« on: June 24, 2018, 04:06:32 PM »
I'm not sure if this is the official place to report a bug, but here goes . . .

I was running version 0.9.8.671 when I first encountered this error. I've upgraded to 0.9.8.672 and it's still a problem (CWP Pro).

When I select a User to install an SSL certificate, the Domain dropdown remains empty.

It would seem that an apostrophe (') in the word "doesn't" needs to be escaped in the javascript function validatevhostssl. the offending line is:

Code: [Select]
text: 'DNS of your domain doesn't point to this server or you have htaccess restrictions',
A quick fix would be very much appreciated.

Kind regards

Offline
***
Re: Problem with AutoSSL Tab in Module SSL Certificates
« Reply #1 on: June 25, 2018, 02:25:30 AM »
The only way to report a bug is to contact CWP team directly at http://centos-webpanel.com/contact

I have reported several bugs using this link and they honor and fix the issues.

Offline
**
Re: Problem with AutoSSL Tab in Module SSL Certificates
« Reply #2 on: June 27, 2018, 09:43:00 AM »
Yeah, I had this issue too. There's a couple of things to consider.

1. When I create a new account I stop using the AutoSSL to install at that time. I do it later. Unless your DNS templates working perfectly.

2. After created the account, I go to the DNS Function >> DNS List Zones >> Edit Records for the domain just created. I don't use CNAME for www. I changed that to A. And you will have to use ip address instead of your domain.

3. When all of my DNS Records look good then I log into User control panel. There I use AutoSSL.

4. If that failed then I will go to Admin control panel. Apache Settings > SSL Certification > AutoSSL [FREE]

NOTE. If you create new certifications then delete, there's a limit that Let's Encrypt allows. Then you will have to wait for them to reset before you can create it again. On their site it said 1 week.

Offline
*
Re: Problem with AutoSSL Tab in Module SSL Certificates
« Reply #3 on: June 27, 2018, 10:34:57 AM »
Please confirm if you do not have any .htaccess in the domain path that prevents the creation and reading of new directories.

Offline
*
Re: Problem with AutoSSL Tab in Module SSL Certificates
« Reply #4 on: November 13, 2018, 02:38:35 AM »
I just created a domain that points to my dns, there is no htaccess, and that blessed message, not even give clues to solve it.

Offline
*
Re: Problem with AutoSSL Tab in Module SSL Certificates
« Reply #5 on: November 24, 2018, 07:28:02 AM »
I have the same problem here .
Its a fresh install of CWP. I checked and there is no .htaccess file.
all sub domains are created using CWP zones.
I cant get certificate for main domains (i have 2) or any of subdomains (I have a few on each domain.)

I really need the ssl feature. one of the reasons I installed CWP is that I thought it would simplify this kind of process.

can anyone help on this ?


Offline
*
Re: Problem with AutoSSL Tab in Module SSL Certificates
« Reply #6 on: December 06, 2018, 09:48:38 PM »
I have the same problem from june. Since then, when I try to install an SSL certificate, the domain dropdown remains empty and the message "DNS of your domain doesn't point to this server or you have htaccess restrictions" appears.
I'm 100% sure that the DNS are good and no .htaccess file is bothering.
I've rebuilding the new webserver with php-fpm (actually version 0.9.8.745), but still no work.
Every else on the server works perfect, just the certificates problem.
A strange thing is that I can renew the certificates for the domains that I have already added, and works perfect.

Offline
*
Re: Problem with AutoSSL Tab in Module SSL Certificates
« Reply #7 on: December 10, 2018, 07:53:24 PM »
After doing all kinds of tests, I managed to realize that the problem is the web browser. When using Safari or Chrome, at least in macOS, the domain drop-down menu does not open and the error appears, but when using Firefox it works perfectly.
I hope this helps someone else.

Offline
*
Re: Problem with AutoSSL Tab in Module SSL Certificates
« Reply #8 on: December 16, 2018, 06:56:18 PM »
I have that problem too , in my case was  :
WebServer Settings - select Nginx & Apache - Force Apache to use PHP-FPM - Save and rebuild
www.MiddoWeb.com - web services.
www.SysAdmin20.com - sysadmin 2.0

Offline
*
Re: Problem with AutoSSL Tab in Module SSL Certificates
« Reply #9 on: May 29, 2019, 11:50:59 AM »
Facing the same.

Offline
*
Re: Problem with AutoSSL Tab in Module SSL Certificates
« Reply #10 on: October 14, 2019, 09:15:00 AM »
The Solution for me was, do not use force-https-http2 at the begining! the first time, default must be selected as webserver, after creating the certificate this can be changed.

Offline
*
Re: Problem with AutoSSL Tab in Module SSL Certificates
« Reply #11 on: February 19, 2020, 10:34:29 AM »
I have the same issue, I have other domains that worked. Yet not the this current one, I have removed it added it again, I have completely removed the .htaccess file, and yet I keep getting this simple message DNS of your domain doesn't point to this server or you have htaccess restrictions which can not be true, since this domain indeed points to my server for three days already.

Offline
*****
Re: Problem with AutoSSL Tab in Module SSL Certificates
« Reply #12 on: February 19, 2020, 03:30:58 PM »
The upgraded autossl module will be fixed via next updates.

Offline
*
Re: Problem with AutoSSL Tab in Module SSL Certificates
« Reply #13 on: February 19, 2020, 07:56:25 PM »
So Sandeep, are we to understand that installing the LetsEncrypt SSL certificates is not possible for the time being?
Can you let us know when this will be resolved?  Do you have a projected date for next update to CWP?

It looks like my hosting endeavors will be on hold for new domains until then, and I am just trying to get a hold on when I might be able to resume.

Any further help or information would be great.

Offline
*
Re: Problem with AutoSSL Tab in Module SSL Certificates
« Reply #14 on: February 19, 2020, 08:36:32 PM »
This problem happens when there is something that redirects your domain to https before having the ssl created,

In order to generate the ssl you must ensure:

That the domain is pointed to your server
That the domain for any reason has some redirection to https or other domain

That  webservers  is active and running