Author Topic: CWP to CWP account migration doesnot transfer anything.  (Read 11992 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Re: CWP to CWP account migration doesnot transfer anything.
« Reply #30 on: July 11, 2020, 04:00:41 PM »
Additional Update:
Attempting Method 1 CWP->CWP Migration again, here are my results... still not fully migrated.

1. Does not transfer Softaculous statistics and installation information.
2. The actual applications installed by Softaculous do work.
3. Loss of Softaculous management of already installed applications.
4. Email accounts did not transfer.
5. Domain SSL information did transfer.

End Result:  Mostly working... sort of.

Offline
*
Re: CWP to CWP account migration doesnot transfer anything.
« Reply #31 on: August 17, 2020, 05:14:49 PM »
Final Update (Works Successfully):
Attempting Method 1 CWP->CWP Migration again, here are my results... fully migrated.

Both CWP Server versions are the same:  CWPpro version: 0.9.8.1002

1. Does not transfer Softaculous statistics and installation information.
    UPDATE:  Softaculous information transferred (all that was required).
2. The actual applications installed by Softaculous do work.
    UPDATE:  Softaculous confirmed.  Applications are working.
3. Loss of Softaculous management of already installed applications.
    UPDATE:  Management of already installed applications is working.
4. Email accounts did not transfer.
    UPDATE:  All email will transfer but must manually add mail accounts using control panel.
5. Domain SSL information did transfer.
    UPDATE:  All SSL information did transfer but must manually re-activate certificates.

End Result:  CWP->CWP Migration Worked.

Perhaps is was a lack of understanding in previous attempts using the migration tool.  However, I am still unsuccessful using both backup and restore options to effectively migrate user accounts.  I performed the CWP->CWP migration over two external IP addresses.  Initial attempts were using internal IP addresses.  Another note, the CWPpro version is also updated.

Suggestions:
1. Please be sure to open ports 2304 and 22 (unless changed) on both internal and external firewalls.
2. Run /scripts/check_api User API in the CWP terminal to confirm correct operation of port 2304 .
    OUTPUT:
    User API port 2302 check: OK
    Oauth query check: OK
    User API folder check: OK
    External API port 2304 check: OK
    External API files and htaccess : OK
    CSF Firewall status check: ENABLED
    TCP_IN for port 2304 set in /etc/csf/csf.conf: OK
    TCP_OUT for port 2304 set in /etc/csf/csf.conf: OK

Offline
*
Re: CWP to CWP account migration doesnot transfer anything.
« Reply #32 on: September 14, 2020, 02:46:05 PM »
Im trying a CWP to CWP account migration too. Both servers are CWPpro version: 0.9.8.1008 and I dont user email accounts.
/scripts/check_api is OK:
Code: [Select]
User API port 2302 check: OK
Oauth query check: OK
User API folder check: OK
External API port 2304 check: OK
External API files and htaccess : OK
CSF Firewall status check: ENABLED
TCP_IN for port 2304 set in /etc/csf/csf.conf: OK
TCP_OUT for port 2304 set in /etc/csf/csf.conf: OK

I can see the origin server from cwp_to_cwp with the list of all origin accounts, but every account migrations gives me the same error:
Code: [Select]
[2020-09-14 14:17:13] - Start import process CWPTOCWP_20200914141713
[2020-09-14 14:17:20] - Import Account myaccount
[2020-09-14 14:17:20] - Create Backup Account myaccount
[2020-09-14 14:17:23] - Start Transfer Backup myaccount
[2020-09-14 10:17:27] - Account Create Error myaccount

If I give a look at the detailed migration log /home/.CWPTOCWP_20200914141713/myuser.json I get:
Code: [Select]
{
    "BACKUP_ID": "myaccount202009141417150826b5c04738bedcc5ebc17dc643e103",
    "FILE_NAME": "cwpmove-myaccount.tar.gz",
    "FILE_BACKLOG": "master.log",
    "FILE_BACK_ELOG": "",
    "STATUS": "11",
    "LOGS": " [2020-09-14 14:17:22] - Start Backup myaccount<br> [2020-09-14 14:17:22] -  Create Backup Account myaccount<br> [2020-09-14 14:17:23] - Completed Backup myaccount <br>  [2020-09-14 10:17:26] - Start Transfer Backup myaccount<br> [2020-09-14 10:17:26] -  Start Transfer Backup myaccount<br>  [2020-09-14 10:17:26] - Transfer Backup Completed myaccount<br> [2020-09-14 10:17:27] - Account Create Error Check All Fields (only lower caps are allowed and no special characters or empty spaces... myaccount<br>",
    "PERCENTAGE": 60
}

Reading: Account Create Error Check All Fields (only lower caps are allowed and no special characters or empty spaces... myaccount Ive tried replacing the account password with only lowercase and number characters but I get the same issue.

On the new server I can create new accounts and cPanel account restore works. Do you have suggestions better investigating the issue? A more detailed error log could help
« Last Edit: September 14, 2020, 03:14:59 PM by Teo »

Offline
*
Re: CWP to CWP account migration doesnot transfer anything.
« Reply #33 on: September 14, 2020, 02:48:55 PM »
Please check that the user does not exist in / etc / pass, shadow and group as well as that / home / USER does not exist

Offline
*
Re: CWP to CWP account migration doesnot transfer anything.
« Reply #34 on: September 14, 2020, 03:19:29 PM »
Please check that the user does not exist in / etc / pass, shadow and group as well as that / home / USER does not exist

Code: [Select]
cat /etc/passwd
cat /etc/group
ls -l /home/
gives no references about the users Im trying to migrate