Author Topic: Allowed IP's not set or you don't have access from IP  (Read 4586 times)

0 Members and 1 Guest are viewing this topic.

Offline
***
Allowed IP's not set or you don't have access from IP
« on: April 17, 2019, 12:24:19 AM »
I am trying to setup CWP API manager for billing module (Blesta).

I have Allowed New API access
Short Name = Blesta
IP Origin = <server IP> (where Blesta billing is installed)
Key Code = (the key given me by CWP)
Request = Json

I have copied the appropriate details into the Blesta Module, however the module is returning the following error

Allowed API's not set or you dont have access from IP : <blesta installation IP> (server where blesta is installed)

The Blesta developers believe there is a bug in CWP...ie the Allow API access is not functioning correctly?

I have disabled all security from CWP GUI and the error still exists!


Is there anyone here that has the knowledge to offer advice on this problem?

How do i fix this?

Offline
*****
Re: Allowed IP's not set or you don't have access from IP
« Reply #1 on: April 18, 2019, 05:49:51 AM »
Hi, try to contact to CWP developers.
You can ask me to solve any problem with your server for some money in pm  ;)
Services Monitoring & RBL Monitoring
http://centos-webpanel.com/services-monitor
Join our Development Team and get paid !
http://centos-webpanel.com/develope-modules-for-cwp

Installation Instructions
http://centos-webpanel.com/installation-instructions
Get Fast Support Here
http://centos-webpanel.com/support-services

Offline
*
Re: Allowed IP's not set or you don't have access from IP
« Reply #2 on: October 24, 2019, 11:33:26 AM »
I am trying to setup CWP API manager for billing module (Blesta).

I have Allowed New API access
Short Name = Blesta
IP Origin = <server IP> (where Blesta billing is installed)
Key Code = (the key given me by CWP)
Request = Json

I have copied the appropriate details into the Blesta Module, however the module is returning the following error

Allowed API's not set or you dont have access from IP : <blesta installation IP> (server where blesta is installed)

The Blesta developers believe there is a bug in CWP...ie the Allow API access is not functioning correctly?

I have disabled all security from CWP GUI and the error still exists!


Is there anyone here that has the knowledge to offer advice on this problem?

How do i fix this?
I have the same case,
 whether it has found the solution
« Last Edit: October 24, 2019, 11:44:11 AM by mcyahoo »

Offline
***
Re: Allowed IP's not set or you don't have access from IP
« Reply #3 on: October 24, 2019, 07:45:04 PM »
I stopped using Blesta in favour of whmcs (which is actually much better value for money anyway)