Author Topic: Apache Re-Build Not Working  (Read 931 times)

0 Members and 1 Guest are viewing this topic.

Apache Re-Build Not Working
« on: May 01, 2019, 12:00:40 AM »
Hi, this is not a question but a problem that took me hours to figure out. I found the cause of the problem and I have decided to post it here in case someone gets stuck with the same problem.

When I was trying to rebuild apache (2.4.39) in Centos 7, the whole process went through and it seemed like there were no errors. But after finishing rebuilding, the Apache server wouldn't start. Then a AI robot would fix it for me. (I guess the AI robot was simply doing a "yum remove cwp-httpd" and then doing a "yum install cwp-httpd")

This happened a few times until I discovered the server was missing a library: libuuid-devel

If installing the library (yum install libuuid-devel) everything worked fine.

Just wanted to put it out there in case somebody gets stuck trying to rebuild apache.

Re: Apache Re-Build Not Working
« Reply #1 on: July 18, 2019, 12:33:20 AM »
Thank you ! Congratulations on your help! It worked very well for me, I did not know much what to do and your help saved me!

thank you