Author Topic: not found - doesn't exist  (Read 21079 times)

0 Members and 1 Guest are viewing this topic.

* not found - doesn't exist
« on: March 16, 2015, 09:04:02 AM »
I have tried to install ffmpeg through the installer many, many times, but never got it to work.

All seems to go OK, no errors and when doing the following commands all seems to be ok.

Code: [Select]
[root@localhost /]# whereis ffmpeg
ffmpeg: /usr/bin/ffmpeg /usr/share/ffmpeg /usr/share/man/man1/ffmpeg.1.gz

Code: [Select]
[root@localhost /]# ffmpeg
ffmpeg version 2.2.1 Copyright (c) 2000-2014 the FFmpeg developers
  built on Apr 13 2014 13:00:18 with gcc 4.4.6 (GCC) 20120305 (Red Hat 4.4.6-4)
  configuration: --prefix=/usr --libdir=/usr/lib64 --shlibdir=/usr/lib64 --mandir=/usr/share/man --enable-shared --enable-runtime-cpudetect --enable-gpl --enable-version3 --enable-postproc --enable-avfilter --enable-pthreads --enable-x11grab --enable-vdpau --disable-avisynth --enable-frei0r --enable-libopencv --enable-libdc1394 --enable-libgsm --enable-libmp3lame --enable-libnut --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-librtmp --enable-libspeex --enable-libtheora --enable-libvorbis --enable-libvpx --enable-libx264 --enable-libxavs --enable-libxvid --extra-cflags='-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -fPIC' --disable-stripping
  libavutil      52. 66.100 / 52. 66.100
  libavcodec     55. 52.102 / 55. 52.102
  libavformat    55. 33.100 / 55. 33.100
  libavdevice    55. 10.100 / 55. 10.100
  libavfilter     4.  2.100 /  4.  2.100
  libswscale      2.  5.102 /  2.  5.102
  libswresample   0. 18.100 /  0. 18.100
  libpostproc    52.  3.100 / 52.  3.100
Hyper fast Audio and Video encoder
usage: ffmpeg [options] [[infile options] -i infile]... {[outfile options] outfile}...

Use -h to get full help or, even better, run 'man ffmpeg'

Even the following line is added in php.ini
Code: [Select]
So all should be OK, but it isn't...

I have tried to find, but that isn't anywhere on my system.
Code: [Select]
[root@localhost ~]# find / -name
[root@localhost ~]#

By accident I did a PHP grep and this gave the following error

Code: [Select]
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib64/extensions/no-debug-non-zts-20100525/' - /usr/lib64/extensions/no-debug-non-zts-20100525/ cannot open shared object file: No such file or directory in Unknown on line 0
So it seems that the installation went OK, but in reality since is missing, it is never loaded and therefore doesn't work.

Does anybody have any idea as to how to fix this?


Re: not found - doesn't exist
« Reply #1 on: March 16, 2015, 12:51:17 PM »
what you need is ffmpeg-php extenion. I would suggest you to manually install it also automated installing of ffmpeg-php should never be done.

Re: not found - doesn't exist
« Reply #2 on: March 18, 2015, 01:44:09 PM »
This article can help you to correctly install ffmpeg in cwp. I see there is extension directory missing in php.ini. Complete all the steps and you are good to go.

Re: not found - doesn't exist
« Reply #3 on: March 18, 2015, 05:22:40 PM »
Excellent, thanks very much!

I did have to make some minor changes, but I now finally have ffmpeg installed and enabled on my server.

The thing I needed to change was:

- put full path to in php.ini

Thanks again for your help, much appreciated.

Re: not found - doesn't exist
« Reply #4 on: March 18, 2015, 05:30:49 PM »
Well you dont need to add full path in extension. If you set extension_dir like explained in the article then adding extention = "" would do the job.