Author Topic: Can not install php 5.6 and lower versions CWP - PRO  (Read 2259 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Can not install php 5.6 and lower versions CWP - PRO
« on: July 14, 2019, 09:40:39 PM »
Can not install php 5.6 and lower versions.
I am running CentOS Linux release 7.6.1810 (Core)
How could we install it? (we need 5.6 or lower versions)
When I try to install php through PHP-FPM Selector I get these errors:

/tmp/php-build/php-5.3.29/ext/dom/document.c:1214:5: warning: passing argument 2 of 'dom_get_ns' discards 'const' qualifier from pointer target type [enabled by default]
     nsptr = dom_get_ns(root, nodep->ns->href, &errorcode, nodep->ns->prefix);
     ^
In file included from /tmp/php-build/php-5.3.29/ext/dom/document.c:28:0:
/tmp/php-build/php-5.3.29/ext/dom/php_dom.h:109:10: note: expected 'char *' but argument is of type 'const xmlChar *'
 xmlNsPtr dom_get_ns(xmlNodePtr node, char *uri, int *errorcode, char *prefix);
          ^
/tmp/php-build/php-5.3.29/ext/dom/document.c:1214:5: warning: passing argument 4 of 'dom_get_ns' discards 'const' qualifier from pointer target type [enabled by default]
     nsptr = dom_get_ns(root, nodep->ns->href, &errorcode, nodep->ns->prefix);
     ^
In file included from /tmp/php-build/php-5.3.29/ext/dom/document.c:28:0:
/tmp/php-build/php-5.3.29/ext/dom/php_dom.h:109:10: note: expected 'char *' but argument is of type 'const xmlChar *'
 xmlNsPtr dom_get_ns(xmlNodePtr node, char *uri, int *errorcode, char *prefix);
          ^




/tmp/php-build/php-5.3.29/ext/fileinfo/libmagic/apprentice.c:781:4: warning: passing argument 1 of '_php_stream_opendir' discards 'const' qualifier from pointer target type [enabled by default]
    dir = php_stream_opendir(fn, REPORT_ERRORS, NULL);
    ^
In file included from /tmp/php-build/php-5.3.29/main/php.h:400:0,
                 from /tmp/php-build/php-5.3.29/ext/fileinfo/libmagic/apprentice.c:32:
/tmp/php-build/php-5.3.29/main/php_streams.h:339:20: note: expected 'char *' but argument is of type 'const char *'
 PHPAPI php_stream *_php_stream_opendir(char *path, int options, php_stream_context *context STREAMS_DC TSRMLS_DC);
                    ^




/tmp/php-build/php-5.3.29/ext/mcrypt/mcrypt_filter.c: In function 'php_mcrypt_filter_create':
/tmp/php-build/php-5.3.29/ext/mcrypt/mcrypt_filter.c:210:2: warning: passing argument 1 of 'mcrypt_module_open' discards 'const' qualifier from pointer target type [enabled by default]
  mcrypt_module = mcrypt_module_open(cipher, algo_dir, mode, mode_dir);
  ^
In file included from /usr/include/mcrypt.h:4:0,
                 from /tmp/php-build/php-5.3.29/ext/mcrypt/mcrypt_filter.c:25:
/usr/include/mutils/mcrypt.h:38:9: note: expected 'char *' but argument is of type 'const char *'
  MCRYPT mcrypt_module_open(char *algorithm,
         ^






/tmp/php-build/php-5.3.29/ext/mysqli/mysqli_api.c: In function 'php_add_field_properties':
/tmp/php-build/php-5.3.29/ext/mysqli/mysqli_api.c:1055:2: warning: passing argument 4 of 'add_property_string_ex' discards 'const' qualifier from pointer target type [enabled by default]
  add_property_string(value, "db", (field->db ? field->db : ""), 1);
  ^
In file included from /tmp/php-build/php-5.3.29/main/php.h:38:0,
                 from /tmp/php-build/php-5.3.29/ext/mysqli/mysqli_api.c:29:
/tmp/php-build/php-5.3.29/Zend/zend_API.h:420:14: note: expected 'char *' but argument is of type 'const char * const'
 ZEND_API int add_property_string_ex(zval *arg, const char *key, uint key_len, char *str, int duplicate TSRMLS_DC);
              ^




/tmp/php-build/php-5.3.29/ext/pdo/pdo.c: In function 'php_pdo_parse_data_source':
/tmp/php-build/php-5.3.29/ext/pdo/pdo.c:280:23: warning: initialization discards 'const' qualifier from pointer target type [enabled by default]
      char *orig_val = data_source + valstart;
                       ^



char *str = php_escape_html_entities((unsigned char*)Z_STRVAL_PP(tmp), Z_STRLEN_PP(tmp), &new_len, 0, 0, NULL TSRMLS_CC);
     ^
In file included from /tmp/php-build/php-5.3.29/ext/standard/php_standard.h:30:0,
                 from /tmp/php-build/php-5.3.29/ext/soap/php_soap.h:28,
                 from /tmp/php-build/php-5.3.29/ext/soap/soap.c:25:
/tmp/php-build/php-5.3.29/ext/standard/html.h:42:14: note: expected 'int *' but argument is of type 'size_t *'
 PHPAPI char *php_escape_html_entities(unsigned char *old, int oldlen, int *newlen, int all, int quote_style, char *hint_charset TSRMLS_DC);
              ^
/tmp/php-build/php-5.3.29/ext/soap/soap.c:4172:5: warning: passing argument 3 of 'php_escape_html_entities' from incompatible pointer type [enabled by default]
     char *str = php_escape_html_entities((unsigned char*)Z_STRVAL_PP(tmp), Z_STRLEN_PP(tmp), &new_len, 0, 0, NULL TSRMLS_CC);
     ^
In file included from /tmp/php-build/php-5.3.29/ext/standard/php_standard.h:30:0,
                 from /tmp/php-build/php-5.3.29/ext/soap/php_soap.h:28,
                 from /tmp/php-build/php-5.3.29/ext/soap/soap.c:25:
/tmp/php-build/php-5.3.29/ext/standard/html.h:42:14: note: expected 'int *' but argument is of type 'size_t *'
 PHPAPI char *php_escape_html_entities(unsigned char *old, int oldlen, int *newlen, int all, int quote_style, char *hint_charset TSRMLS_DC);
              ^




lcrypt   -o sapi/fpm/php-fpm
/usr/bin/ld: warning: libssl.so.10, needed by //usr/lib64/libssh2.so.1, may conflict with libssl.so.1.1
/usr/bin/ld: warning: libssl.so.10, needed by //usr/lib64/libssh2.so.1, may conflict with libssl.so.1.1
/usr/bin/ld: ext/openssl/xp_ssl.o: undefined reference to symbol 'SSLv3_server_method@@libssl.so.10'
//usr/lib64/libssl.so.10: error adding symbols: DSO missing from command line
collect2: error: ld returned 1 exit status
make: *** [sapi/fpm/php-fpm] Error 1
mkdir: cannot create directory '/opt/alt/php-fpm53/usr/var/sockets/': No such file or directory
mkdir: cannot create directory '/opt/alt/php-fpm53/usr/etc/php-fpm.d/': No such file or directory
mkdir: cannot create directory '/opt/alt/php-fpm53/usr/etc/php-fpm.d/users/': No such file or directory
/usr/local/src/php-fpm-5.3.sh: line 76: /opt/alt/php-fpm53/usr/etc/php-fpm.d/users.conf: No such file or directory
/usr/local/src/php-fpm-5.3.sh: line 77: /opt/alt/php-fpm53/usr/etc/php-fpm.conf: No such file or directory
/usr/local/src/php-fpm-5.3.sh: line 79: /opt/alt/php-fpm53/usr/etc/php-fpm.d/cwpsvc.conf: No such file or directory
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
Skipping as php build failed
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
Skipping as php build failed
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
Skipping as php build failed
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
Skipping as php build failed
exe:/opt/alt/php-fpm53/usr/sbin/php-fpm
Redirecting to /bin/systemctl restart httpd.service

Build Completed
###################


Notification added

Offline
*****
Re: Can not install php 5.6 and lower versions CWP - PRO
« Reply #1 on: July 16, 2019, 08:36:58 AM »
seems you've updated the openssl version . Install the Base version of openssl and openssl development package from yum.