Author Topic: Install ImageMagick or GD ?  (Read 29969 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Re: Install ImageMagick or GD ?
« Reply #15 on: August 10, 2016, 09:11:40 AM »
i have installed imagmagic success. with basic CWP php 5.4
i can see module loaded success.

but at subdomain, i run php7
i look at
Code: [Select]
<?php phpinfo();?> on php7, there is no imagmagic extension loaded.
i have try add
Code: [Select]
extension=imagick.so at php.ini and restart apache, still can't get it work with php7.
is there anyone can give me solution?

Thank You

Offline
*****
Re: Install ImageMagick or GD ?
« Reply #16 on: August 10, 2016, 10:53:47 AM »
Hi, try to use oldest version.
You can ask me to solve any problem with your server for some money in pm  ;)
Services Monitoring & RBL Monitoring
http://centos-webpanel.com/services-monitor
Join our Development Team and get paid !
http://centos-webpanel.com/develope-modules-for-cwp

Installation Instructions
http://centos-webpanel.com/installation-instructions
Get Fast Support Here
http://centos-webpanel.com/support-services

Offline
*
Re: Install ImageMagick or GD ?
« Reply #17 on: August 10, 2016, 02:42:17 PM »
Hi, try to use oldest version.

yes, i know about that. but i want to use php7
seems the script only install for base php that use by cwp

Offline
*
Re: Install ImageMagick or GD ?
« Reply #18 on: August 10, 2016, 03:55:29 PM »
with php selector php7 i got this error:
Code: [Select]
PHP Warning:  PHP Startup: Unable to load dynamic library '/opt/alt/php7/usr/lib/php/extensions/no-debug-non-zts-20160303/imagick.so' - /opt/alt/php7/usr/lib/php/extensions/no-debug-non-zts-20160303/imagick.so: cannot open shared object file: No such file or directory in Unknown on line 0if i change to default php, it has no problem

Offline
*
Re: Install ImageMagick or GD ?
« Reply #19 on: May 01, 2017, 03:26:37 AM »
i am copy the imagemagik.so from -> /usr/local/lib/php/extensions/no-debug-non-zts-20131226
to -> /usr/lib64/extensions/no-debug-non-zts-20100525

and re install imagemagik : sh /scripts/install_imagick
problem solved!!

if same error for ffmpeg copy ffmpeg.so from ...........


Offline
*
Re: Install ImageMagick or GD ?
« Reply #20 on: June 07, 2018, 03:39:49 PM »
-      2018  .    ?         ?

Offline
***
Re: Install ImageMagick or GD ?
« Reply #21 on: December 04, 2018, 09:27:43 PM »
contact support and we will check it
http://centos-webpanel.com/contact

Right and you ask for money in the spirit of open source.

Heres the error.
extension=imagick.so
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/local/lib/php/ex                                                                                       tensions/no-debug-non-zts-20160303/imagick.so' - /usr/local/lib/php/extensions/n                                                                                       o-debug-non-zts-20160303/imagick.so: cannot open shared object file: No such fil                                                                                       e or directory in Unknown on line 0
Imagick NOT Installed !

Offline
***
Re: Install ImageMagick or GD ?
« Reply #22 on: December 05, 2018, 04:43:44 AM »
Right and you ask for money in the spirit of open source.

Where did you saw CWP is open source?
GamePanel and TeamspeakManager Modules source codes are for SALE, PM me!

Offline
*
Re: Install ImageMagick or GD ?
« Reply #23 on: March 31, 2019, 12:44:28 AM »
contact support and we will check it
http://centos-webpanel.com/contact

Right and you ask for money in the spirit of open source.

Heres the error.
extension=imagick.so
PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/local/lib/php/ex                                                                                       tensions/no-debug-non-zts-20160303/imagick.so' - /usr/local/lib/php/extensions/n                                                                                       o-debug-non-zts-20160303/imagick.so: cannot open shared object file: No such fil                                                                                       e or directory in Unknown on line 0
Imagick NOT Installed !


Hello, I manage to fix this with:
Code: [Select]
yum install gcc php-devel php-pear
yum install ImageMagick ImageMagick-devel
pecl install imagick
service httpd reload

Results:
Code: [Select]
[root@domain~]# php -v
PHP 5.6.37 (cli) (built: Mar 29 2019 15:49:35)
Copyright (c) 1997-2016 The PHP Group
Zend Engine v2.6.0, Copyright (c) 1998-2016 Zend Technologies
    with the ionCube PHP Loader (enabled) + Intrusion Protection from ioncube24.com (unconfigured) v10.3.2, Copyright (c) 2002-2018, by ionCube Ltd.
    with Zend Guard Loader v3.3, Copyright (c) 1998-2015, by Zend Technologies

No More Error with imagick