Author Topic: Module Command Error  (Read 8889 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Module Command Error
« on: August 26, 2019, 08:00:17 PM »
Hi All,

Basically I installed the WHMCS module by following this guide

https://www.youtube.com/watch?time_continue=2&v=96dizYdi6WY

The problem is when I try to create an account on the remote CWP server from WHMCS, it will throw the following error

Code: [Select]
Check All Fields (only lower caps are allowed and no special characters or empty spaces...
Here is a screenshot https://imgur.com/ox7G6AN

Has anyone had such problems and can they help? Where the error log is located which can show what is happening? /usr/local/cwpsrv/logs/error_log doesn't show anything related to this issue. Thanks in advance.

Offline
*
Re: Module Command Error
« Reply #1 on: August 27, 2019, 08:50:02 AM »
you need to check that you are sending all details like domain, username, ....and that they are in the correct format.
VPS & Dedicated server provider with included FREE Managed support for CWP.
http://www.studio4host.com/

*** Don't allow that your server or website is down, choose hosting provider with included expert managed support for your CWP.

Offline
*
Re: Module Command Error
« Reply #2 on: August 27, 2019, 08:52:31 AM »
Thank you for your response. As displayed in the screenshot, the domain name and the username format is fine.

Offline
*
Re: Module Command Error
« Reply #3 on: August 27, 2019, 09:03:30 AM »
only required parameters here are
domain, username, email, password

You need to be sure that all are in the correct format and have no any special characters or empty spaces.
VPS & Dedicated server provider with included FREE Managed support for CWP.
http://www.studio4host.com/

*** Don't allow that your server or website is down, choose hosting provider with included expert managed support for your CWP.

Offline
*
Re: Module Command Error
« Reply #4 on: August 27, 2019, 10:47:06 AM »
It doesn't have empty spaces or special characters. That is why I'm asking for help.

Offline
*
Re: Module Command Error
« Reply #5 on: August 27, 2019, 12:02:49 PM »
Apparently you can't use special characters or capital letters in the 'Password' field which is not a smart idea from the security perspective. I will point the devs. to this topic. Hopefully they will fix this.

Offline
*
Re: Module Command Error
« Reply #6 on: August 29, 2019, 08:30:07 AM »
I was wrong, capital letters for passwords is permitted.

To tell WHMCS to generate random passwords without special characters, go to Setup>General settings>Security and check 'Generate passwords containing a combination of letters and numbers only' This way you don't need to modify the password manually while creating new users and the module will not complain about special characters.