Author Topic: Crontab not working after installing Mod Security [SOLVED]  (Read 4394 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Crontab not working after installing Mod Security [SOLVED]
« on: January 22, 2020, 02:15:04 PM »
Before it was working but after installating Mod Security Crontab is not working.
Basically my website is disposable mail and the mails should be deleted every 30min.

my cron command starts with
Code: [Select]
wget /dev/null url <- url means my website delete mail url
i posted this question before but i saw that my account is delete so i recreated account and verified it.

i checked logs but not able to find the mod security cron id

i am using free centos webpanel 7
« Last Edit: January 26, 2020, 07:54:37 AM by Igor S. »

Offline
*
Re: Crontab not working after installing Mod Security
« Reply #1 on: January 22, 2020, 06:14:15 PM »
if you Uninstall Mod Security your cron work again?

Offline
*
Re: Crontab not working after installing Mod Security
« Reply #2 on: January 22, 2020, 07:35:55 PM »
yes if i remove mod security cron job is working. i want to keep mod security :'(
i want to know the log file of mod security to find out cron job id to whitelist.
Question is
Mod security blocking cron job?
or
Mod security blocking wget (my command)?

previously i was using VestaCP on Ubuntu 18.04 and my website was hacked many times. i searched for best free control panel and then switched to CentOS Web Panel.
I like this web panel because it has more features

Offline
*****
Re: Crontab not working after installing Mod Security
« Reply #3 on: January 23, 2020, 08:33:40 AM »
You need to check the Apache's log for mod_security errors and add the required rule to the whitelist.
You can ask me to solve any problem with your server for some money in pm  ;)
Services Monitoring & RBL Monitoring
http://centos-webpanel.com/services-monitor
Join our Development Team and get paid !
http://centos-webpanel.com/develope-modules-for-cwp

Installation Instructions
http://centos-webpanel.com/installation-instructions
Get Fast Support Here
http://centos-webpanel.com/support-services

Offline
*
Re: Crontab not working after installing Mod Security
« Reply #4 on: January 26, 2020, 06:17:08 AM »
The issue was not with mod security. the issue was with Cloudflare. I previously changed the tls protocol to 1.3 and because of this wget was not working. i changed to tls 1.0 (default) and now crontab is working :)