Author Topic: spamassassin is inactive! how are your settings?  (Read 1986 times)

0 Members and 1 Guest are viewing this topic.

Offline
**
spamassassin is inactive! how are your settings?
« on: September 16, 2019, 08:27:31 PM »
my spamassassin is not active
how did i notice this

-Too many spam e-mail coming
-incoming emails never go to the spam folder
-i have read many spamassassin support articles, but my settings don't work at all.
-then I saw this video. here postfix, clamav and spamassassin had the setting. (https://www.youtube.com/watch?v=xhGlO0gEhQc)
-i realized something was missing.
- and bingo
-actually, everything was close.
-cwp wiki also had this topic. (http://wiki.centos-webpanel.com/how-to-configure-spamassassin)
- i tried to apply these settings. but postfix gives an error. :.(

how did you do it.

/etc/postfix/master.cf    added
Code: [Select]
smtp      inet  n       -       n       -       -       smtpd
  -o content_filter=smtp-amavis:127.0.0.1:10024
  -o receive_override_options=no_address_mappings
  -o content_filter=spamassassin
and this
Code: [Select]
spamassassin      unix -      n      n      -      -      pipe
  user=nobody argv=/usr/bin/spamc -f -e
  /usr/sbin/sendmail -oi -f ${sender} ${recipient}

i don't know how to apply it. with ssh? I skipped this step !!!

Next, we have to edit /etc/sysconfig/spamassassin with the code below:

Code: [Select]
SAHOME="/var/lib/spamassassin/"
SPAMDOPTIONS="-d -c -C /etc/spamassassin/local.cf -m5 -u nobody -s ${SAHOME}spamd.log"
----------------------------------------------------------------------------------------------------
and i added them
Configure /etc/spamassassin/local.cf with default options below:
Code: [Select]
rewrite_header Subject *****SPAM*****
# report_safe 1
# trusted_networks 212.17.35.
required_score 5.0
use_bayes 1
bayes_auto_learn 1
bayes_ignore_header X-Bogosity
bayes_ignore_header X-Spam-Flag
bayes_ignore_header X-Spam-Status
include /usr/share/spamassassin/
----------------------------------------------------------------------------------------------------
and
Code: [Select]
sa-update
systemctl restart postfix spamassassin
----------------------------------------------------------------------------------------------------
but postfix gave error

  • can you tell us step by step how you did it


Quote
Attention to the managers!
One Time to buy support. Can you solve this problem?
I can buy it if possible.



  • Spamassassin: config and scan per mailbox
  • Clustering manager
  • Mail Space Usage
  • All Space Usage + = Disk Space Usage
  • Mail Scanner
    hopeful fourth year

Offline
*****
Re: spamassassin is inactive! how are your settings?
« Reply #1 on: September 16, 2019, 10:11:24 PM »
Please check with support to fix this

Offline
**
Re: spamassassin is inactive! how are your settings?
« Reply #2 on: September 17, 2019, 05:24:10 PM »
I've solved the problem. I'm careless.
Thank you..
  • Spamassassin: config and scan per mailbox
  • Clustering manager
  • Mail Space Usage
  • All Space Usage + = Disk Space Usage
  • Mail Scanner
    hopeful fourth year

Offline
*
Re: spamassassin is inactive! how are your settings?
« Reply #3 on: September 28, 2019, 10:27:49 AM »
Though you cannot configure SpamAssassin to delete all spam messages, you can let each mailbox owner configure their own spam protection settings. This includes, for example, setting their spam filters to automatically delete messages marked by SpamAssassin.