Author Topic: Opcache enabled but cached scripts are Zero  (Read 4806 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Opcache enabled but cached scripts are Zero
« on: October 03, 2019, 05:10:37 PM »
It seems to me not working ? what can I do anything else to fix this ? (Im newbie about CWP)

My WebServer Settings:


In my website phpinfo(); shows:


« Last Edit: October 03, 2019, 05:12:14 PM by wipau »

Offline
*
Re: Opcache enabled but cached scripts are Zero
« Reply #1 on: October 05, 2019, 10:43:33 AM »
Looks like it happens for me as well.

Actually I was going to post because I did notice PHP 7.2 performs better than PHP 7.3. The latter consumes more memory and generates page slower. No wonder then!

I'm still trying to figure out why. Maybe OPcache segfaults somewhere, but I can't find any trace in the logs.
« Last Edit: October 05, 2019, 10:51:12 AM by Arkshine »

Offline
*
Re: Opcache enabled but cached scripts are Zero
« Reply #2 on: October 05, 2019, 02:21:01 PM »
After searching on Google, I found the issue appears in others Panels, and the culprit is: ionCube.

Looking at the changelog, the 10.3.8 is supposed to include a fix for a potential crash with OpCache. Looks like it's not enough.




To disable ionCuble, removing the extension from Select Options or disabling in Manual Options is completely ignored by CWP for some reasons. I had to move the file /opt/alt/php-fpm73/usr/php/php.d/iconuble.ini in a directory to not be parsed.

Once disabled, it works great again.

Offline
*
Re: Opcache enabled but cached scripts are Zero
« Reply #3 on: October 05, 2019, 09:03:07 PM »
After searching on Google, I found the issue appears in others Panels, and the culprit is: ionCube.

Looking at the changelog, the 10.3.8 is supposed to include a fix for a potential crash with OpCache. Looks like it's not enough.




To disable ionCuble, removing the extension from Select Options or disabling in Manual Options is completely ignored by CWP for some reasons. I had to move the file /opt/alt/php-fpm73/usr/php/php.d/iconuble.ini in a directory to not be parsed.

Once disabled, it works great again.

You are LIFE SAVERRR! You are absolutely right. I removed php-fpm73 ioncube.ini and opcache works now!!

You mentioned that php 7.2 faster than php 7.3 , so should I downgrade ?? Or it depends OPCache ?

Offline
*
Re: Opcache enabled but cached scripts are Zero
« Reply #4 on: October 06, 2019, 09:59:34 AM »
It was faster with 7.2 because OpCache was not working with 7.3. Now it's working, you should keep 7.3 if you can.
7.2 active support is going to end soon and from benchmark you can see on Google, 7.3 is usually 10% faster than 7.2.