Author Topic: CWP not importing/moving files from CPanel  (Read 12488 times)

0 Members and 1 Guest are viewing this topic.

CWP not importing/moving files from CPanel
« on: November 12, 2019, 11:55:04 AM »
I'm, trying to move an account with multiple subdomains, databases and emails accounts from CPanel to a CWP installed on a digital ocean droplet.

I'm using the Cpanel server migration , connect to Cpanel , select the the account i want to move and start the transfer. In CWP the transfer is made and no error are displayed, but.....

No files are move - all the folders just have an index.html and that's it.
I've made sure that i have enough hdd space
I've modified the default pack on Cwp and put unlimited on subdomains, storage, band etc.....
I've try to move only the files and skip the databases
Most of the databases are created and populated (however i noticed at least 1 was blank  ).
I tried the "Account migration from Cpanel": creating a full backup on original server , rename it like cpmove-{USER}.tar.gz, uploading to /home on new server and tried to restore. Same as before folders are created with only index.html file.

Any ideas ?

Re: CWP not importing/moving files from CPanel
« Reply #1 on: November 12, 2019, 12:00:12 PM »
As an update

I noticed that in home a folder /tmpback is created and inside there is  folder named after cpanel backup and contain an unziped backup archive. Looks like CWP7 cannot move the files from there to the right folder.

Re: CWP not importing/moving files from CPanel
« Reply #2 on: November 19, 2019, 03:17:06 PM »
Anyone ?

Re: CWP not importing/moving files from CPanel
« Reply #3 on: November 19, 2019, 08:10:05 PM »
I too am having problems with this.
I have been thinking about it for a while and I wonder...the Centos-web panel is php driven is it not?

I wonder if php restrictions/directives also apply to the panel itself?

If so, that would mean php max file size, php max post size, php memory limit, timeout settings etc all might all have to be increased dramatically from their defaults for this to work?

I found that even when uploading the cpanel backup manually via ftp I was striking similar was uploading only about 4%, of the total cpanel backup...I increased php7 max file size a bit, then it would upload I'm not sure???

It seems weird to me that any of these settings should even apply to root user via file manager when migrating.

I am also starting to think that the reason this panel appears so buggy is because we are all used to control panels that are not built on php.