Author Topic: ioncube - reinstallation  (Read 2075 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
ioncube - reinstallation
« on: April 29, 2020, 03:06:34 AM »
I accidentally click the uninstall ioncobe - then lost ability to connect to cwp control pabel via webpage.

I ran the script 'update_ioncube'  restarted server but still no web access to control panel.

I made sure there was zend_extension = /usr/local/ioncube/ioncube_loader_lin_7.2.so in the php.ini located at /usr/local/cwp/php71.php.ini

also confirmed update did install ioncube - but the admin web pages keeps saying need ioncube installed in the error logs

anybody know a solution

Offline
*
Re: ioncube - reinstallation
« Reply #1 on: April 29, 2020, 04:16:38 AM »
 it is now saying that the php ioncube was installed with different version of php -

Offline
*
Re: ioncube - reinstallation
« Reply #2 on: April 29, 2020, 06:29:50 AM »
 sh /scripts/restart_cwpsrv
VPS & Dedicated server provider with included FREE Managed support for CWP.
http://www.studio4host.com/

*** Don't allow that your server or website is down, choose hosting provider with included expert managed support for your CWP.

Online
*
Re: ioncube - reinstallation
« Reply #3 on: April 29, 2020, 03:42:54 PM »
I accidentally click the uninstall ioncobe - then lost ability to connect to cwp control pabel via webpage.

I ran the script 'update_ioncube'  restarted server but still no web access to control panel.

I made sure there was zend_extension = /usr/local/ioncube/ioncube_loader_lin_7.2.so in the php.ini located at /usr/local/cwp/php71.php.ini

also confirmed update did install ioncube - but the admin web pages keeps saying need ioncube installed in the error logs

anybody know a solution



For Solutions:
http://forum.centos-webpanel.com/index.php?topic=8793.msg30709#msg30709  , It works

Offline
*
Re: ioncube - reinstallation
« Reply #4 on: April 30, 2020, 03:57:28 AM »
I followed the instructions provided
I still get error message

FastCGI sent in stderr: "PHP message: PHP Fatal error:  The file /usr/local/cwpsrv/htdocs/admin/login/index.php was encoded by the ionCube Encoder for PHP 5.6 and cannot run under PHP 7.1 or later.
 Please ask the provider of the script to provide a version encoded with the ionCube Encoder for PHP 7.1.

Any assistance would be greatly appreciated

i changed the php.ini file to the following
zend_extension = /usr/local/ioncube/ioncube_loader_lin_5.6.so

and then the login page displayed the following
'No Loader is installed, please try to run this command or contact support: sh /scripts/update_ioncube restart'

followed instructions - now same message
restarted cwp as well as tried rebooting server - still not working.




« Last Edit: April 30, 2020, 04:05:38 AM by rtoutant »