Author Topic: Innodb not running even after force recovery  (Read 1028 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Innodb not running even after force recovery
« on: January 21, 2020, 08:39:08 AM »
Hello Friends

My innodb crashed somehow on sunday without doing anything. Now its not working at all.

I tried skipping innodb and try to work on MYISAM but my all database on production is using innodb. By using MYISAM i take the backup of my websites database and all other databases visible like root, mysql,postfix etc.

But now what to do with innodb. Till it is not recovered my production websites remain down and thats pretty problem to me.

Anybody any suggestion.

Maria DB status


# systemctl -l status mariadb.service

● mariadb.service - MariaDB 10.1.36 database server
   Loaded: loaded (/usr/lib/systemd/system/mariadb.service; enabled; vendor preset: disabled)
  Drop-In: /etc/systemd/system/mariadb.service.d
           └─migrated-from-my.cnf-settings.conf
   Active: failed (Result: exit-code) since Tue 2020-01-21 13:42:21 IST; 23s ago
     Docs: man:mysqld(8)
           https://mariadb.com/kb/en/library/systemd/
  Process: 25311 ExecStartPost=/bin/sh -c systemctl unset-environment _WSREP_START_POSITION (code=exited, status=0/SUCCESS)
  Process: 6079 ExecStart=/usr/sbin/mysqld $MYSQLD_OPTS $_WSREP_NEW_CLUSTER $_WSREP_START_POSITION (code=exited, status=1/FAILURE)
  Process: 6064 ExecStartPre=/bin/sh -c [ ! -e /usr/bin/galera_recovery ] && VAR= ||   VAR=`/usr/bin/galera_recovery`; [ $? -eq 0 ]   && systemctl set-environment _WSREP_START_POSITION=$VAR || exit 1 (code=exited, status=0/SUCCESS)
  Process: 6061 ExecStartPre=/bin/sh -c systemctl unset-environment _WSREP_START_POSITION (code=exited, status=0/SUCCESS)
 Main PID: 6079 (code=exited, status=1/FAILURE)
   Status: "MariaDB server is down"

Jan 21 13:42:21  mysqld[6079]: 2020-01-21 13:42:21 140010481858816 [ERROR] InnoDB: Could not open or create the system tablespace. If you tried to add new data files to the system tablespace, and it failed here, you should now edit innodb_data_file_path in my.cnf back to what it was, and remove the new ibdata files InnoDB created in this failed attempt. InnoDB only wrote those files full of zeros, but did not yet use them in any way. But be careful: do not remove old data files which contain your precious data!
Jan 21 13:42:21  mysqld[6079]: 2020-01-21 13:42:21 140010481858816 [ERROR] Plugin 'InnoDB' init function returned error.
Jan 21 13:42:21  mysqld[6079]: 2020-01-21 13:42:21 140010481858816 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
Jan 21 13:42:21  mysqld[6079]: 2020-01-21 13:42:21 140010481858816 [Note] Plugin 'FEEDBACK' is disabled.
Jan 21 13:42:21  mysqld[6079]: 2020-01-21 13:42:21 140010481858816 [ERROR] Unknown/unsupported storage engine: InnoDB
Jan 21 13:42:21  mysqld[6079]: 2020-01-21 13:42:21 140010481858816 [ERROR] Aborting
Jan 21 13:42:21  systemd[1]: mariadb.service: main process exited, code=exited, status=1/FAILURE
Jan 21 13:42:21  systemd[1]: Failed to start MariaDB 10.1.36 database server.
Jan 21 13:42:21  systemd[1]: Unit mariadb.service entered failed state.
Jan 21 13:42:21  systemd[1]: mariadb.service failed.

Offline
*****
Re: Innodb not running even after force recovery
« Reply #1 on: January 22, 2020, 11:30:47 AM »
Hi, try to use the commands below.

Code: [Select]
mv /var/lib/mysql/ib_logfile0 /var/lib/mysql/ib_logfile0_OLD
mv /var/lib/mysql/ib_logfile1 /var/lib/mysql/ib_logfile1_OLD
systemctl restart mariadb

If that won't help, you will have to talk to a sysadmin or you can pm me will see
You can ask me to solve any problem with your server for some money in pm  ;)
Services Monitoring & RBL Monitoring
http://centos-webpanel.com/services-monitor
Join our Development Team and get paid !
http://centos-webpanel.com/develope-modules-for-cwp

Installation Instructions
http://centos-webpanel.com/installation-instructions
Get Fast Support Here
http://centos-webpanel.com/support-services