Author Topic: CWP pro, apache is runing ,bat CWP view apache stoped.  (Read 1892 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
CWP pro, apache is runing ,bat CWP view apache stoped.
« on: January 29, 2020, 03:02:06 PM »
good afternoon

I have a rare problem and no matter how hard I try to solve it, I don't get it.

I have the CWP Pro version and in the cwp it appears to me that apache is off in error, but if I use ssh for force restart, it starts but in cwp it still does not give error.

Code: [Select]
[root@prime ~]# tail -f /usr/local/apache/logs/error_log
[Wed Jan 29 14:59:25.120316 2020] [:notice] [pid 30119:tid 140211817576320] ModS                                                                                                             ecurity for Apache/2.9.1 (http://www.modsecurity.org/) configured.
[Wed Jan 29 14:59:25.120330 2020] [:notice] [pid 30119:tid 140211817576320] ModS                                                                                                             ecurity: APR compiled version="1.6.2"; loaded version="1.6.2"
[Wed Jan 29 14:59:25.120336 2020] [:notice] [pid 30119:tid 140211817576320] ModS                                                                                                             ecurity: PCRE compiled version="8.32 "; loaded version="8.32 2012-11-30"
[Wed Jan 29 14:59:25.120340 2020] [:notice] [pid 30119:tid 140211817576320] ModS                                                                                                             ecurity: LIBXML compiled version="2.9.1"
[Wed Jan 29 14:59:25.120344 2020] [:notice] [pid 30119:tid 140211817576320] ModS                                                                                                             ecurity: Status engine is currently disabled, enable it by set SecStatusEngine t                                                                                                             o On.
[Wed Jan 29 14:59:25.198115 2020] [ssl:warn] [pid 30120:tid 140211817576320] AH0                                                                                                             1873: Init: Session Cache is not configured [hint: SSLSessionCache]
[Wed Jan 29 14:59:25.203442 2020] [ssl:warn] [pid 30120:tid 140211817576320] AH0                                                                                                             1906: prime.appnet.cf:443:0 server certificate is a CA certificate (BasicConstra                                                                                                             ints: CA == TRUE !?)
[Wed Jan 29 14:59:25.204012 2020] [core:warn] [pid 30120:tid 140211817576320] AH                                                                                                             00098: pid file /usr/local/apache/logs/httpd.pid overwritten -- Unclean shutdown                                                                                                              of previous Apache run?
[Wed Jan 29 14:59:25.207434 2020] [mpm_event:notice] [pid 30120:tid 140211817576                                                                                                             320] AH00489: Apache/2.4.39 (Unix) OpenSSL/1.0.2k-fips configured -- resuming no                                                                                                             rmal operations
[Wed Jan 29 14:59:25.207494 2020] [core:notice] [pid 30120:tid 140211817576320]                                                                                                              AH00094: Command line: '/usr/local/apache/bin/httpd'

Code: [Select]
httpd.service
   Loaded: not-found (Reason: No such file or directory)
   Active: failed (Result: exit-code) since Wed 2020-01-29 14:54:01 CET; 1h 6min ago
 Main PID: 27009 (code=exited, status=1/FAILURE)

Jan 29 14:54:01 prime.appnet.cf systemd[1]: Starting The Apache HTTP Server...
Jan 29 14:54:01 prime.appnet.cf httpd[27009]: (98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:80
Jan 29 14:54:01 prime.appnet.cf httpd[27009]: no listening sockets available, shutting down
Jan 29 14:54:01 prime.appnet.cf httpd[27009]: AH00015: Unable to open logs
Jan 29 14:54:01 prime.appnet.cf systemd[1]: httpd.service: main process exited, code=exited, status=1/FAILURE
Jan 29 14:54:01 prime.appnet.cf kill[27010]: kill: cannot find process ""
Jan 29 14:54:01 prime.appnet.cf systemd[1]: httpd.service: control process exited, code=exited status=1
Jan 29 14:54:01 prime.appnet.cf systemd[1]: Failed to start The Apache HTTP Server.
Jan 29 14:54:01 prime.appnet.cf systemd[1]: Unit httpd.service entered failed state.
Jan 29 14:54:01 prime.appnet.cf systemd[1]: httpd.service failed.


With this command I can start without problems.
/usr/local/apache/bin/httpd -k restart

And
Code: [Select]
[root@prime ~]# yum list installed | grep httpd
cwp-httpd.x86_64                   2.4.39-3                       @cwp

Thanks greetings

Offline
*****
Re: CWP pro, apache is runing ,bat CWP view apache stoped.
« Reply #1 on: January 29, 2020, 04:01:23 PM »
Hi, delete SSL certificate for prime.appnet.cf and then restart Apache
You can ask me to solve any problem with your server for some money in pm  ;)
Services Monitoring & RBL Monitoring
http://centos-webpanel.com/services-monitor
Join our Development Team and get paid !
http://centos-webpanel.com/develope-modules-for-cwp

Installation Instructions
http://centos-webpanel.com/installation-instructions
Get Fast Support Here
http://centos-webpanel.com/support-services

Offline
*
Re: CWP pro, apache is runing ,bat CWP view apache stoped.
« Reply #2 on: January 29, 2020, 05:48:10 PM »
Hello again.
Is work fine, after change hostname and generate new certificate.

thanks thanks.
« Last Edit: January 29, 2020, 06:04:50 PM by liviudiaconu85 »