Author Topic: problem creating the certificate the web doesn't work for me  (Read 1423 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
problem creating the certificate the web doesn't work for me
« on: February 04, 2020, 10:12:23 AM »
hello my problem is this that I created the certificate with autossl.
Does Autossl use let's encrypt to create certificates?
The problem I have is that it gives me this message when I say about entering the website where I generated the certificate.
Código de error: SSL_ERROR_RX_RECORD_TOO_LONG
this file is /etc/nginx/conf.d/vhosts/despedidasexclusivas.com.ssl.conf
server {
        listen 188.166.23.139:443 ;
        server_name despedidasexclusivas.com  www.despedidasexclusivas.com;
        root /home/onzulin/public_html;
        index index.php index.html index.htm;
        access_log /usr/local/apache/domlogs/despedidasexclusivas.com.bytes bytes;
        access_log /usr/local/apache/domlogs/despedidasexclusivas.com.log combined;
        error_log /usr/local/apache/domlogs/despedidasexclusivas.com.error.log error;

        #deprecated
        #ssl                  on;
        listen          443 ssl;
        ssl_certificate      /etc/pki/tls/certs/despedidasexclusivas.com.bundle;
        ssl_certificate_key  /etc/pki/tls/private/despedidasexclusivas.com.key;
        ssl_protocols TLSv1 TLSv1.1 TLSv1.2;
        ssl_ciphers EECDH+ECDSA+AESGCM:EECDH+aRSA+AESGCM:EECDH+ECDSA+SHA384:EECDH+ECDSA+SHA256:EECDH+aRSA+SHA384:EECDH+aRSA+SHA256:EECDH+aRSA!RC4:EECDH:!RC4:!aNULL:!eN$        ssl_prefer_server_ciphers   on;

        ssl_session_cache   shared:SSL:10m;
        ssl_session_timeout 60m;

        location / {

                add_header Strict-Transport-Security "max-age=31536000";
                add_header X-Content-Type-Options nosniff;

                location ~.*\.(jpeg|jpg|png|gif|bmp|ico|svg|css|js)$ {
                        expires max;
                }

                location ~ [^/]\.php(/|$) {
                        fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
                        if (!-f $document_root$fastcgi_script_name) {
                                return  404;
                        }

                        fastcgi_pass    unix:/opt/alt/php-fpm72/usr/var/sockets/onzulin.sock;
                        fastcgi_index   index.php;
                        include         /etc/nginx/fastcgi_params;
                }

        }

        location ~* "/\.(htaccess|htpasswd)$" {deny all;return 404;}

        disable_symlinks if_not_owner from=/home/onzulin/public_html;

        location /.well-known/acme-challenge {
                default_type "text/plain";
                alias /usr/local/apache/autossl_tmp/.well-known/acme-challenge;
        }
}
I also have another file:
despedidasexclusivas.com.conf
What solution does this problem have? in the forums they say that you just have to put
listen 443 ssl;
but don't run the nginx with php-fpm webserver.
 

Offline
***
Re: problem creating the certificate the web doesn't work for me
« Reply #1 on: February 06, 2020, 05:54:44 AM »
That error usually has to do with a misconfigured proxy server.  Ex if your using nginx in front of apache.

I just tested your site and it works fine.  Are you behind a socks proxy or something like that?
« Last Edit: February 06, 2020, 06:13:36 AM by rcschaff »
Google Hangouts:  rcschaff82@gmail.com