Author Topic: HTTP Test Page on the homepage and 404 Not Found  (Read 9897 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
HTTP Test Page on the homepage and 404 Not Found
« on: February 04, 2020, 11:13:20 PM »
Hello everyone!
First of all, congratulations for the work!

1. I have a VPS and I installed centos OS and CWP.

2. I created an account from CloudFlare and the nameservers generated by cloudflare (Name Server 1 and Name Server 2) resolves to my shared IP.

3. I installed and activated LAMP

4. I installed WordPress on var/www/html/ with right permissions

5. Configured the wp-config.php and it's all OK

Worked for 24 hours and:

A) the homepage show HTTP Test Page
B) other pages shows 404 Not Found The requested URL MY-DOMAIN/custom-url was not found on this server.

Now I uploaded on var/www/html/
"index.html" and "test.php" because I thought wordpress was corrupt, but none does not work.

Even if I reinstall Centos OS, start all over again. It works 24 hours and then stops


Anyone know what happened?
I have to do something before installing WP?
Maybe I don't have to install LAMP?

Regards

Offline
***
Re: HTTP Test Page on the homepage and 404 Not Found
« Reply #1 on: February 05, 2020, 01:47:40 AM »
probably received an update from CWP that overwrote all customer user settings.

Are you using apache or nginx-phpfpm?
Google Hangouts:  rcschaff82@gmail.com

Offline
***
Re: HTTP Test Page on the homepage and 404 Not Found
« Reply #2 on: February 05, 2020, 02:36:12 AM »
P.S.  If your using CWP, you shouldn't be installing anything via terminal.  You should use the CWP to select your configurations and let it do the work.  If you install LAMP before CWP, you will most definitely break CWP.
Google Hangouts:  rcschaff82@gmail.com

Offline
*
Re: HTTP Test Page on the homepage and 404 Not Found
« Reply #3 on: February 05, 2020, 09:15:02 AM »
Thanks for the reply!
I use apache and not nginx-phpfpm.

How do I reinstall CWP Without restoring OS?

Regards

Offline
***
Re: HTTP Test Page on the homepage and 404 Not Found
« Reply #4 on: February 05, 2020, 03:31:36 PM »
You can try yum removing the lamp stack you installed, then rerun /use/local/src/
sh (installscript)
Google Hangouts:  rcschaff82@gmail.com

Offline
*
Re: HTTP Test Page on the homepage and 404 Not Found
« Reply #5 on: February 05, 2020, 11:32:09 PM »
Hi,
I did!

Now, the "var/html/..." folder does not exist. Also does not exist "etc/httpd..."

I created an account and work with it.
I installed wp, created database and from cwp i entered the right permissions. Everything works!!!

Is it normal for a single administrator to work with an account that is usually used for Reseller?

It would have been convenient to upload everything to "var/html/..." without creating accounts for beginners!

Do you recommend using the VPS with the account created or looking for the reason why the "etc/httpd" and "var/html" folder is gone?

Thanks for your attention!

Offline
***
Re: HTTP Test Page on the homepage and 404 Not Found
« Reply #6 on: February 05, 2020, 11:49:49 PM »
CWP is more for a hosting platform.  If your looking for a simple LAMP Stack, it's not really required.  Though it does make it easier to configure mail and such.
Google Hangouts:  rcschaff82@gmail.com