Author Topic: Mail forwarding problem  (Read 4840 times)

0 Members and 1 Guest are viewing this topic.

Offline
***
Mail forwarding problem
« on: February 26, 2020, 01:48:58 PM »
So I created an email forward rule on a domain from control panel.  Then I deleted the forwarding rule.  Now all incoming emails are rejected on that one domain even though there are no forwarding rules.

I tried rebuilding mail server, problem persists.

Offline
*****
Re: Mail forwarding problem
« Reply #1 on: February 26, 2020, 05:55:15 PM »
whats in the maillog ?

Offline
***
Re: Mail forwarding problem
« Reply #2 on: February 26, 2020, 06:45:57 PM »
Error Log
Code: [Select]
Feb 26 13:42:04 server postfix/smtpd[26363]: lost connection after RCPT from unknown[71.214.155.80]
Feb 26 13:42:04 server postfix/smtpd[26363]: disconnect from unknown[71.214.155.80] ehlo=2 starttls=1 auth=1 mail=1 rcpt=0/1 commands=5/6
Feb 26 13:43:21 server postfix/smtpd[26363]: warning: hostname 71-214-155-80.orlf.qwest.net does not resolve to address 71.214.155.80: Name or service not known
Feb 26 13:43:21 server postfix/smtpd[26363]: connect from unknown[71.214.155.80]
Feb 26 13:43:21 server postfix/smtpd[26363]: Anonymous TLS connection established from unknown[71.214.155.80]: TLSv1.2 with cipher ECDHE-RSA-AES128-GCM-SHA256 (128/128 bits)
Feb 26 13:43:22 server postfix/smtpd[26363]: NOQUEUE: reject: RCPT from unknown[71.214.155.80]: 550 5.1.1 : Recipient address rejected: User unknown in virtual mailbox table; from=<2019@lakeservers.com> to= proto=ESMTP helo=<[192.168.0.8]>
Feb 26 13:43:23 server postfix/smtpd[26363]: disconnect from unknown[71.214.155.80] ehlo=2 starttls=1 auth=1 mail=1 rcpt=0/1 quit=1 commands=6/7

71.214.155.80 is house ip



Offline
***
Re: Mail forwarding problem
« Reply #3 on: February 26, 2020, 07:07:54 PM »
Code: [Select]
eb 26 14:05:01 server postfix/smtpd[29003]: warning: hostname 71-214-155-80.orlf.qwest.net does not resolve to address 71.214.155.80: Name or service not known
Feb 26 14:05:01 server postfix/smtpd[29003]: connect from unknown[71.214.155.80]
Feb 26 14:05:02 server postfix/smtpd[29003]: Anonymous TLS connection established from unknown[71.214.155.80]: TLSv1.2 with cipher ECDHE-RSA-AES128-GCM-SHA256 (128/128 bits)
Feb 26 14:05:02 server postfix/smtpd[29003]: 7644818EDC: client=unknown[71.214.155.80], sasl_method=PLAIN, sasl_username=2019@lakeservers.com
Feb 26 14:05:02 server postfix/cleanup[29012]: 7644818EDC: message-id=<0c2894ec-b866-7410-5d85-08deeb3fbc34@lakeservers.com>
Feb 26 14:05:02 server postfix/qmgr[28937]: 7644818EDC: from=<2019@lakeservers.com>, size=729, nrcpt=1 (queue active)
Feb 26 14:05:02 server postfix/smtpd[29003]: disconnect from unknown[71.214.155.80] ehlo=2 starttls=1 auth=1 mail=1 rcpt=1 data=1 quit=1 commands=8
Feb 26 14:05:02 server postfix/smtp[29014]: 7644818EDC: to=, relay=libra.goldspot.us[198.58.96.204]:25, delay=0.3, delays=0.19/0.01/0.06/0.03, dsn=2.0.0, status=sent (250 2.0.0 Ok: queued as D31CCAA89)
Feb 26 14:05:02 server postfix/qmgr[28937]: 7644818EDC: removed

The above code is a successful mail delivered from the same server but to a different domain on the same server as rosinto.com.  Problem is only one domain email.......rosinto.com  All others work.. It is not a problem of the sender, it is a problem of the receiver.
« Last Edit: February 26, 2020, 07:11:39 PM by pixelpadre »

Offline
*****
Re: Mail forwarding problem
« Reply #4 on: February 26, 2020, 07:10:58 PM »
is the correct MX ip "198.58.96.204" ?

Offline
***
Re: Mail forwarding problem
« Reply #5 on: February 26, 2020, 07:14:21 PM »
For the rosinto.com yes.
for lakeservers. com 45.33.10.132
« Last Edit: February 26, 2020, 07:16:51 PM by pixelpadre »

Offline
***
Re: Mail forwarding problem
« Reply #6 on: February 26, 2020, 07:18:50 PM »
I am going to delete the domain and add it again.  That will most likely fix it.  But this all started after I created a forwarding rule and then deleted it.  It has to be connected to the forwarding.

update.  deleted and created new domain and still the same error message.  Very puzzling.
« Last Edit: February 26, 2020, 07:37:14 PM by pixelpadre »

Offline
***
Re: Mail forwarding problem
« Reply #7 on: February 26, 2020, 08:32:36 PM »
Error message above on failed email delivery cites 192.168.0.8.  Thats my local ip.  Can a development lamp on my desktop be behind this?

Offline
***
Re: Mail forwarding problem update
« Reply #8 on: February 27, 2020, 12:22:21 AM »
Ok.  I removed rosinto from server 1 and moved it to server #2 and created the same email account.

So I tried sending an email from server#2 2019@lakeservers.com (as before) to simhof@rosinto.com (now on server #2). 

Result: success.  But there still seems to be a problem with server #1.  This is unquestionably tied to the alias/forwarding that I created.  It was only after creating and deleting the alias that the sheet hit the fan.  I suppose I could recreate the same scenario now on server #2 to see if I can show that it is the problem.  But I have already f'ed up server 1.  So I dont think I will do that.  I will leave it to the developers.

Although I couldnt not send mail from server 2 to the one domain rosinto.com on server 1, gmail could, as well as form email from server 1, which further complicates the troubleshooting.