Author Topic: Change Maine PHP version thru PHP selector or PHP Switcher?  (Read 366 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Change Maine PHP version thru PHP selector or PHP Switcher?
« on: March 03, 2020, 06:21:42 PM »
Hi, I just bought the the CWP7-Pro-Version.
The problem is when I use the PHP-Selector 2 New and try to install the PHP V7.3 it say red and then I push to install it but after about 30 minutes it is done it still itís red and not installed.
Even when I use the PHP version Switcher 2 and try to select PHP version to PHP 7.3 it start I can see that on the CPU but after about 15 minutes it still PHP 5.6.
So what ever I do I canít change to PHP 7.3

I also tried to change on the domain. There it looks like the PHP 7.3 is an alternative but when I change the domain to PHP 7.3 it add an .htaccess on the domain files with this in it
AddHandler application/x-httpd-php73 .php
But that gives me 500 internal error

What can be the problem?
Please anybody?

Offline
**
Re: Change Maine PHP version thru PHP selector or PHP Switcher?
« Reply #1 on: March 04, 2020, 12:37:38 AM »

I also tried to change on the domain. There it looks like the PHP 7.3 is an alternative but when I change the domain to PHP 7.3 it add an .htaccess on the domain files with this in it
AddHandler application/x-httpd-php73 .php
But that gives me 500 internal error

What can be the problem?
Please anybody?

Chances are, that a script you are running on that domain requires a module that is not compiled into the php7.3.  Check /usr/local/apache/domlogs/(Domain).error.log to find out what the specific php error is, and post that.
Google Hangouts:  rcschaff82@gmail.com

Offline
*
Re: Change Maine PHP version thru PHP selector or PHP Switcher?
« Reply #2 on: March 04, 2020, 05:49:19 AM »
Hi, the error file is very long with same info. But here is some of it.

Wed Mar 04 01:12:37.715369 2020] [core:error] [pid 7512:tid 139645157308160] [client 162.158.134.4:62924] End of script output before headers: index.php
[Wed Mar 04 01:13:26.468896 2020] [:error] [pid 7512:tid 139645174093568] [client 162.158.134.4:39698] SoftException in Application.cpp:542: Could not execute script "/home/diyhrto/public_html/mydomain_com/index.php"
[Wed Mar 04 01:13:26.469104 2020] [:error] [pid 7512:tid 139645174093568] [client 162.158.134.4:39698] Caused by SystemException in API_Linux.cpp:444: execve() for program "/opt/alt/php73/usr/bin/php-cgi" failed: No such file or directory
[Wed Mar 04 01:13:26.469290 2020] [core:error] [pid 7512:tid 139645174093568] [client 162.158.134.4:39698] End of script output before headers: index.php
[Wed Mar 04 01:14:50.862188 2020] [:error] [pid 7512:tid 139645258020608] [client 162.158.134.4:39840] SoftException in Application.cpp:542: Could not execute script "/home/diyhrto/public_html/mydomain_com/index.php"
[Wed Mar 04 01:14:50.862345 2020] [:error] [pid 7512:tid 139645258020608] [client 162.158.134.4:39840] Caused by SystemException in API_Linux.cpp:444: execve() for program "/opt/alt/php56/usr/bin/php-cgi" failed: No such file or directory
[Wed Mar 04 01:14:50.862540 2020] [core:error] [pid 7512:tid 139645258020608] [client 162.158.134.4:39840] End of script output before headers: index.php
[Wed Mar 04 01:16:40.323632 2020] [:error] [pid 7415:tid 139645148915456] [client 162.158.134.4:57846] SoftException in Application.cpp:542: Could not execute script "/home/diyhrto/public_html/mydomain_com/wp-admin/setup-config.php"
[Wed Mar 04 01:16:40.323796 2020] [:error] [pid 7415:tid 139645148915456] [client 162.158.134.4:57846] Caused by SystemException in API_Linux.cpp:444: execve() for program "/opt/alt/php73/usr/bin/php-cgi" failed: No such file or directory

Offline
*****
Re: Change Maine PHP version thru PHP selector or PHP Switcher?
« Reply #3 on: March 04, 2020, 06:10:00 AM »
check the required php version are already installed. You're using php selector.

It seems your server have issues with low ram memory.

Offline
*
Re: Change Maine PHP version thru PHP selector or PHP Switcher?
« Reply #4 on: March 04, 2020, 06:22:59 AM »
Hi, on PHP selector it say (red) not installed on every version.
On PHP Info it say PHP 5.6.3.7
I have a small VPS with 1gb. And on PHP ini it say 128mb for each script.
Isnít my memory enough?
« Last Edit: March 04, 2020, 06:55:25 AM by diyhrt »

Offline
*
Re: Change Maine PHP version thru PHP selector or PHP Switcher?
« Reply #5 on: March 04, 2020, 07:00:35 AM »
I have sent you the login to my server before. Do you have time to take a look?

Offline
*****
Re: Change Maine PHP version thru PHP selector or PHP Switcher?
« Reply #6 on: March 04, 2020, 09:35:24 AM »
php 7 needs at-least 1.5 gb for the build.

Offline
***
Re: Change Maine PHP version thru PHP selector or PHP Switcher?
« Reply #7 on: March 04, 2020, 11:53:36 AM »
php 7 needs at-least 1.5 gb for the build.

Yea I had the same problem.  I had to shut down a lot of services like apache that were running.  Once I did that bam it was finished.