Author Topic: API - Slim application error add account  (Read 6527 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
API - Slim application error add account
« on: March 04, 2020, 06:05:43 PM »
hi, I have this error:
Slim Application Error

The application could not run because of the following error:
Details
Type: ErrorException
Code: 8
Message: Trying to get property of non-object
File: /usr/local/cwpsrv/var/services/api/v1/index.php
Trace

#0 /usr/local/cwpsrv/var/services/api/v1/index.php(0): Slim\Slim::handleErrors(8, 'Trying to get p...', '/usr/local/cwps...', 0, Array)
#1 [internal function]: {closure}()
#2 /usr/local/cwpsrv/var/services/api/v1/Slim/Route.php(0): call_user_func_array(Object(Closure), Array)
#3 /usr/local/cwpsrv/var/services/api/v1/Slim/Slim.php(0): Slim\Route->dispatch()
#4 /usr/local/cwpsrv/var/services/api/v1/Slim/Middleware/Flash.php(0): Slim\Slim->call()
#5 /usr/local/cwpsrv/var/services/api/v1/Slim/Middleware/MethodOverride.php(0): Slim\Middleware\Flash->call()
#6 /usr/local/cwpsrv/var/services/api/v1/Slim/Middleware/PrettyExceptions.php(0): Slim\Middleware\MethodOverride->call()
#7 /usr/local/cwpsrv/var/services/api/v1/Slim/Slim.php(0): Slim\Middleware\PrettyExceptions->call()
#8 /usr/local/cwpsrv/var/services/api/v1/index.php(0): Slim\Slim->run()
#9 {main}

and sending this info

$data = array(
    "key" => "asdadasdadasdasdasdas",
    "action"=>"add",
    "domain"=>"rufus.com",
    "user"=>"rufus",
    "pass"=>"PASSWORD123",
    "email"=>"email@account",
    "package"=>"basic",
    "inode"=>"0",
    "limit_nproc"=>"40",
    "limit_nofile"=>"0",
    "server_ips"=>"xx.xx.xx.xx"
);

this ip and the key are hiding for this post

any help???? why????, thank you
« Last Edit: March 04, 2020, 06:07:25 PM by omarruben »

Offline
*
Re: API - Slim application error add account
« Reply #1 on: March 04, 2020, 06:55:16 PM »
Are you sending with GET or POST?

Offline
*
Re: API - Slim application error add account
« Reply #2 on: March 04, 2020, 07:12:40 PM »
i am sendind POST


when I ask for a list of accounts everything works fine, the problem is on ADD


Offline
*
Re: API - Slim application error add account
« Reply #3 on: March 04, 2020, 07:52:40 PM »
It is possible that the package name is misspelled or does not exist, you can also use the package id and you should not have this problem

Offline
*
Re: API - Slim application error add account
« Reply #4 on: March 05, 2020, 12:28:14 AM »
yes, the problem is the Package name, it works with the id number of the package... is this a bug?
thank you !!!