Author Topic: how to force https on rouncube webmail  (Read 813 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
how to force https on rouncube webmail
« on: March 20, 2020, 01:04:16 AM »
Hello guys, I installed CWP and loving it, but got some issues with forcing https on my site so my questions are simple:
1-how to force https on all my domains without using the .htaccess file, is there any better way?
2-do i have to request a new letsencrypt SSL for each domain and subdomain i created?  cant it be shared?
3-how to properly force https on roundcube webmail? lets encrypted is installed however if i typed http://webmail.domainname.com it doesnt redirect to https, so need this to be working.
thats all for now. thanks in advanced.
cheers

Offline
*
Re: how to force https on rouncube webmail
« Reply #1 on: March 20, 2020, 02:28:47 AM »
U need to edit the apache template and regenerate the vhosts for Server wide ssl for your Domains.

Cant give you an example howto do but maybe another Person :)

Offline
*
Re: how to force https on rouncube webmail
« Reply #2 on: July 06, 2020, 12:00:19 AM »
Im having trouble getting my webmail to force https as well. My webmail domain sits at mydomain.com/webmail. I have tried editing the .htaccess (works for the main domain but not the /webmail). Also edited the webmail.conf located at /usr/local/cwpsrv/conf.d/webmail.conf with the following code :

Code: [Select]
return 301 https://$host:2096$request_uri;
Nothing seems to be working. Anyone figure this out yet?

Offline
*****
Re: how to force https on rouncube webmail
« Reply #3 on: July 06, 2020, 11:08:58 AM »
Hi,

The most practical way to force webmail to secure mode for all user accounts is to apply the nginx force-https template in WebServers Settings -> WebServers Master Conf or only for specific users in WebServers Domain Conf.