Author Topic: Can not switch php version  (Read 2773 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Can not switch php version
« on: March 25, 2020, 04:17:46 AM »
i can not switch php version to 7.3.x

i'm trying many time in PHP Versiopn Switcher menu, but it can not apply

Offline
**
Re: Can not switch php version
« Reply #1 on: March 25, 2020, 08:52:53 AM »
I have the same issue and reported to CWP team. They said they are looking into this issue and will be resolved in very next version.

Offline
***
Re: Can not switch php version
« Reply #2 on: March 25, 2020, 05:42:09 PM »
Just tried it on my NATed experiment.
Worked fine, once PHP was recompiled (which took about 10 minutes).
Code: [Select]
PHP Version 7.3.16
System Linux cwp.xxxx.com 3.10.0-1062.12.1.el7.x86_64 #1 SMP Tue Feb 4 23:02:59 UTC 2020 x86_64
Build Date Mar 25 2020 17:25:17

CWP version: 0.9.8.952
Running a server/VPS means YOU take responsibility to learn how to do it properly. If you can't manage, buy shared hosting.
Private messages asking for unpaid help may be ignored.

Offline
*
Re: Can not switch php version
« Reply #3 on: March 26, 2020, 02:19:08 AM »
if cwp dont update for this, maybe i should change to use openlitespeed cyberpanel, it faster

Offline
*
Re: Can not switch php version
« Reply #4 on: March 26, 2020, 09:36:47 AM »
EPEL and Remi repositories already have php versions.
Why on earth is CWP team re-building every single PHP with all those extensions?
This, I can not understand...

Code: [Select]
yum install https://dl.fedoraproject.org/pub/epel/epel-release-latest-7.noarch.rpm
yum install http://rpms.remirepo.net/enterprise/remi-release-7.rpm
yum install yum-utils
yum-config-manager --enable remi-php70
yum-config-manager --enable remi-php71
yum-config-manager --enable remi-php72
yum-config-manager --enable remi-php73
yum install php php-mcrypt php-cli php-gd php-curl php-mysql php-ldap php-zip php-fileinfo php-...

Offline
***
Re: Can not switch php version
« Reply #5 on: March 26, 2020, 10:16:22 AM »
if cwp dont update for this, maybe i should change to use openlitespeed cyberpanel, it faster
Close the door on your way out.  :-*
Running a server/VPS means YOU take responsibility to learn how to do it properly. If you can't manage, buy shared hosting.
Private messages asking for unpaid help may be ignored.

Offline
***
Re: Can not switch php version
« Reply #6 on: March 26, 2020, 10:18:25 AM »
Why on earth is CWP team re-building every single PHP with all those extensions?
This, I can not understand...
Be thankful that it isn't like some panels eg. DirectAdmin, that recompile ("custombuild") for nearly all changes.  ;)
During the initial install, ccache should be installed by default - it does help.
Not everyone wants the same php modules/extensions, so compiling php does make some sense, for example LDAP - never used it. (Same goes for Apache, where dav isn't required for OwnCloud/NextCloud.)
« Last Edit: March 26, 2020, 10:34:03 AM by ejsolutions »
Running a server/VPS means YOU take responsibility to learn how to do it properly. If you can't manage, buy shared hosting.
Private messages asking for unpaid help may be ignored.

Offline
***
Re: Can not switch php version
« Reply #7 on: March 26, 2020, 10:32:25 AM »
Admittedly, it's not very clear what's going on because once you Save & Build, it looks like nothing has happened.
You need to scroll down..
Quote
PHP Compiler Started in Background. You can monitor PHP rebuild from the console using command: tail -f /var/log/php-rebuild.log
Go the the Dashboard and you should notice Load has risen, as well as cc1 showing in the process list. (This is not difficult stuff, guys but so many people need hand-holding these days  ::)).

Appendix: PHP 7.3.16 switched successfully on CWP Pro VM - took 15 minutes.
« Last Edit: March 26, 2020, 10:42:18 AM by ejsolutions »
Running a server/VPS means YOU take responsibility to learn how to do it properly. If you can't manage, buy shared hosting.
Private messages asking for unpaid help may be ignored.

Offline
*
Re: Can not switch php version
« Reply #8 on: March 26, 2020, 11:56:26 AM »
There are 3 PHP upgrade stuff going on!
Why is there so much PHP stuff anyways:

  • PHP Version Switcher v2
  • PHP Selector v2
  • PHP-FPM Selector

Offline
***
Re: Can not switch php version
« Reply #9 on: March 26, 2020, 12:15:03 PM »
There are 3 PHP upgrade stuff going on!
Why is there so much PHP stuff anyways:
  • PHP Version Switcher v2 - system-wide (and user accounts for free CWP)
  • PHP Selector v2 - CWP Pro only, for individual user accounts
  • PHP-FPM Selector - different, newer PHP mode
Simples. ;)
Running a server/VPS means YOU take responsibility to learn how to do it properly. If you can't manage, buy shared hosting.
Private messages asking for unpaid help may be ignored.