Author Topic: Let's encrypt for CWP Panel at TLD:2031 is not working as also for webmail.xxx  (Read 967 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
Hi Dear Colleagues

I've installed CWP (Centos 7) at May 2018 and just a few time after that, Let's Encrypt was added to CWP as main SSL automation & certification, what was supposed to cover also CWP Panel TLD:2031 url as also urls like:
cpanel.mydomain.com
webmail.mydomain.com
as also for customer accounts domains.

Nowadays i've CWP Premium version but never ever got CWP Panel TLD:2031 running with a Let's encrypt valid certificate, rather than the self-signed sll certificate that Chrome always complains that is no safety...

I am managing Linux Servers for more than 25 years and everytime that something goes wrong i go to the documentations, foruns etc and search for possible solutions and try to use it what works most of the time.

At the same way if i try to access... mydomain.com/webmail it works with the respectively LET's encrypt certificate for this domain, as also for the other domains being hosted at the same server. But if i try to access webmail.mydomain.com is uses the self-signed SSL certificate what is considered not safety obviously.

At the end... many times that i've tried to uses or recommend customers to use auto detect in Thunderbird email setup for their accounts for example sales@mycustomersdomain.com it recognizes the imap.mycustomersdomain.com & smtp.mycustomersdomain.com but at the first time the i've try to receive & send messages is necessary to accept the certificate as not matching the email server certificate... What causes me surprise, once SNI came to cover this topic, i suppose considering what 'ive read about it.

My CWP panel since 2018 does not works with LE SSL even after exchange many emails with CWP Support.
My CWP standards subdomain for services like webmail, cpanel etc does not work with LE SSL as also
and my emails accounts for customer always ends up using my hostname rather the imap.customerdomain.com as IMAP and SMTP server once LE SSL are configured in postfix + dovecot regarding the LE SSL certificates for domain of the server host, like

My Server that holds CWP
  vps.mydomain.com
        clientnumber1.com
            imap.clientnumber1.com

Indeed what really only works fine are the LE SSL for the websites for each domain.

Best regards and thanks in advance for those that could intend to help in this challenge!