Author Topic: 2 issues with permalink and ssl  (Read 1941 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
2 issues with permalink and ssl
« on: March 28, 2020, 09:27:38 PM »
Hello, i have cwp installed and configured. I also made free ssl within the cwp panel.

1) I tried to make an account and installed wordpress in it. Everything works fine, and if i try to go to my domain i can normally go, but when i enter wordpress panel, instead of giving me mydomain.url it goes to my cwp hostname/~mydomain/wp-login and the same happens when i try to use permalink for articles...

2)another weird thing is that if i go to the url mydomaing.url it says it's not secure, but when i get redirected in the hostname/~mydomain that is seen as secure.

what's wrong? please help me.Thanks
« Last Edit: March 28, 2020, 09:29:48 PM by rita1989 »

Offline
***
Re: 2 issues with permalink and ssl
« Reply #1 on: March 28, 2020, 09:36:53 PM »
When you first setup WordPress, you did so from hostname/~user

Log into WordPress admin and update the website url

Change WordPress URL in Admin Dashboard
The first and most common method is to change your WordPress URL directly from within the admin dashboard. On the left-hand side, under “Settings,” click into “General.” You can then update the following:

WordPress Address (URL): The address to reach your blog.
Site Address (URL): The address of your WordPress core files.
Both should match unless you are giving WordPress it’s own directory. Remember that after you click “Save Changes,” your WordPress dashboard is now only accessible via the new URL.


As for your ssl issue.  You have a valid cert for your hostname, but not for your domain.  Make sure you get a cert via autossl in the cwp panel for the domain. (most likely set to self generated atm)
« Last Edit: March 28, 2020, 09:44:55 PM by rcschaff »
Google Hangouts:  rcschaff82@gmail.com

Offline
*
Re: 2 issues with permalink and ssl
« Reply #2 on: March 29, 2020, 12:45:30 PM »
thanks for your help!
i followed your suggests and fixed the wordpress issue.

but i can't fix the second one, actually if i try to reinstall it says it's already installed but if i go with my browser it says not secure.



Offline
*****
Re: 2 issues with permalink and ssl
« Reply #3 on: March 30, 2020, 11:18:12 AM »
check the sans are correct

Offline
***
Re: 2 issues with permalink and ssl
« Reply #4 on: March 31, 2020, 12:06:14 AM »
thanks for your help!
i followed your suggests and fixed the wordpress issue.

but i can't fix the second one, actually if i try to reinstall it says it's already installed but if i go with my browser it says not secure.


If you click that "Admin Services" buton, and select at least one, it will grab a cert from letsencrypt.
Google Hangouts:  rcschaff82@gmail.com

Offline
*
Re: 2 issues with permalink and ssl
« Reply #5 on: April 01, 2020, 03:56:24 PM »
thanks for your help!
i followed your suggests and fixed the wordpress issue.

but i can't fix the second one, actually if i try to reinstall it says it's already installed but if i go with my browser it says not secure.


If you click that "Admin Services" buton, and select at least one, it will grab a cert from letsencrypt.

i've done that, added ftp and says signed by let's encrypt but if i open the page in google chrome it still says not secure and gives me this error NET::ERR_CERT_INVALID

what's wrong?