Author Topic: SSI support in latest versions  (Read 1769 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
SSI support in latest versions
« on: March 13, 2020, 04:29:14 PM »
I have several servers with CWP. Some of them I unstalled 1 year ago. But i have 2 new servers with cwp, where i have installed 0.9.8.950. Old server already updated to 0.9.8.950
The same site runs on the old server, but not on the new.
Error log:
Code: [Select]
public_html/.htaccess: Invalid command 'SSILegacyExprParser', perhaps misspelled or defined by a module not included in the server configuration, referer:.htaccess:
Code: [Select]
SSILegacyExprParser on
AddType text/html .shtml
AddHandler server-parsed .shtml
Options Indexes SymLinksIfOwnerMatch Includes
AddHandler server-parsed .html .htm

RewriteEngine on
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME}\.html -f
RewriteRule ^(.*)$ $1.html

Offline
*****
Re: SSI support in latest versions
« Reply #1 on: March 13, 2020, 04:46:13 PM »
hi whats the apache version on new server and old server ?

Offline
*
Re: SSI support in latest versions
« Reply #2 on: March 13, 2020, 05:26:37 PM »
hi whats the apache version on new server and old server ?
Apache version: Apache/2.4.39
On the new server I downgraded to Apache/2.4.29, no changes.
With LiteSpeed Enterprise it works fine, but I need Apache

Offline
*****
Re: SSI support in latest versions
« Reply #3 on: March 15, 2020, 09:07:04 AM »
you should remove
SSILegacyExprParser from htacces and check

Offline
*
Re: SSI support in latest versions
« Reply #4 on: March 17, 2020, 06:17:04 PM »
With LiteSpeed Enterprise:
https://imgur.com/hI6PMyD
With Apache without SSILegacyExprParser in htacces
https://imgur.com/OhFhEjV

Offline
*****
Re: SSI support in latest versions
« Reply #5 on: March 18, 2020, 06:11:08 AM »
check that "mod_include" is enabled on your apache config