Author Topic: 408 HTTP error  (Read 452 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
408 HTTP error
« on: April 24, 2020, 12:42:52 PM »
Hello,

I have installed SWP pro, and I am using on one of my sites wordpress. I have updated the PHP limits, so I can upload themes and big files.

When I try to upload a theme through wordpress, I receive 408 error. I'm not sure how I can fix it, I checked on my side and I have fast connection, so I don't think the issue is coming from my side.

Can you please help me solve this issue.

Thanks

Offline
***
Re: 408 HTTP error
« Reply #1 on: April 24, 2020, 01:14:44 PM »
It could be timing out because it can't write to the temp directory.  What size file are you trying to upload?
Google Hangouts:  rcschaff82@gmail.com

Offline
*
Re: 408 HTTP error
« Reply #2 on: April 25, 2020, 10:38:12 AM »
I am trying to upload file size 14MB

Offline
***
Re: 408 HTTP error
« Reply #3 on: April 25, 2020, 10:40:51 AM »
Then there should be no reason with a descent internet connection that it should fail.  Check your PHP log to see if there are write errors for anything.

CWP /usr/local/cwpsrv/log/error_log
Accts  /usr/local/apach/domlogs
Google Hangouts:  rcschaff82@gmail.com

Offline
*
Re: 408 HTTP error
« Reply #4 on: April 25, 2020, 04:17:18 PM »
I have emptied the log and I just checked again now and I found this error in (Accts  /usr/local/apach/domlogs)

95.91.213.140 - - [25/Apr/2020:12:14:36 -0400] "POST /wp-admin/admin-ajax.php HTTP/1.1" 200 47 "http://uxiology.com/wp-admin/theme-install.php?browse=featured" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/81.0.4044.122 Safari/537.36"

95.91.213.140 - - [25/Apr/2020:12:14:44 -0400] "POST /wp-admin/update.php?action=upload-theme HTTP/1.1" 408 221 "http://uxiology.com/wp-admin/theme-install.php?browse=featured" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/81.0.4044.122 Safari/537.36"


Offline
***
Re: 408 HTTP error
« Reply #5 on: April 25, 2020, 04:32:33 PM »
You don't happen to have modsecurity enabled by chance?
Google Hangouts:  rcschaff82@gmail.com

Offline
*
Re: 408 HTTP error
« Reply #6 on: April 25, 2020, 06:24:46 PM »
I have just uninstalled Modsecurity.

I tried again and I get this error in log:
95.91.213.140 - - [25/Apr/2020:14:19:51 -0400] "POST /wp-admin/update.php?action=upload-theme HTTP/1.1" 500 535 "http://uxiology.com/wp-admin/theme-install.php?browse=featured" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/81.0.4044.122 Safari/537.36"


Offline
***
Re: 408 HTTP error
« Reply #7 on: April 25, 2020, 06:47:26 PM »
Something is left over from ModSecurity.  I didn't necessarily want you to uninstall it, but there should be a log file or a debug file you could look at to see if it was stopping the upload.
Google Hangouts:  rcschaff82@gmail.com