Author Topic: My server doesn't make backups anymore  (Read 1849 times)

0 Members and 1 Guest are viewing this topic.

Offline
*
My server doesn't make backups anymore
« on: April 23, 2020, 01:30:05 PM »
Hi there,

I'm having some troubles figuring out what's going on with my backups. My CWP7 backups were working just fine, but I found out (the worst way possible) It wasn't making backups anymore since March 3th or 6th.

I'd tryied disabling and enabling again backups for an account, to see if somehow it restarted the configuration. But it didn't make any difference at all.

Do you know what could be the problem? or at least how can I find out? I'm a little bit lost here.

Thanks in advance,
Andrés

Offline
*
Re: My server doesn't make backups anymore
« Reply #1 on: April 26, 2020, 08:56:48 AM »
I have the same problem.

Someone with a solution?

Offline
***
Re: My server doesn't make backups anymore
« Reply #2 on: April 26, 2020, 12:05:26 PM »
Troubleshooting Steps:
Log in via SSH as root
crontab -l
(You Should see "/usr/local/cwp/php71/bin/php-cgi -d max_execution_time=10000000 -q /usr/local/cwpsrv/htdocs/resources/admin/include/{Whichever backup}")

test by removing the "-q" from the command.  (EX of new backup)
/usr/local/cwp/php71/bin/php-cgi -d max_execution_time=10000000  /usr/local/cwpsrv/htdocs/resources/admin/include/cron_newbackup.php

If you don't receive any errors, then it should be working.  IF your recieve an error about ioncube, there are at least 10 topics on the forum about how to fix that issue recently.  It involves manually updating your cwp files, as something failed in the last update.
Google Hangouts:  rcschaff82@gmail.com

Offline
*
Re: My server doesn't make backups anymore
« Reply #3 on: April 26, 2020, 12:26:01 PM »
What if it shows this error? Hahahaha

Code: [Select]
[root@centosweb ~]# /usr/local/cwp/php71/bin/php-cgi -d max_execution_time=10000000 -q /usr/local/cwpsrv/htdocs/rerces/admin/include/cron_newbackup.php
PHP Warning:  count(): Parameter must be an array or an object that implements Countable in /usr/local/cwpsrv/htdoresources/admin/addons/class_backupmanager.php on line 0
PHP Warning:  count(): Parameter must be an array or an object that implements Countable in /usr/local/cwpsrv/htdoresources/admin/addons/class_backupmanager.php on line 0
You have new mail in /var/spool/mail/root

I've already reported it to the CWP team, see what happens to the backup system now.

Offline
***
Re: My server doesn't make backups anymore
« Reply #4 on: April 26, 2020, 12:27:47 PM »
That's a new one lol.  Definately open a ticket on that one :)

Thought thinking about it. Try deleteing the schedule in CWP and recreating it, and see if it fixes the issue.
Google Hangouts:  rcschaff82@gmail.com

Offline
*
Re: My server doesn't make backups anymore
« Reply #5 on: April 26, 2020, 12:58:39 PM »
The problem is not in cron.
I have the same mistake.

Offline
***
Re: My server doesn't make backups anymore
« Reply #6 on: April 26, 2020, 01:05:29 PM »
The problem is not in cron.
I have the same mistake.

Understood.  Was making sure you didn't have an old version of the script encoded in ioncube5 still residing on the server, and couldn't be run by 7.2.  There's been quite a few people who's updates failed and old php files reside on their server after the update to 926.

As I said, I"m on .926 running 7.2, and everything is working perfectly fine for me that I notice.  So need to "Troubleshoot" what's going on so they can issue a patch.
Google Hangouts:  rcschaff82@gmail.com

Offline
***
Re: My server doesn't make backups anymore
« Reply #7 on: April 26, 2020, 01:10:53 PM »
Try starting the backup, and run tail -f /var/log/cwp/cron_backup.log
Google Hangouts:  rcschaff82@gmail.com

Offline
***
Re: My server doesn't make backups anymore
« Reply #8 on: April 26, 2020, 01:29:12 PM »
I guess I spoke too soon. Friday didn't run.   Apparently the new backup can't get a list of accounts to backup, as that's where it's stuck...
Google Hangouts:  rcschaff82@gmail.com

Offline
*
Re: My server doesn't make backups anymore
« Reply #9 on: April 26, 2020, 01:40:03 PM »
I have the same problem.

backup not working for about 1 week

Offline
*****
Re: My server doesn't make backups anymore
« Reply #10 on: April 26, 2020, 05:04:01 PM »
we're working on it.

Offline
*
Re: My server doesn't make backups anymore
« Reply #11 on: April 26, 2020, 09:31:07 PM »
We are looking forward..

Offline
*
Re: My server doesn't make backups anymore
« Reply #12 on: April 26, 2020, 11:31:32 PM »
Just installed latest update and new backup still doesn't work.

Offline
*
Re: My server doesn't make backups anymore
« Reply #13 on: April 27, 2020, 03:07:33 PM »
Has there been any advancements on this issue? My backups are still not working. Thank you.

Offline
*
Re: My server doesn't make backups anymore
« Reply #14 on: April 27, 2020, 04:17:44 PM »
I have an open ticket on this "Urgent" problem and I'm not getting any answers at the moment.